DualShock 4 over Bluetooth does not work

Bug #1849993 reported by Lastique on 2019-10-26
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Connecting Sony DualShock 4 over Bluetooth does not work on kernel 5.3. After pressing the PS button on the gamepad, the LED blinks for a few seconds while connecting and then stays constantly lit when Bluetooth connection is established. However, while "connected", lsusb doesn't show the gamepad and it doesn't work in games.

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: linux-image-lowlatency 5.3.0.19.22
ProcVersionSignature: Ubuntu 5.3.0-19.20-lowlatency 5.3.1
Uname: Linux 5.3.0-19-lowlatency x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu8
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC3: lastique 2092 F.... pulseaudio
 /dev/snd/controlC0: lastique 2092 F.... pulseaudio
 /dev/snd/controlC2: lastique 2092 F.... pulseaudio
 /dev/snd/controlC1: lastique 2092 F.... pulseaudio
CurrentDesktop: KDE
Date: Sat Oct 26 23:55:45 2019
HibernationDevice:
 # Prevents "gave up waiting for suspend/resume device" timeout on boot
 RESUME=none
InstallationDate: Installed on 2015-05-01 (1639 days ago)
InstallationMedia: Kubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
MachineType: System manufacturer System Product Name
ProcFB: 0 EFI VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-19-lowlatency root=UUID=a03f1835-52f9-4409-9da7-fe45770637ae ro quiet splash nomdmonddf nomdmonisw vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-5.3.0-19-lowlatency N/A
 linux-backports-modules-5.3.0-19-lowlatency N/A
 linux-firmware 1.183.1
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to eoan on 2019-10-26 (0 days ago)
dmi.bios.date: 11/09/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 3603
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P8Z68-V PRO
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr3603:bd11/09/2012:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP8Z68-VPRO:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: System Product Name
dmi.product.sku: SKU
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Lastique (andysem) wrote :
Lastique (andysem) wrote :

The problem exists in the mainline kernel 5.3.7 and does NOT exist with 5.2.21. I cannot test 5.4-rc4 because Nvidia driver doesn't compile for this kernel.

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Lastique (andysem) wrote :

Upon connecting the gamepad, kern.log contains the following lines:

Nov 3 12:03:00 lastique-pc kernel: [ 189.682027] sony 0005:054C:05C4.0009: unknown main item tag 0x0
Nov 3 12:03:00 lastique-pc kernel: [ 189.682133] sony 0005:054C:05C4.0009: DualShock 4 calibration report's CRC check failed, received crc 0x0 != 0x2666b240
Nov 3 12:03:00 lastique-pc kernel: [ 189.682135] sony 0005:054C:05C4.0009: Retrying DualShock 4 get calibration report request
Nov 3 12:03:00 lastique-pc kernel: [ 189.682137] sony 0005:054C:05C4.0009: DualShock 4 calibration report's CRC check failed, received crc 0x0 != 0x2666b240
Nov 3 12:03:00 lastique-pc kernel: [ 189.682138] sony 0005:054C:05C4.0009: Retrying DualShock 4 get calibration report request
Nov 3 12:03:00 lastique-pc kernel: [ 189.682142] sony 0005:054C:05C4.0009: DualShock 4 calibration report's CRC check failed, received crc 0x0 != 0x2666b240
Nov 3 12:03:00 lastique-pc kernel: [ 189.682144] sony 0005:054C:05C4.0009: Failed to get calibration data from Dualshock 4
Nov 3 12:03:00 lastique-pc kernel: [ 189.682212] sony 0005:054C:05C4.0009: hidraw8: BLUETOOTH HID v81.00 Gamepad [Wireless Controller] on 5c:f3:70:69:51:4e
Nov 3 12:03:00 lastique-pc kernel: [ 189.682214] sony 0005:054C:05C4.0009: failed to claim input

Lastique (andysem) wrote :

Possible upstream bug: https://bugzilla.kernel.org/show_bug.cgi?id=204877

The bug contains a link with a fix. Please, backport.

Lastique (andysem) wrote :

I can confirm that the patch[1] in the upstream bug indeed fixes the problem for me.

[1]: https://git.kernel.org/pub/scm/linux/kernel/git/bluetooth/bluetooth-next.git/commit/?id=8bb3537095f107ed55ad51f6241165b397aaafac

Lastique (andysem) wrote :

The bug is still present in 5.3.0-22.

tags: added: rls-ee-incoming
Lastique (andysem) wrote :

Fixed in 5.3.0-24.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.