Touchpad most times not working after reboot on Asus ZenBook Pro 14 UX480 & Ubuntu 19.10

Bug #1849442 reported by Daniel on 2019-10-23

This bug report will be marked for expiration in 15 days if no further activity occurs. (find out why)

8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

General System Information:

I have an »Asus ZenBook Pro 14 UX480« notebook and installed »Ubuntu 19.10«. No dual boot.

What I expected to happen:

The touchpad should work.

What happened instead

The touchpad was working after the fresh installation. However after the first reboot it did not respond. After the next reboot it worked again. Now it will work after every 10th reboot, all other times it wont.

Using an external mouse via USB is working.

The touchpad was not working at all in Ubuntu 18.04 and 19.04.

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: linux-image-5.3.0-19-generic 5.3.0-19.20
ProcVersionSignature: Ubuntu 5.3.0-19.20-generic 5.3.1
Uname: Linux 5.3.0-19-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu8
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dan 1767 F.... pulseaudio
 /dev/snd/controlC1: dan 1767 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Wed Oct 23 09:50:26 2019
InstallationDate: Installed on 2019-10-17 (5 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 13d3:56cb IMC Networks USB2.0 HD IR UVC WebCam
 Bus 001 Device 004: ID 8087:0aaa Intel Corp.
 Bus 001 Device 002: ID 062a:4101 MosArt Semiconductor Corp. Wireless Keyboard/Mouse
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: ASUSTeK COMPUTER INC. ZenBook Pro 14 UX450FDX_UX480FD
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.3.0-19-generic root=/dev/mapper/vgubuntu-root ro
RelatedPackageVersions:
 linux-restricted-modules-5.3.0-19-generic N/A
 linux-backports-modules-5.3.0-19-generic N/A
 linux-firmware 1.183
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/09/2018
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: UX450FDX.301
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: UX450FDX
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrUX450FDX.301:bd10/09/2018:svnASUSTeKCOMPUTERINC.:pnZenBookPro14UX450FDX_UX480FD:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnUX450FDX:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.family: ZenBook Pro
dmi.product.name: ZenBook Pro 14 UX450FDX_UX480FD
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Daniel (hurley42) wrote :
summary: - Touchpad on Asus ZenBook Pro 14 UX480 & Ubuntu 19.10 most times not
- working after reboot
+ Touchpad most times not working after reboot on Asus ZenBook Pro 14
+ UX480 & Ubuntu 19.10
Daniel (hurley42) wrote :

I tried this commands, as suggested in several boards:

> sudo rmmod i2c_hid
> sudo modprobe i2c_hid

This worked once only. Never again later.

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Daniel (hurley42) wrote :

When the laptop wakes up from hibernation the touchpad will start working again.

You-Sheng Yang (vicamo) wrote :

Could you boot with "i2c_hid.debug=1 hid.debug=1" and paste dmesg again?

Daniel (hurley42) wrote :

Hey, interesting observation: When I add these debug option, then the touchpad will work right away more often than without (1 of 9 boots was not working, whereas before it was almost every second boot).

Daniel (hurley42) wrote :

For comparison, this is the log if the touchpad is working right away

Daniel (hurley42) wrote :

Another observation: When the touchpad is not working after booting the notebook, and I will pause (hibernation) and then wake up the notebook again, then the touchpad will work consistently.

Kai-Heng Feng (kaihengfeng) wrote :
Po-Hsu Lin (cypressyew) wrote :

Mark as Incomplete for comment #9, please feel free to change the status after the test.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers