iwlwifi - repeated kernel OOPS when wifi turned on

Bug #1848857 reported by Alberto Donato on 2019-10-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

On a fresh 19.10 install, I get repeated (every ~10s) kernel backtraces when wifi is enabled

This is an example of the trace:

[ 3963.367576] iwlwifi 0000:04:00.0: Failed to get geographic profile info -5
[ 3963.367591] ------------[ cut here ]------------
[ 3963.367660] WARNING: CPU: 3 PID: 27181 at drivers/net/wireless/intel/iwlwifi/mvm/scan.c:1874 iwl_mvm_rx_umac_scan_complete_notif.cold+0xc/0x13 [iwlmvm]
[ 3963.367662] Modules linked in: unix_diag rfcomm scsi_transport_iscsi binfmt_misc veth ccm xt_comment dummy xt_CHECKSUM xt_MASQUERADE xt_conntrack ipt_REJECT nf_reject_ipv4 xt_tcpudp ip6table_mangle ip6table_nat iptable_mangle iptable_nat nf_nat nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 nf_tables nfnetlink ip6table_filter ip6_tables iptable_filter bpfilter bridge stp llc aufs overlay cmac bnep nls_iso8859_1 intel_rapl_m
sr mei_hdcp snd_soc_skl snd_soc_hdac_hda snd_hda_ext_core snd_soc_skl_ipc snd_soc_sst_ipc snd_soc_sst_dsp snd_soc_acpi_intel_match snd_soc_acpi snd_hda_codec_hdmi snd_soc_core snd_compress ac97_bus snd_pcm_dmaengine snd_hda_codec_realtek snd_usb_audio snd_hda_codec_generic snd_usbmidi_lib snd_hda_intel snd_seq_midi snd_hda_codec snd_seq_midi_event snd_hda_core snd_hwdep snd_pcm intel_rapl_common x86_pkg_temp_thermal intel_
powerclamp snd_rawmidi iwlmvm coretemp snd_seq mac80211 kvm_intel libarc4 kvm iwlwifi irqbypass snd_seq_device intel_cstate intel_rapl_perf snd_timer
[ 3963.367710] thinkpad_acpi serio_raw cfg80211 nvram uvcvideo wmi_bmof btusb videobuf2_vmalloc joydev rtsx_pci_ms mei_me ledtrig_audio memstick input_leds mei btrtl videobuf2_memops intel_pch_thermal btbcm videobuf2_v4l2 btintel videobuf2_common bluetooth videodev mc snd ecdh_generic ecc intel_xhci_usb_role_switch roles soundcore mac_hid sch_fq_codel parport_pc ppdev lp parport ip_tables x_tables autofs4 btrfs xor zstd_c
ompress raid6_pq libcrc32c dm_crypt hid_lenovo hid_generic usbhid hid crct10dif_pclmul crc32_pclmul ghash_clmulni_intel i915 aesni_intel aes_x86_64 crypto_simd i2c_algo_bit ahci rtsx_pci_sdmmc libahci drm_kms_helper cryptd glue_helper syscopyarea sysfillrect sysimgblt fb_sys_fops psmouse e1000e drm i2c_i801 rtsx_pci wmi video
[ 3963.367764] CPU: 3 PID: 27181 Comm: kworker/3:0 Tainted: G W 5.3.0-18-generic #19-Ubuntu
[ 3963.367766] Hardware name: LENOVO 20F6CTO1WW/20F6CTO1WW, BIOS R02ET71W (1.44 ) 05/08/2019
[ 3963.367782] Workqueue: events iwl_mvm_async_handlers_wk [iwlmvm]
[ 3963.367806] RIP: 0010:iwl_mvm_rx_umac_scan_complete_notif.cold+0xc/0x13 [iwlmvm]
[ 3963.367810] Code: 48 c7 c7 00 19 ea c0 e8 df 7c e7 ec 0f 0b 49 8b 47 10 44 8b a0 9c 00 00 00 e9 a2 3e fe ff 48 c7 c7 00 19 ea c0 e8 c1 7c e7 ec <0f> 0b e9 dc 43 fe ff 48 c7 c7 00 19 ea c0 e8 ae 7c e7 ec 0f 0b 41
[ 3963.367813] RSP: 0018:ffffb5498370bdd0 EFLAGS: 00010246
[ 3963.367816] RAX: 0000000000000024 RBX: ffff967ee2199040 RCX: 0000000000000006
[ 3963.367818] RDX: 0000000000000000 RSI: 0000000000000082 RDI: ffff9681b1397440
[ 3963.367820] RBP: ffffb5498370be08 R08: 0000000000000729 R09: 0000000000000004
[ 3963.367822] R10: 0000000000000000 R11: 0000000000000001 R12: ffffb5498370be20
[ 3963.367823] R13: ffff9681a5049e28 R14: 0000000000000000 R15: ffff9681755c3b00
[ 3963.367826] FS: 0000000000000000(0000) GS:ffff9681b1380000(0000) knlGS:0000000000000000
[ 3963.367829] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 3963.367831] CR2: 000008e554b32000 CR3: 000000037a00a001 CR4: 00000000003606e0
[ 3963.367833] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[ 3963.367835] DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
[ 3963.367837] Call Trace:
[ 3963.367853] iwl_mvm_async_handlers_wk+0xb0/0x140 [iwlmvm]
[ 3963.367859] process_one_work+0x1db/0x380
[ 3963.367863] worker_thread+0x4d/0x400
[ 3963.367869] kthread+0x104/0x140
[ 3963.367873] ? process_one_work+0x380/0x380
[ 3963.367878] ? kthread_park+0x80/0x80
[ 3963.367884] ret_from_fork+0x35/0x40
[ 3963.367889] ---[ end trace d7c13f3a9f33f0d0 ]---
[ 3963.941981] iwlwifi 0000:04:00.0: Applying debug destination EXTERNAL_DRAM
[ 3964.090765] iwlwifi 0000:04:00.0: Applying debug destination EXTERNAL_DRAM
[ 3964.173015] iwlwifi 0000:04:00.0: FW already configured (0) - re-configuring

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: linux-image-generic 5.3.0.18.21
ProcVersionSignature: Ubuntu 5.3.0-18.19-generic 5.3.1
Uname: Linux 5.3.0-18-generic x86_64
ApportVersion: 2.20.11-0ubuntu8
Architecture: amd64
CurrentDesktop: GNOME
Date: Sat Oct 19 16:37:59 2019
InstallationDate: Installed on 2019-10-19 (0 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
MachineType: LENOVO 20F6CTO1WW
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.3.0-18-generic root=/dev/mapper/ubuntu-root ro rootflags=subvol=@ quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-5.3.0-18-generic N/A
 linux-backports-modules-5.3.0-18-generic N/A
 linux-firmware 1.183
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/08/2019
dmi.bios.vendor: LENOVO
dmi.bios.version: R02ET71W (1.44 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20F6CTO1WW
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrR02ET71W(1.44):bd05/08/2019:svnLENOVO:pn20F6CTO1WW:pvrThinkPadX260:rvnLENOVO:rn20F6CTO1WW:rvrNotDefined:cvnLENOVO:ct10:cvrNone:
dmi.product.family: ThinkPad X260
dmi.product.name: 20F6CTO1WW
dmi.product.sku: LENOVO_MT_20F6_BU_Think_FM_ThinkPad X260
dmi.product.version: ThinkPad X260
dmi.sys.vendor: LENOVO

Alberto Donato (ack) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
You-Sheng Yang (vicamo) wrote :

This seems a duplicate of bug 1846016 to me. Could you try https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.4-rc2/ ?

Alberto Donato (ack) wrote :

Indeed, it does seem to be a duplicate.

With mainline kernel seems to be working fine.
Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers