slow copy files to flash disk (multiple files - in multiple nautilus windows)

Bug #184762 reported by Skeletonix on 2008-01-21
10
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

Hello,

 if are a files( two 1GB documents ) copied to flash pen drive by once velocity is good - ~2min (only one nautilus windows of copy status appear), but if is selected first document a copying is started (the first nautilus windows of copy status appear ) and then I start transfer of the second document (the second nautilus windows of copy status appear ) the copy velocity fall very down - ~2hours.

lordmule (stavrakakis) wrote :

I have a Corsair Flash Voyager 16G and I have about 2G of pdf to move about. My home machine is Intrepid alpha 3 and I get about 4MB/s. On my Hardy Heron at work I get about 20MB/s, in windows I can reach roughly 26-30MB/s.

it is a FAT32 partition, and I do have multiple windows open. I'll work on reproducing the transfer with time and cp on the intrepid box.

komputes (komputes) wrote :

It would also be interesting to compare copy times with the ext2 filesystem as well.

lordmule (stavrakakis) wrote :

oopsies I never managed to get those results. I did find that with Mac OSX the performance of my thumb drive was still quite crap for lots of small files. Still a FAT32 partition. As for the ubuntu side of things, I found that nautilus tends to hang on me quite frequently, I used Thunar (xfce4) for copy operations and the performance and response times are much better. Nautilus or OS kernel drivers...?

Changed in nautilus:
importance: Undecided → Low
shacharr (shacharr) wrote :

Happens to me as well. I think that multiple file activities on a Corsair Flash hit a slow path. Maybe a kernel problem? Maybe Nautilus/kernel integration problems? It is really really weird.

Can you please try reproducing this with Intrepid as the kernel has been updated to 2.6.27-9 and report back.
Thank you.

Javier Jardón (jjardon) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux:
status: Incomplete → Invalid
entrophilic (aswarren) wrote :

I can confirm this issue using a Corsair Flash Voyager 16GB with a single Fat32 partition using Kubuntu 8.10 kernel version 2.6.27-14-generic.
Mounted as /dev/sdc1 on /media/CORSAIR type vfat (rw,nosuid,nodev,uhelper=hal,uid=1000,utf8)
Copying a 4.3 Gb iso image (kubuntu dvd 9.04) from the hard drive to /dev/sdc1 gives speed that fluctuates between 2-8 MiB/s. Hasn't finished copying yet but I will guesstimate that it will take around 30 minutes total.
Running on a Dell Optiplex GX270

Changed in linux (Ubuntu):
status: Invalid → New
kernel-janitor (kernel-janitor) wrote :

Hi tomaskloucek,

Please be sure to confirm this issue exists with the latest development release of Ubuntu. ISO CD images are available from http://cdimage.ubuntu.com/releases/ . Please then run following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux-image-`uname -r` 184762

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Jonathan Thomas (echidnaman) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers