ubuntu_sysdig_smoke_test failed on 5.3 / 5.4 / 5.6 /5.8 / 5.10 kernels

Bug #1844493 reported by Po-Hsu Lin
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Krzysztof Kozlowski
linux (Ubuntu)
Undecided
Unassigned
Eoan
Undecided
Unassigned
Focal
Undecided
Unassigned
linux-aws (Ubuntu)
Undecided
Unassigned
Eoan
Undecided
Unassigned
Focal
Undecided
Unassigned
linux-azure (Ubuntu)
Undecided
Unassigned
Eoan
Undecided
Unassigned
Focal
Undecided
Unassigned
linux-gcp (Ubuntu)
Undecided
Unassigned
Eoan
Undecided
Unassigned
Focal
Undecided
Unassigned

Bug Description

Test failed with:
  FAILED (trace at least 25 reads of /dev/zero by dd)
  FAILED (trace at least 25 writes to /dev/null by dd)

Steps:
  sudo apt-get install git python-minimal python-yaml gdb -y
  git clone --depth=1 git://kernel.ubuntu.com/ubuntu/autotest-client-tests
  git clone --depth=1 git://kernel.ubuntu.com/ubuntu/autotest
  rm -fr autotest/client/tests
  ln -sf ~/autotest-client-tests autotest/client/tests
  AUTOTEST_PATH=/home/ubuntu/autotest sudo -E autotest/client/autotest-local --verbose autotest/client/tests/ubuntu_sysdig_smoke_test/control

Test output:
  == sysdig smoke test to trace dd, cat, read and writes ==
  Limiting raw capture file to 16384 blocks
  Try 1 of 10
  Sysdig capture started after 1 seconds wait
  Raw capture file is 16 Mbytes
  Converted events file is 18 Mbytes
  Try 2 of 10
  Sysdig capture started after 1 seconds wait
  Raw capture file is 16 Mbytes
  Converted events file is 22 Mbytes
  Try 3 of 10
  Sysdig capture started after 1 seconds wait
  Raw capture file is 16 Mbytes
  Converted events file is 21 Mbytes
  Try 4 of 10
  Sysdig capture started after 1 seconds wait
  Raw capture file is 16 Mbytes
  Converted events file is 21 Mbytes
  Try 5 of 10
  Sysdig capture started after 1 seconds wait
  Raw capture file is 16 Mbytes
  Converted events file is 21 Mbytes
  Try 6 of 10
  Sysdig capture started after 1 seconds wait
  Raw capture file is 16 Mbytes
  Converted events file is 21 Mbytes
  Try 7 of 10
  Sysdig capture started after 1 seconds wait
  Raw capture file is 16 Mbytes
  Converted events file is 21 Mbytes
  Try 8 of 10
  Sysdig capture started after 1 seconds wait
  Raw capture file is 16 Mbytes
  Converted events file is 21 Mbytes
  Try 9 of 10
  Sysdig capture started after 1 seconds wait
  Raw capture file is 16 Mbytes
  Converted events file is 21 Mbytes
  Try 10 of 10
  Sysdig capture started after 1 seconds wait
  Raw capture file is 16 Mbytes
  Converted events file is 21 Mbytes
  Found:
     279845 sysdig events
     29882 context switches
     0 reads from /dev/zero by dd
     0 writes to /dev/null by dd
  PASSED (trace at least 25 context switches)
  FAILED (trace at least 25 reads of /dev/zero by dd)
  FAILED (trace at least 25 writes to /dev/null by dd)

  Summary: 1 passed, 2 failed

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: linux-image-5.3.0-10-generic 5.3.0-10.11
ProcVersionSignature: User Name 5.3.0-10.11-generic 5.3.0-rc8
Uname: Linux 5.3.0-10-generic x86_64
AlsaDevices:
 total 0
 crw-rw---- 1 root audio 116, 1 Sep 18 08:10 seq
 crw-rw---- 1 root audio 116, 33 Sep 18 08:10 timer
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay': 'aplay'
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord': 'arecord'
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CurrentDmesg:

Date: Wed Sep 18 08:18:54 2019
IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig': 'iwconfig'
MachineType: Intel Corporation S1200RP
PciMultimedia:

ProcFB: 0 mgag200drmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-10-generic root=UUID=b0d2ae4e-12dd-423e-acea-272ee8b2a893 ro
RelatedPackageVersions:
 linux-restricted-modules-5.3.0-10-generic N/A
 linux-backports-modules-5.3.0-10-generic N/A
 linux-firmware 1.182
RfKill: Error: [Errno 2] No such file or directory: 'rfkill': 'rfkill'
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/01/2015
dmi.bios.vendor: Intel Corp.
dmi.bios.version: S1200RP.86B.03.02.0003.070120151022
dmi.board.asset.tag: ....................
dmi.board.name: S1200RP
dmi.board.vendor: Intel Corporation
dmi.board.version: G62254-407
dmi.chassis.asset.tag: ....................
dmi.chassis.type: 17
dmi.chassis.vendor: ..............................
dmi.chassis.version: ..................
dmi.modalias: dmi:bvnIntelCorp.:bvrS1200RP.86B.03.02.0003.070120151022:bd07/01/2015:svnIntelCorporation:pnS1200RP:pvr....................:rvnIntelCorporation:rnS1200RP:rvrG62254-407:cvn..............................:ct17:cvr..................:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: S1200RP
dmi.product.sku: To be filled by O.E.M.
dmi.product.version: ....................
dmi.sys.vendor: Intel Corporation

Revision history for this message
Po-Hsu Lin (cypressyew) wrote :
tags: added: ubuntu-sysdig-smoke-test
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1844493

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Marcelo Cerri (mhcerri)
Changed in linux (Ubuntu Eoan):
assignee: nobody → Marcelo Cerri (mhcerri)
Changed in ubuntu-kernel-tests:
assignee: nobody → Marcelo Cerri (mhcerri)
Sean Feole (sfeole)
tags: added: gcp
tags: added: sru-20191021
Sean Feole (sfeole)
tags: added: aws
Sean Feole (sfeole)
tags: added: azure
Sean Feole (sfeole)
Changed in ubuntu-kernel-tests:
status: New → Triaged
tags: added: sru-20191111
Po-Hsu Lin (cypressyew)
tags: added: sru-20191202
Po-Hsu Lin (cypressyew)
tags: added: sru-20200106
Sean Feole (sfeole)
tags: added: sru-20200127
Sean Feole (sfeole)
tags: added: 5.3
Sean Feole (sfeole)
tags: added: sru-20200217
Sean Feole (sfeole)
summary: - ubuntu_sysdig_smoke_test failed on Eoan
+ ubuntu_sysdig_smoke_test failed on Eoan/5.3 kernels
Revision history for this message
Po-Hsu Lin (cypressyew) wrote : Re: ubuntu_sysdig_smoke_test failed on Eoan/5.3 kernels

This test is still failing for Eoan 5.3.0-43.36 on node kili, onibi. But surprisingly it has passed on node vought with the same kernel.

tags: added: sru-20200316
Sean Feole (sfeole)
tags: added: sru-20200406
Po-Hsu Lin (cypressyew)
tags: added: sru-20200518
Sean Feole (sfeole)
tags: added: sru-20200608
Revision history for this message
Po-Hsu Lin (cypressyew) wrote :

With Oracle Focal 5.4.0-1021.21
This is only failing on VM.Standard2.1, but passed on VM.Standard2.16

tags: added: 5.4 focal oracle
tags: added: sru-20200629
summary: - ubuntu_sysdig_smoke_test failed on Eoan/5.3 kernels
+ ubuntu_sysdig_smoke_test failed on 5.3 / 5.4 kernels
Revision history for this message
Sean Feole (sfeole) wrote : Re: ubuntu_sysdig_smoke_test failed on 5.3 / 5.4 kernels

This appears to just be a nuisance now, rather than a reliable test as it is consistently failing in clouds. Will take some time to break this down and figure out if we can fix the test.

Changed in ubuntu-kernel-tests:
assignee: Marcelo Cerri (mhcerri) → Sean Feole (sfeole)
Changed in linux (Ubuntu Eoan):
assignee: Marcelo Cerri (mhcerri) → nobody
Changed in linux (Ubuntu):
assignee: Marcelo Cerri (mhcerri) → nobody
Po-Hsu Lin (cypressyew)
tags: added: sru-20200810
Revision history for this message
Francis Ginther (fginther) wrote :

Failing with Bionic linux-aws 5.4.0-1026.26~18.04.1 and 5.4.0-1025.25~18.04.1.

tags: added: sru-20200921
Revision history for this message
Kelsey Skunberg (kelsey-skunberg) wrote :

Failed on Bionic/oracle : 5.4.0-1026.26~18.04.1 : amd64

tags: added: bionic
Revision history for this message
Po-Hsu Lin (cypressyew) wrote : Re: ubuntu_sysdig_smoke_test failed on 5.3 / 5.4 / 5.6 kernels

Issue found on oem-5.6.0-1035

summary: - ubuntu_sysdig_smoke_test failed on 5.3 / 5.4 kernels
+ ubuntu_sysdig_smoke_test failed on 5.3 / 5.4 / 5.6 kernels
tags: added: sru-20201109
Po-Hsu Lin (cypressyew)
summary: - ubuntu_sysdig_smoke_test failed on 5.3 / 5.4 / 5.6 kernels
+ ubuntu_sysdig_smoke_test failed on 5.3 / 5.4 / 5.6 /5.8 kernels
Po-Hsu Lin (cypressyew)
tags: added: sru-20201130
tags: added: sru-20210104
tags: added: sru-20210125
Ian May (ian-may)
tags: added: sru-20210222
Revision history for this message
Po-Hsu Lin (cypressyew) wrote :

Found on 5.10.0-1020.21 Focal OEM

summary: - ubuntu_sysdig_smoke_test failed on 5.3 / 5.4 / 5.6 /5.8 kernels
+ ubuntu_sysdig_smoke_test failed on 5.3 / 5.4 / 5.6 /5.8 / 5.10 kernels
tags: added: sru-20210315
tags: added: hwe
Revision history for this message
Ian May (ian-may) wrote :

found on focal/aws 5.4.0-1042.44

Revision history for this message
Krzysztof Kozlowski (krzk) wrote :

focal/aws-5.8 5.8.0-1031.33~20.04.1

tags: added: 5.8 sru-20210412
Revision history for this message
Ian May (ian-may) wrote :

ocal/linux-azure 5.4.0-1047.49 sru-20210412

Revision history for this message
Ian May (ian-may) wrote :

focal/linux-azure 5.4.0-1047.49~18.04.1 sru-20210412

Revision history for this message
Ian May (ian-may) wrote :

focal/linux-gcp 5.8.0-1029.30~20.04.1

Revision history for this message
Krzysztof Kozlowski (krzk) wrote :

Found on focal/linux-gke 5.4.0-1043.45

tags: added: gke
Revision history for this message
Ian May (ian-may) wrote :

bionic/linux-oracle-5.4: 5.4.0-1044.47~18.04.1

Revision history for this message
Ian May (ian-may) wrote :

focal/linux-aws: 5.4.0-1049.51

tags: added: sru-20210510
Revision history for this message
Krzysztof Kozlowski (krzk) wrote :

I'll fix it :)

Changed in ubuntu-kernel-tests:
assignee: Sean Feole (sfeole) → Krzysztof Kozlowski (krzk)
Changed in ubuntu-kernel-tests:
status: Triaged → In Progress
Revision history for this message
Po-Hsu Lin (cypressyew) wrote :
Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in linux (Ubuntu Eoan):
status: Incomplete → Invalid
Changed in linux (Ubuntu Focal):
status: New → Invalid
Po-Hsu Lin (cypressyew)
Changed in linux-aws (Ubuntu):
status: New → Invalid
Po-Hsu Lin (cypressyew)
Changed in linux-aws (Ubuntu Eoan):
status: New → Invalid
Changed in linux-aws (Ubuntu Focal):
status: New → Invalid
Changed in linux-azure (Ubuntu):
status: New → Invalid
Changed in linux-azure (Ubuntu Eoan):
status: New → Invalid
Changed in linux-azure (Ubuntu Focal):
status: New → Invalid
Changed in linux-gcp (Ubuntu):
status: New → Invalid
Changed in linux-gcp (Ubuntu Eoan):
status: New → Invalid
Changed in linux-gcp (Ubuntu Focal):
status: New → Invalid
Changed in ubuntu-kernel-tests:
status: In Progress → Fix Committed
Changed in ubuntu-kernel-tests:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers