BT advertising packet wakes up the system from S3 and suspend-to-idle

Bug #1844247 reported by AceLan Kao
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
Undecided
AceLan Kao
Bionic
Undecided
AceLan Kao
Disco
Undecided
AceLan Kao
Eoan
Undecided
AceLan Kao
Focal
Undecided
AceLan Kao

Bug Description

[Impact]
The new feature added by below commit let BT device to wake up the system from S3 or s2idle.
   a0085f2510e8 ("Bluetooth: btusb: driver to enable the usb-wakeup feature")
But this feature also wakes up the system randomly from an unpaired BLE device by its advertising packets.

[Fix]
There is no easy way to fix this and requires firmware update, so current solution for this is to revert it.
   1ffdb51f28e8 ("Revert "Bluetooth: btusb: driver to enable the usb-wakeup feature"")

[Test]
Verified on machines which has paired BLE devices, and can't be waken up by BT devices after entered suspended.

[Regression]
Yes, it reverts the feature by waking up system from s2idle by paired BT devices, but this feature introduces regression, so I'd suggest to revert it.

AceLan Kao (acelankao)
no longer affects: linux-oem (Ubuntu)
Changed in linux (Ubuntu Bionic):
assignee: nobody → AceLan Kao (acelankao)
Changed in linux (Ubuntu Disco):
assignee: nobody → AceLan Kao (acelankao)
Changed in linux (Ubuntu Eoan):
assignee: nobody → AceLan Kao (acelankao)
status: New → In Progress
Changed in linux (Ubuntu Disco):
status: New → In Progress
Changed in linux (Ubuntu Bionic):
status: New → In Progress
AceLan Kao (acelankao)
description: updated
AceLan Kao (acelankao)
description: updated
AceLan Kao (acelankao)
description: updated
description: updated
description: updated
description: updated
You-Sheng Yang (vicamo)
tags: added: oem-priority originate-from-1842635 somerville
Revision history for this message
Kleber Sacilotto de Souza (kleber-souza) wrote :

The kernel fix

1ffdb51f28e8 Revert "Bluetooth: btusb: driver to enable the usb-wakeup feature"

has already been applied to Disco as part of bug #1845390 (Disco update: upstream stable patchset 2019-09-25) and to Bionic as part of bug #1845266 (Bionic update: upstream stable patchset 2019-09-24).

Changed in linux (Ubuntu Eoan):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Bionic):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Disco):
status: In Progress → Fix Committed
Revision history for this message
Pierre Equoy (pieq) wrote :

Device: XPS 13 7390
Image: 19.10 Beta
Kernel: updated to 5.3.0-13-generic (from 5.3.0-10-generic)

With kernel 5.3.0-10-generic, the device wouldn't suspend properly when a BT device was connected to it. After updating to 5.3.0-13-generic, the issue is gone. I can use a BT mouse, then suspend the device (by pressing the top-right menu, holding Alt key and clicking the "pause" button), and the device will indeed suspend and only resume when I press a key on the keyboard or the power button.

AceLan Kao (acelankao)
no longer affects: linux-oem (Ubuntu Disco)
no longer affects: linux-oem (Ubuntu Bionic)
no longer affects: linux-oem (Ubuntu Eoan)
no longer affects: linux-oem (Ubuntu Focal)
Steve Langasek (vorlon)
Changed in linux (Ubuntu Disco):
status: Fix Committed → Won't Fix
Revision history for this message
You-Sheng Yang (vicamo) wrote :

This was actually fixed in Disco version 5.0.0-32.34 by bug 1845390.

Changed in linux (Ubuntu Disco):
status: Won't Fix → Fix Released
Changed in linux (Ubuntu Eoan):
status: Fix Committed → Invalid
Changed in linux (Ubuntu Focal):
status: Fix Committed → Invalid
Revision history for this message
You-Sheng Yang (vicamo) wrote :

The fix commit 1ffdb51f28e8 ("Revert "Bluetooth: btusb: driver to enable the usb-wakeup feature"") is included in v5.3 or above.

Changed in hwe-next:
status: New → Fix Released
Changed in linux (Ubuntu):
status: Fix Committed → Invalid
Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released
Revision history for this message
You-Sheng Yang (vicamo) wrote :

This was actually fixed in Bionic version 4.15.0-66.75 by bug 1845266.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers