cherrypick has_sipl fix

Bug #1843960 reported by Dimitri John Ledkov on 2019-09-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

cherrypick has_sipl fix from the s390 maintainer tree

https://git.kernel.org/pub/scm/linux/kernel/git/s390/linux.git/patch/?id=4df9a82549cfed5b52da21e7d007b79b2ea1769a

Otherwise, has_secure sysfs attribute is never correct.

From: Philipp Rudo <email address hidden>

BugLink: https://bugs.launchpad.net/bugs/1843960

Fixes: c9896acc7851 ("s390/ipl: Provide has_secure sysfs attribute")
Cc: <email address hidden> # 5.2+
Reviewed-by: Heiko Carstens <email address hidden>
Signed-off-by: Philipp Rudo <email address hidden>
Signed-off-by: Vasily Gorbik <email address hidden>
(cherry picked from commit 4df9a82549cfed5b52da21e7d007b79b2ea1769a
 git://git.kernel.org/pub/scm/linux/kernel/git/s390/linux.git)
Signed-off-by: Dimitri John Ledkov <email address hidden>
---
 drivers/s390/char/sclp_early.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/s390/char/sclp_early.c b/drivers/s390/char/sclp_early.c
index e71992a3c55f..cc5e84b80c69 100644
--- a/drivers/s390/char/sclp_early.c
+++ b/drivers/s390/char/sclp_early.c
@@ -40,7 +40,7 @@ static void __init sclp_early_facilities_detect(struct read_info_sccb *sccb)
  sclp.has_gisaf = !!(sccb->fac118 & 0x08);
  sclp.has_hvs = !!(sccb->fac119 & 0x80);
  sclp.has_kss = !!(sccb->fac98 & 0x01);
- sclp.has_sipl = !!(sccb->cbl & 0x02);
+ sclp.has_sipl = !!(sccb->cbl & 0x4000);
  if (sccb->fac85 & 0x02)
   S390_lowcore.machine_flags |= MACHINE_FLAG_ESOP;
  if (sccb->fac91 & 0x40)
--
2.20.1

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1843960

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Frank Heimes (frank-heimes) wrote :

[PATCH][UNSTABLE][EOAN] UBUNTU: SAUCE: s390/sclp: Fix bit checked for has_sipl
https://lists.ubuntu.com/archives/kernel-team/2019-September/103721.html

Changed in ubuntu-z-systems:
status: New → Triaged
tags: added: s390x

(Removing upstream stable Cc as this is a sauce patch for Ubuntu)

On Sat, Sep 14, 2019 at 12:00:02AM +0100, Dimitri John Ledkov wrote:
> From: Philipp Rudo <email address hidden>
>
> BugLink: https://bugs.launchpad.net/bugs/1843960
>
> Fixes: c9896acc7851 ("s390/ipl: Provide has_secure sysfs attribute")
> Cc: <email address hidden> # 5.2+
> Reviewed-by: Heiko Carstens <email address hidden>
> Signed-off-by: Philipp Rudo <email address hidden>
> Signed-off-by: Vasily Gorbik <email address hidden>
> (cherry picked from commit 4df9a82549cfed5b52da21e7d007b79b2ea1769a
> git://git.kernel.org/pub/scm/linux/kernel/git/s390/linux.git)
> Signed-off-by: Dimitri John Ledkov <email address hidden>

Applied to eoan/master-next, thanks!

Changed in linux (Ubuntu):
status: Triaged → Fix Committed
Changed in ubuntu-z-systems:
status: Triaged → Fix Committed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1843960

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 5.3.0-12.13

---------------
linux (5.3.0-12.13) eoan; urgency=medium

  * Change kernel compression method to improve boot speed (LP: #1840934)
    - [Packaging] Add lz4 build dependency for s390x

  * Miscellaneous Ubuntu changes
    - SAUCE: Remove spl and zfs source

linux (5.3.0-11.12) eoan; urgency=medium

  * eoan/linux: 5.3.0-11.12 -proposed tracker (LP: #1844144)

  * Suspend to RAM(S3) does not wake up for latest megaraid and mpt3sas
    adapters(SAS3.5 onwards) (LP: #1838751)
    - PCI: Restore Resizable BAR size bits correctly for 1MB BARs

  * s390/setup: Actually init kernel lock down (LP: #1843961)
    - SAUCE: (lockdown) s390/setup: Actually init kernel lock down

  * cherrypick has_sipl fix (LP: #1843960)
    - SAUCE: s390/sclp: Fix bit checked for has_sipl

  * Change kernel compression method to improve boot speed (LP: #1840934)
    - [Config]: Switch kernel compression from LZO to LZ4 on s390x

  * Installation fails on eoan/PowerVM : missing /dev/nvram (LP: #1837726)
    - [Config] CONFIG_NVRAM=y for ppc64el

  * Miscellaneous Ubuntu changes
    - [Config]: remove nvram from ppc64el modules ABI
    - [Config] Update annotations for recent config changes
    - SAUCE: sched: Add __ASSEMBLY__ guards around struct clone_args
    - SAUCE: i2c: qcom-geni: Disable DMA processing on the Lenovo Yoga C630
    - SAUCE: arm64: dts: qcom: Add Lenovo Yoga C630
    - update dkms package versions

  [ Upstream Kernel Changes ]

  * Rebase to v5.3

 -- Seth Forshee <email address hidden> Tue, 17 Sep 2019 13:36:26 +0200

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers