bionic: support derivative linux-fde kernel

Bug #1842433 reported by Shrirang Bagul on 2019-09-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Shrirang Bagul

Bug Description

Impact:

Several Ubuntu core projects which require UEFI secure boot with full disk encryption enabled.
The linux-fde derivative kernel which satisfies this requirement by providing a kernel binary with an embedded initramfs.

kmods to support HW crypto, filesystems, HW random number generation, etc. The requirement for some of these modules to be built-in comes from:
1. https://bazaar.launchpad.net/~snappy-dev/initramfs-tools-ubuntu-core/trunk/view/head:/modules/modules.amd64
2. https://git.launchpad.net/~ubuntu-kernel/ubuntu/+source/linux-snap/+git/bionic/commit/Makefile?id=6c3c9030bbae7f1a5c1a1773424431f7777e2c6c

The purpose of this bug is essentially used to track the kernel config changes introduced on top of the amd64-generic Bionic kernel.

Regression Potential:
Low. The kernel will be maintained as a derivative kernel.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1842433

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: bionic
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → High
Changed in linux (Ubuntu):
assignee: nobody → Shrirang Bagul (shrirang-bagul)
Shrirang Bagul (shrirang-bagul) wrote :

Fixed in linux-fde (4.15.0-1001.2)

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers