Operation against ntfs in ubuntu_ltp_syscalls test will fail with EROFS

Bug #1842266 reported by Po-Hsu Lin on 2019-09-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Unassigned
linux (Ubuntu)
Undecided
AaronMa
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

This issue can only be found on AMD64 / i386 and s390x KVM (failed: EACCES on s390x KVM)
Passed with ARM64.

For P8, it will fail with btrfs before this.

This issue seems to be new, as the test does not report that it supports ntfs with older kernel (4.4.0-157)
tst_supported_fs_types.c:44: INFO: mkfs.btrfs does exist
tst_supported_fs_types.c:60: INFO: Kernel supports vfat
tst_supported_fs_types.c:44: INFO: mkfs.vfat does exist
tst_supported_fs_types.c:83: INFO: Filesystem exfat is not supported
tst_supported_fs_types.c:88: INFO: Skipping FUSE as requested by the test

But with 4.4.161:
tst_supported_fs_types.c:44: INFO: mkfs.vfat does exist
tst_supported_fs_types.c:83: INFO: Filesystem exfat is not supported
tst_supported_fs_types.c:60: INFO: Kernel supports ntfs
tst_supported_fs_types.c:44: INFO: mkfs.ntfs does exist

tst_mkfs.c:90: INFO: Formatting /dev/loop1 with ntfs opts='' extra opts=''
Failed to set locale, using default 'C'.
The partition start sector was not specified for /dev/loop1 and it could not be obtained automatically. It has been set to 0.
The number of sectors per track was not specified for /dev/loop1 and it could not be obtained automatically. It has been set to 0.
The number of heads was not specified for /dev/loop1 and it could not be obtained automatically. It has been set to 0.
To boot from a device, Windows needs the 'partition start sector', the 'sectors per track' and the 'number of heads' to be set.
Windows will not be able to boot from this device.
tst_test.c:1108: INFO: Timeout per run is 0h 05m 00s
safe_macros.c:225: BROK: sync_file_range02.c:47: open(mnt_point/test1,66,0644) failed: EROFS

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-4.15.0-60-generic 4.15.0-60.67~16.04.1
ProcVersionSignature: User Name 4.15.0-60.67~16.04.1-generic 4.15.18
Uname: Linux 4.15.0-60-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.19
Architecture: amd64
Date: Mon Sep 2 03:04:48 2019
SourcePackage: linux-signed-hwe
UpgradeStatus: No upgrade log present (probably fresh install)

Po-Hsu Lin (cypressyew) wrote :
affects: linux-signed-hwe (Ubuntu) → linux (Ubuntu)
tags: added: 4.4 sru-20190812 ubuntu-ltp-syscalls

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1842266

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu Xenial):
status: New → Incomplete
Po-Hsu Lin (cypressyew) on 2019-09-02
description: updated
tags: added: i386
Po-Hsu Lin (cypressyew) on 2019-09-02
description: updated
Po-Hsu Lin (cypressyew) on 2019-09-05
summary: - Operation against ntfs in ubuntu_syscalls test will fail with EROFS
+ Operation against ntfs in ubuntu_ltp_syscalls test will fail with EROFS
AaronMa (mapengyu) on 2019-09-16
no longer affects: ubuntu-kernel-tests
Changed in ubuntu-kernel-tests:
assignee: nobody → AaronMa (mapengyu)
AaronMa (mapengyu) wrote :

The syscall is not implemented on FUSE which ntfs uses.
LTP sync_file_range02 testcase skip FUSE on purpose.

No failure reported by testcase, just error in log.

So let's ignore this issue.

Changed in ubuntu-kernel-tests:
status: New → Won't Fix
Po-Hsu Lin (cypressyew) wrote :

fs_fill from ubuntu_ltp will failed with this as well.

Po-Hsu Lin (cypressyew) wrote :
Changed in ubuntu-kernel-tests:
status: Won't Fix → Fix Released
assignee: AaronMa (mapengyu) → nobody
Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in linux (Ubuntu Xenial):
status: Incomplete → Invalid
Changed in linux (Ubuntu Bionic):
status: New → Invalid
Changed in linux (Ubuntu):
assignee: nobody → AaronMa (mapengyu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers