No sound inputs from the external microphone and headset on a Dell machine

Bug #1842265 reported by Hui Wang on 2019-09-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
High
Hui Wang
Bionic
Undecided
Unassigned
linux-oem (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]
When we plug an external mic/headset-mic, the system can't
detect it and as a result can't record sound from it.

[Fix]
Apply an existing fixup to fix this issue.

[Test Case]
After applying the patch, plug an external mic or headset-mic,
system can detect it and can record the sound from it too.

[Regression Risk]
Low. just add an existing fixup to this new machine.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1842265

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Hui Wang (hui.wang) on 2019-09-02
description: updated
tags: added: originate-from-1839820 somerville
Changed in linux (Ubuntu):
importance: Undecided → High
Seth Forshee (sforshee) on 2019-09-05
Changed in linux (Ubuntu):
status: Incomplete → Fix Committed
AceLan Kao (acelankao) on 2019-09-06
Changed in linux-oem (Ubuntu Bionic):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 5.3.0-10.11

---------------
linux (5.3.0-10.11) eoan; urgency=medium

  * eoan/linux: 5.3.0-10.11 -proposed tracker (LP: #1843232)

  * No sound inputs from the external microphone and headset on a Dell machine
    (LP: #1842265)
    - SAUCE: ALSA: hda - Expand pin_match function to match upcoming new tbls
    - SAUCE: ALSA: hda - Define a fallback_pin_fixup_tbl for alc269 family

  * Horizontal corrupted line at top of screen caused by framebuffer compression
    (LP: #1840236)
    - SAUCE: drm/i915/fbc: disable framebuffer compression on IceLake

  * Add bpftool to linux-tools-common (LP: #1774815)
    - [Debian] package bpftool in linux-tools-common

  * Miscellaneous Ubuntu changes
    - update dkms package versions

  [ Upstream Kernel Changes ]

  * Rebase to v5.3-rc8

 -- Paolo Pisati <email address hidden> Mon, 09 Sep 2019 10:00:41 +0200

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers