[EHL] Enable intel_idle driver

Bug #1842218 reported by quanxian on 2019-09-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
intel
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Description
Need to enable intel_idle for the Elkhart Lake product line in mainline kernel.

This allows for finer-grain C-state control (using all supported platform MWAIT hints) than ACPI C-states. The intel_idle driver uses a different approach (MWAIT calls from kernel driver) than Windows (ACPI calls from kernel driver).

Target Release: 20.10
Target Kernel: 5.6

quanxian (quanxian-wang) wrote :

bc94638886ab21f8247d3f7f39573d3feb7d8284 v5.6

description: updated
Changed in intel:
status: New → Fix Committed
quanxian (quanxian-wang) wrote :

18734958e9bfbc055805d110a38dc76307eba742 239ed06d0eefc4ee351af69bd64742ada56c4bdb 4ec32d9e8e5b6d6eb491eeee3938665d8a2388fa 75a80267410e38ab76c4ceb39753f96d72113781 77fb4e0a559a960eb36d0b2c50c781c5492577eb 987c785319b99e32602f7f86cfae3cf9b81e402b 9f3d6daf61e5156139cd05643f7f1c2a9b7b49b0 a3299182216397a0b943d2549d1997f4eba2bdd2 aa659a3fca79abd9a3ca3ddc535db631b01c9a02 bc94638886ab21f8247d3f7f39573d3feb7d8284 bff8e60a86f4960133f90ad9add9adeb082b8154 e6d4f08a677654385869ba0c39d7c9ceec47e5c5

quanxian (quanxian-wang) on 2020-05-13
description: updated
tags: added: intel-kernel-20.10
removed: intel-kernel-20.04
quanxian (quanxian-wang) on 2020-06-09
information type: Private → Public

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1842218

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: groovy
quanxian (quanxian-wang) on 2020-06-18
information type: Public → Private
quanxian (quanxian-wang) on 2020-06-22
information type: Private → Public
quanxian (quanxian-wang) on 2020-11-16
Changed in intel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers