Fix touchpad IRQ storm after S3

Bug #1841396 reported by Kai-Heng Feng on 2019-08-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
Status tracked in Eoan
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned
Eoan
Undecided
Unassigned
linux-oem (Ubuntu)
Status tracked in Eoan
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned
Eoan
Undecided
Unassigned
linux-oem-osp1 (Ubuntu)
Status tracked in Eoan
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned
Eoan
Undecided
Unassigned

Bug Description

[Impact]
IRQ storm generated from touchpad after S3, renders touchpad useless.

[Fix]
gpiolib routines expect pin offset instead of pin number. Passing correct
pin offset can solve the issue.

[Test]
With the patch applied the issue doesn't happen anymore on HP Zbook 17
G5.

[Regression Potential]
Low. Though there are many users of pinctrl-intel, this make it
correctly uses gpiolib.

tags: added: oem-priority originate-from-1833972 stella
Changed in linux-oem (Ubuntu Disco):
status: New → Invalid
Changed in linux-oem (Ubuntu Eoan):
status: New → Invalid
Changed in linux-oem-osp1 (Ubuntu Disco):
status: New → Invalid
Changed in linux-oem-osp1 (Ubuntu Eoan):
status: New → Invalid

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1841396

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu Bionic):
status: New → Incomplete
Changed in linux (Ubuntu Disco):
status: New → Incomplete
Seth Forshee (sforshee) on 2019-08-30
Changed in linux (Ubuntu Eoan):
status: Incomplete → Fix Committed
Changed in linux (Ubuntu Bionic):
status: Incomplete → Fix Committed
Changed in linux (Ubuntu Disco):
status: Incomplete → Fix Committed

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-disco' to 'verification-done-disco'. If the problem still exists, change the tag 'verification-needed-disco' to 'verification-failed-disco'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-disco

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 5.3.0-10.11

---------------
linux (5.3.0-10.11) eoan; urgency=medium

  * eoan/linux: 5.3.0-10.11 -proposed tracker (LP: #1843232)

  * No sound inputs from the external microphone and headset on a Dell machine
    (LP: #1842265)
    - SAUCE: ALSA: hda - Expand pin_match function to match upcoming new tbls
    - SAUCE: ALSA: hda - Define a fallback_pin_fixup_tbl for alc269 family

  * Horizontal corrupted line at top of screen caused by framebuffer compression
    (LP: #1840236)
    - SAUCE: drm/i915/fbc: disable framebuffer compression on IceLake

  * Add bpftool to linux-tools-common (LP: #1774815)
    - [Debian] package bpftool in linux-tools-common

  * Miscellaneous Ubuntu changes
    - update dkms package versions

  [ Upstream Kernel Changes ]

  * Rebase to v5.3-rc8

 -- Paolo Pisati <email address hidden> Mon, 09 Sep 2019 10:00:41 +0200

Changed in linux (Ubuntu Eoan):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers