Asus X451MA does not boot with linux > 4.15.0-55

Bug #1841313 reported by Yvan Masson on 2019-08-24
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

On an Asus X451MA running Linux Mint 18.3 (Ubuntu 16.04.3), last kernel update from 4.15.0-55 to 4.15.0-58 prevents it from booting: it hangs at the beginning of boot.

I tested with kernel 4.15.0-59 from "xenial-proposed" and with a live image of Ubuntu 18.04.2 and the issue remains. I could not test with a more recent kernel on this same install because it requires libssl1.1 that is not available in the Xenial repositories. I suppose it does not help, but a picture from live Ubuntu 18.04.2 is attached.

I will provide more information with apport very soon.

Do not hesitate to ask if I can provide other details or test other versions / parameters.

Regards,
Yvan
---
ApportVersion: 2.20.1-0ubuntu2.19
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: marie-claude 1541 F.... pulseaudio
CurrentDesktop: X-Cinnamon
DistroRelease: Linux 18.3
HibernationDevice: RESUME=UUID=d93009cf-a1ab-47ec-811c-d76dfbc4926d
InstallationDate: Installed on 2017-04-08 (868 days ago)
InstallationMedia: Linux Mint 18.1 "Serena" - Release amd64 20161213
IwConfig:
 enp3s0f2 no wireless extensions.

 lo no wireless extensions.
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 04f2:b404 Chicony Electronics Co., Ltd
 Bus 001 Device 002: ID 04ca:2006 Lite-On Technology Corp. Broadcom BCM43142A0 Bluetooth Device
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: ASUSTeK COMPUTER INC. X451MA
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-55-generic root=UUID=a34dd005-da91-42c3-95c6-b25185f3ee21 ro intel_idle.max_cstate=1 quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 4.15.0-55.60~16.04.2-generic 4.15.18
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-55-generic N/A
 linux-backports-modules-4.15.0-55-generic N/A
 linux-firmware 1.157.22
RfKill:
 0: hci0: Bluetooth
  Soft blocked: yes
  Hard blocked: no
Tags: sylvia sylvia
Uname: Linux 4.15.0-55-generic x86_64
UnreportableReason: Le rapport fait référence à un paquet non installé.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: False
dmi.bios.date: 04/10/2015
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: X451MA.216
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: X451MA
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrX451MA.216:bd04/10/2015:svnASUSTeKCOMPUTERINC.:pnX451MA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnX451MA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.family: X
dmi.product.name: X451MA
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Yvan Masson (yvan-masson) wrote :
tags: added: apport-collected sylvia
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Yvan Masson (yvan-masson) wrote :

I forgot to say that the following kernel parameters do not solve the issue:
- acpi=off
- noapic
- pci=biosirq
- nomodeset i915.nomodeset

Regards,
Yvan

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: bionic
axt (axt.) wrote :

> Linux Mint 18.3 (Ubuntu 16.04.3)

At the first: Mint is *not* Ubuntu, it is only based on it with several changes, additions and withheld packages.

As a basis I would always have flashed the last available BIOS/UEFI. But 216 is already on your Asus X451MA.

"r8169 can't disable aspm" (your screenshot) is an information, not an error.

Are the kernels fully installed, i.e. is there _enough space_ on a possibly separate boot partition?

But...Xenial is obsolete (only original Ubuntu Xenial has 5 years "LTS" status), kernel 4.15 is very _old_ (it must be maintained by Canonical or the distributions that use it). I know Mint allegedly also supports 18.3, but at best Cinnamon and other additives.

You should install a recent distribution...and on an Atom Silvermont N3540 with a lightweight desktop environment (LDisco with LXQt, LBionic.3 with LXDE).

Yvan Masson (yvan-masson) wrote :

I tried with other Ubuntu live versions: 18.04.3 boots (18.04.2 does not), 19.04 also boots.

Regards,
Yvan

Kai-Heng Feng (kaihengfeng) wrote :

Can you please test 4.15.0-56 and 4.15.0-57?

Yvan Masson (yvan-masson) wrote :

@axt.: Yes, the kernels are properly installed, I reinstalled them without error before reporting. I understand that 4.15 is old, but I supposed that there is the same issue on Ubuntu Xenial (you are right, I should have test it, and I will try to do it).

@kaihengfeng: I could not find 4.15.0-56 and 4.15.0-57: could you tell me where I can get them?

Yvan Masson (yvan-masson) wrote :

Thanks.

I tested with 4.15.0-56: install of linux-headers-4.15.0-56-generic fails because it misses libssl1.1, but grub list this version so I could try to boot on it and it fails the same way.

I could not test with 4.15.0-57 because your first link is wrong (and I am confused I really couldn't find this build myself…).

Yvan Masson (yvan-masson) wrote :

I just tested with live Xenial 16.04.6 and it boots properly (kernel is 4.15.0-45).

Yvan Masson (yvan-masson) wrote :

I had to give the computer back to its owner, I won't be able to do other tests, sorry.

lomme003 (lomme003) wrote :

ASUS R417M will take 4.15.0-55 but not 4.15.0-58, maybe same bug?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers