Intel HDMI audio print "Unable to sync register" errors

Bug #1840394 reported by Hui Wang on 2019-08-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
Critical
Hui Wang
Bionic
Medium
Unassigned
Disco
Medium
Unassigned
linux-oem (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

This fix is in the v5.3-rc3, and EAON already has this patch by backporting stable, so
this patch is only for B/D.

[Impact]
After S3, the intel hdmi audio on a dell laptop print the error like below:
[ 2052.030247] snd_hda_codec_hdmi hdaudioC0D2: Unable to sync register 0x2f0d00. -5

And the hdmi audio can't work anymore after this.

[Fix]
For Intel hdmi audio codec, it doesn't need to resume forcibly, because the i915 side
probably is not ready to let hdmi codec work, since the intel hdmi audio uses component
framework, let i915 control the hdmi codec.

[Test Case]
Tested on that dell laptops, the hdmi audio doesn't have any issues anymore after
applying this patch.

[Regression Risk]
Low. We tested this patch on a couple of machines (dell and lenovo).

Hui Wang (hui.wang) on 2019-08-16
tags: added: originate-from-1839926 somerville

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1840394

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Hui Wang (hui.wang) on 2019-08-16
Changed in linux (Ubuntu):
importance: Undecided → Critical
description: updated
AceLan Kao (acelankao) on 2019-08-16
Changed in linux-oem (Ubuntu Bionic):
status: New → Fix Committed
Changed in linux-oem (Ubuntu):
status: New → Invalid
Stefan Bader (smb) on 2019-08-26
Changed in linux (Ubuntu Bionic):
importance: Undecided → Medium
status: New → Confirmed
Changed in linux-oem (Ubuntu Disco):
status: New → Invalid
Changed in linux (Ubuntu Disco):
importance: Undecided → Medium
status: New → Confirmed
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in linux (Ubuntu Disco):
status: Confirmed → Fix Committed
Changed in linux (Ubuntu Bionic):
status: Confirmed → Fix Committed

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-disco' to 'verification-done-disco'. If the problem still exists, change the tag 'verification-needed-disco' to 'verification-failed-disco'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-disco
Hui Wang (hui.wang) on 2019-09-08
tags: added: verification-done-disco
removed: verification-needed-disco

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers