p54usb module in linux-modules-extra-5.0.0-23-generic does not work

Bug #1839693 reported by Dee Raj on 2019-08-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Status tracked in Eoan
Disco
Undecided
Po-Hsu Lin
Eoan
Undecided
Unassigned

Bug Description

== SRU Justification ==
User report that the p54usb driver will crash when trying to load it on 5.0 kernel for a Dell Wireless 1450 Dual-band (802.11a/b/g) USB 2.0 adapter. This was caused by commit e3554197 (p54: Use skb_peek_tail() instead of direct head pointer accesses.)

== Fix ==
* 1645ab93 (p54: fix crash during initialization)

This patch added a check for target_skb to determine where to queue the buffer. It can be cherry-picked into Disco.
Eoan got this patch from v5.2.1 upstream stable release update.

== Test ==
Test kernel could be found here:
https://people.canonical.com/~phlin/kernel/lp-1839693-p54usb/

This issue was reported against Bionic HWE 5.0 kernel, user confirmed that the patched B-hwe kernel can fix this issue.

== Regression Potential ==
Low, change limited to p54usb driver, patch tested with positive test result.

== Original Bug Report ==

I am using the Product: Dell Wireless 1450 Dual-band (802.11a/b/g) USB 2.0 Adapter

This relies on the p54usb driver. It works great on kernel 4.18. I upgraded to 5.0.0-3 and the device fails to start.

On the older kernel, things seem good:

[ 1255.546620] usb 3-1: new high-speed USB device number 3 using xhci_hcd
[ 1255.704106] usb 3-1: New USB device found, idVendor=413c, idProduct=8104, bcdDevice=10.50
[ 1255.704110] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1255.704112] usb 3-1: Product: Dell Wireless 1450 Dual-band (802.11a/b/g) USB 2.0 Adapter
[ 1255.704115] usb 3-1: Manufacturer: DELL
[ 1255.830808] usb 3-1: reset high-speed USB device number 3 using xhci_hcd
[ 1255.979753] usb 3-1: Loading firmware file isl3887usb
[ 1255.980055] ieee80211 phy1: p54 detected a LM87 firmware
[ 1255.980058] p54: rx_mtu reduced from 3240 to 2384
[ 1255.980060] ieee80211 phy1: FW rev 2.13.25.0 - Softmac protocol 5.9
[ 1255.980063] ieee80211 phy1: cryptographic accelerator WEP:YES, TKIP:YES, CCMP:YES
[ 1256.974586] ieee80211 phy1: hwaddr 00:14:a5:c6:56:ca, MAC:isl3892 RF:Xbow
[ 1256.976368] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
[ 1256.976974] usb 3-1: is registered as 'phy1'
[ 1256.981866] p54usb 3-1:1.0 wlx0014a5c656ca: renamed from wlan0

I'm using:

Description: Ubuntu 18.04.3 LTS
Release: 18.04

Dee Raj (deker0) wrote :
Download full text (18.7 KiB)

Aug 8 23:09:17 airbnb-desktop kernel: [ 15.932908] usbcore: registered new interface driver p54usb
Aug 8 23:09:17 airbnb-desktop kernel: [ 15.998959] ieee80211 phy0: p54 detected a LM87 firmware
Aug 8 23:09:17 airbnb-desktop kernel: [ 15.998960] p54: rx_mtu reduced from 3240 to 2384
Aug 8 23:09:17 airbnb-desktop kernel: [ 16.239810] RIP: 0010:p54_tx_pending+0x128/0x1b0 [p54common]
Aug 8 23:09:17 airbnb-desktop kernel: [ 16.239822] p54_tx+0x1e/0x30 [p54common]
Aug 8 23:09:17 airbnb-desktop kernel: [ 16.239824] p54_download_eeprom+0xca/0x140 [p54common]
Aug 8 23:09:17 airbnb-desktop kernel: [ 16.239825] p54_read_eeprom+0x8c/0xc0 [p54common]
Aug 8 23:09:17 airbnb-desktop kernel: [ 16.239827] p54u_load_firmware_cb+0x140/0x1f0 [p54usb]
Aug 8 23:09:17 airbnb-desktop kernel: [ 16.239840] Modules linked in: p54usb p54common mac80211 cfg80211 snd_hda_intel snd_hda_codec snd_hda_core snd_hwdep input_leds i915 snd_pcm intel_rapl x86_pkg_temp_thermal intel_powerclamp kvmgt vfio_mdev snd_seq_midi mdev coretemp vfio_iommu_type1 snd_seq_midi_event vfio snd_rawmidi kvm drm_kms_helper irqbypass drm snd_seq i2c_algo_bit snd_seq_device fb_sys_fops snd_timer syscopyarea crct10dif_pclmul crc32_pclmul sysfillrect ghash_clmulni_intel sysimgblt aesni_intel snd soundcore mei_me aes_x86_64 crypto_simd mei cryptd glue_helper lpc_ich ie31200_edac intel_cstate intel_rapl_perf mac_hid wmi_bmof sch_fq_codel parport_pc ppdev lp parport ip_tables x_tables autofs4 hid_generic usbhid hid e1000e ahci libahci wmi video
Aug 8 23:09:17 airbnb-desktop kernel: [ 16.239859] RIP: 0010:p54_tx_pending+0x128/0x1b0 [p54common]
Aug 8 23:13:05 airbnb-desktop kernel: [ 256.789506] ieee80211 phy1: p54 detected a LM87 firmware
Aug 8 23:13:05 airbnb-desktop kernel: [ 256.789510] p54: rx_mtu reduced from 3240 to 2384
Aug 8 23:13:05 airbnb-desktop kernel: [ 256.990501] RIP: 0010:p54_tx_pending+0x128/0x1b0 [p54common]
Aug 8 23:13:05 airbnb-desktop kernel: [ 256.990529] p54_tx+0x1e/0x30 [p54common]
Aug 8 23:13:05 airbnb-desktop kernel: [ 256.990533] p54_download_eeprom+0xca/0x140 [p54common]
Aug 8 23:13:05 airbnb-desktop kernel: [ 256.990537] p54_read_eeprom+0x8c/0xc0 [p54common]
Aug 8 23:13:05 airbnb-desktop kernel: [ 256.990541] p54u_load_firmware_cb+0x140/0x1f0 [p54usb]
Aug 8 23:13:05 airbnb-desktop kernel: [ 256.990568] Modules linked in: snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_codec_generic ledtrig_audio p54usb p54common mac80211 cfg80211 snd_hda_intel snd_hda_codec snd_hda_core snd_hwdep input_leds i915 snd_pcm intel_rapl x86_pkg_temp_thermal intel_powerclamp kvmgt vfio_mdev snd_seq_midi mdev coretemp vfio_iommu_type1 snd_seq_midi_event vfio snd_rawmidi kvm drm_kms_helper irqbypass drm snd_seq i2c_algo_bit snd_seq_device fb_sys_fops snd_timer syscopyarea crct10dif_pclmul crc32_pclmul sysfillrect ghash_clmulni_intel sysimgblt aesni_intel snd soundcore mei_me aes_x86_64 crypto_simd mei cryptd glue_helper lpc_ich ie31200_edac intel_cstate intel_rapl_perf mac_hid wmi_bmof sch_fq_codel parport_pc ppdev lp parport ip_tables x_tables autofs4 hid_generic usbhid hid e1000e ahci libahci wmi video
Aug 8 23:13:05 airbnb-desktop kernel: [ 25...

Po-Hsu Lin (cypressyew) on 2019-08-12
Changed in linux-hwe (Ubuntu):
assignee: nobody → Po-Hsu Lin (cypressyew)
Po-Hsu Lin (cypressyew) wrote :

Hello, can you give this B-hwe kernel a try:
https://people.canonical.com/~phlin/kernel/lp-1839693-p54usb/B-hwe/

Thanks

Changed in linux-hwe (Ubuntu):
status: New → Incomplete

 Hi there, sure I’m happy to try it. But I am a bit of a newbie, so I need exact steps on how to install this kernel and even better perhaps a screen share or some other way to communicate with someone while I am doing it. Thank you.

    On Monday, August 12, 2019, 3:30:48 AM EDT, Po-Hsu Lin <email address hidden> wrote:

 Hello, can you give this B-hwe kernel a try:
https://people.canonical.com/~phlin/kernel/lp-1839693-p54usb/B-hwe/

Thanks

** Changed in: linux-hwe (Ubuntu)
      Status: New => Incomplete

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1839693

Title:
  p54usb module in linux-modules-extra-5.0.0-23-generic does not work

Status in linux-hwe package in Ubuntu:
  Incomplete

Bug description:
  I am using the Product: Dell Wireless 1450 Dual-band (802.11a/b/g) USB
  2.0 Adapter

  This relies on the p54usb driver. It works great on kernel 4.18. I
  upgraded to 5.0.0-3 and the device fails to start.

  On the older kernel, things seem good:

  [ 1255.546620] usb 3-1: new high-speed USB device number 3 using xhci_hcd
  [ 1255.704106] usb 3-1: New USB device found, idVendor=413c, idProduct=8104, bcdDevice=10.50
  [ 1255.704110] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
  [ 1255.704112] usb 3-1: Product: Dell Wireless 1450 Dual-band (802.11a/b/g) USB 2.0 Adapter
  [ 1255.704115] usb 3-1: Manufacturer: DELL
  [ 1255.830808] usb 3-1: reset high-speed USB device number 3 using xhci_hcd
  [ 1255.979753] usb 3-1: Loading firmware file isl3887usb
  [ 1255.980055] ieee80211 phy1: p54 detected a LM87 firmware
  [ 1255.980058] p54: rx_mtu reduced from 3240 to 2384
  [ 1255.980060] ieee80211 phy1: FW rev 2.13.25.0 - Softmac protocol 5.9
  [ 1255.980063] ieee80211 phy1: cryptographic accelerator WEP:YES, TKIP:YES, CCMP:YES
  [ 1256.974586] ieee80211 phy1: hwaddr 00:14:a5:c6:56:ca, MAC:isl3892 RF:Xbow
  [ 1256.976368] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
  [ 1256.976974] usb 3-1: is registered as 'phy1'
  [ 1256.981866] p54usb 3-1:1.0 wlx0014a5c656ca: renamed from wlan0

  I'm using:

  Description:    Ubuntu 18.04.3 LTS
  Release:    18.04

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-hwe/+bug/1839693/+subscriptions

Po-Hsu Lin (cypressyew) wrote :

Hi,
Please:
1. Create a new directory in your file browser
2. Download all the *.deb file in the link, put them into that new directory.
3. In that directory, right click (not on files, but anywhere else) will show you an option "Open in Terminal"
4. In the newly opened terminal, execute the following command: "sudo dpkg -i *.deb"
5. After it's done, reboot and see if the p52usb module works for you or not.

This test kernel installed on your system will be removed in the future during the upgrade process.

Thanks

Dee Raj (deker0) wrote :

 Thank you so much for the detailed steps. I will try this tonight and let you know if the USB wifi card starts working again.

    On Monday, August 12, 2019, 11:00:44 PM EDT, Po-Hsu Lin <email address hidden> wrote:

 Hi,
Please:
1. Create a new directory in your file browser
2. Download all the *.deb file in the link, put them into that new directory.
3. In that directory, right click (not on files, but anywhere else) will show you an option "Open in Terminal"
4. In the newly opened terminal, execute the following command: "sudo dpkg -i *.deb"
5. After it's done, reboot and see if the p52usb module works for you or not.

This test kernel installed on your system will be removed in the future
during the upgrade process.

Thanks

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1839693

Title:
  p54usb module in linux-modules-extra-5.0.0-23-generic does not work

Status in linux-hwe package in Ubuntu:
  Incomplete

Bug description:
  I am using the Product: Dell Wireless 1450 Dual-band (802.11a/b/g) USB
  2.0 Adapter

  This relies on the p54usb driver. It works great on kernel 4.18. I
  upgraded to 5.0.0-3 and the device fails to start.

  On the older kernel, things seem good:

  [ 1255.546620] usb 3-1: new high-speed USB device number 3 using xhci_hcd
  [ 1255.704106] usb 3-1: New USB device found, idVendor=413c, idProduct=8104, bcdDevice=10.50
  [ 1255.704110] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
  [ 1255.704112] usb 3-1: Product: Dell Wireless 1450 Dual-band (802.11a/b/g) USB 2.0 Adapter
  [ 1255.704115] usb 3-1: Manufacturer: DELL
  [ 1255.830808] usb 3-1: reset high-speed USB device number 3 using xhci_hcd
  [ 1255.979753] usb 3-1: Loading firmware file isl3887usb
  [ 1255.980055] ieee80211 phy1: p54 detected a LM87 firmware
  [ 1255.980058] p54: rx_mtu reduced from 3240 to 2384
  [ 1255.980060] ieee80211 phy1: FW rev 2.13.25.0 - Softmac protocol 5.9
  [ 1255.980063] ieee80211 phy1: cryptographic accelerator WEP:YES, TKIP:YES, CCMP:YES
  [ 1256.974586] ieee80211 phy1: hwaddr 00:14:a5:c6:56:ca, MAC:isl3892 RF:Xbow
  [ 1256.976368] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
  [ 1256.976974] usb 3-1: is registered as 'phy1'
  [ 1256.981866] p54usb 3-1:1.0 wlx0014a5c656ca: renamed from wlan0

  I'm using:

  Description:    Ubuntu 18.04.3 LTS
  Release:    18.04

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-hwe/+bug/1839693/+subscriptions

Dee Raj (deker0) wrote :

Hi Po-Hsu, thank you so much! Those instructions worked perfectly and the device is now working on the new kernel.
This is the kernel version: Linux desktop 5.0.0-25-generic #26~18.04.1 SMP Mon Aug 12 06:16:39 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

If you give any credit to me for reporting/finding this bug, you can credit D E K E R, but please do not put my real name.

Thank you so much, I appreciate all of your help and the quick fix.

--D

    On Wednesday, August 14, 2019, 10:21:27 AM EDT, Diego <email address hidden> wrote:

  Thank you so much for the detailed steps. I will try this tonight and let you know if the USB wifi card starts working again.

    On Monday, August 12, 2019, 11:00:44 PM EDT, Po-Hsu Lin <email address hidden> wrote:

 Hi,
Please:
1. Create a new directory in your file browser
2. Download all the *.deb file in the link, put them into that new directory.
3. In that directory, right click (not on files, but anywhere else) will show you an option "Open in Terminal"
4. In the newly opened terminal, execute the following command: "sudo dpkg -i *.deb"
5. After it's done, reboot and see if the p52usb module works for you or not.

This test kernel installed on your system will be removed in the future
during the upgrade process.

Thanks

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1839693

Title:
  p54usb module in linux-modules-extra-5.0.0-23-generic does not work

Status in linux-hwe package in Ubuntu:
  Incomplete

Bug description:
  I am using the Product: Dell Wireless 1450 Dual-band (802.11a/b/g) USB
  2.0 Adapter

  This relies on the p54usb driver. It works great on kernel 4.18. I
  upgraded to 5.0.0-3 and the device fails to start.

  On the older kernel, things seem good:

  [ 1255.546620] usb 3-1: new high-speed USB device number 3 using xhci_hcd
  [ 1255.704106] usb 3-1: New USB device found, idVendor=413c, idProduct=8104, bcdDevice=10.50
  [ 1255.704110] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
  [ 1255.704112] usb 3-1: Product: Dell Wireless 1450 Dual-band (802.11a/b/g) USB 2.0 Adapter
  [ 1255.704115] usb 3-1: Manufacturer: DELL
  [ 1255.830808] usb 3-1: reset high-speed USB device number 3 using xhci_hcd
  [ 1255.979753] usb 3-1: Loading firmware file isl3887usb
  [ 1255.980055] ieee80211 phy1: p54 detected a LM87 firmware
  [ 1255.980058] p54: rx_mtu reduced from 3240 to 2384
  [ 1255.980060] ieee80211 phy1: FW rev 2.13.25.0 - Softmac protocol 5.9
  [ 1255.980063] ieee80211 phy1: cryptographic accelerator WEP:YES, TKIP:YES, CCMP:YES
  [ 1256.974586] ieee80211 phy1: hwaddr 00:14:a5:c6:56:ca, MAC:isl3892 RF:Xbow
  [ 1256.976368] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
  [ 1256.976974] usb 3-1: is registered as 'phy1'
  [ 1256.981866] p54usb 3-1:1.0 wlx0014a5c656ca: renamed from wlan0

  I'm using:

  Description:    Ubuntu 18.04.3 LTS
  Release:    18.04

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-hwe/+bug/1839693/+subscriptions

Po-Hsu Lin (cypressyew) on 2019-08-15
affects: linux-hwe (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu Eoan):
status: Incomplete → Fix Released
Changed in linux (Ubuntu Disco):
status: New → In Progress
assignee: nobody → Po-Hsu Lin (cypressyew)
Changed in linux (Ubuntu Eoan):
assignee: Po-Hsu Lin (cypressyew) → nobody
tags: added: disco
Po-Hsu Lin (cypressyew) wrote :

Hi,
thanks for the test, I will SRU this so people can get this fix from updates.

https://lists.ubuntu.com/archives/kernel-team/2019-August/103116.html

description: updated
description: updated
Dee Raj (deker0) wrote :
Download full text (8.4 KiB)

 Hi there, I hope all is well. I wanted to let you know that something odd keeps happening now with the updated packages you sent me.
After about one week of use, the USB card stopped working. I thought maybe I had run some software update and overwrite your files. So, I ran the command you gave me ("sudo dpkg -i *.deb") and restored the packages you sent.
After another week, the same thing happened again - this time I am positive that I did not run any software updates and yet the USB card once again stopped working. I again ran "sudo dpkg -i *.deb" and restored your files and rebooted. It started working same as normal.
So, I decided to write to you and let you know this. I have no idea why it's happening, but two times cannot be a fluke.

Thanks, D E K E R
    On Thursday, August 15, 2019, 01:30:51 AM EDT, Po-Hsu Lin <email address hidden> wrote:

 Hi,
thanks for the test, I will SRU this so people can get this fix from updates.

https://lists.ubuntu.com/archives/kernel-team/2019-August/103116.html

** Description changed:

+ == SRU Justification ==
+ User report that the p54usb driver will crash when trying to load it on 5.0 kernel for a Dell Wireless 1450 Dual-band (802.11a/b/g) USB 2.0 adapter. This was caused by commit e3554197 (p54: Use skb_peek_tail() instead of direct head pointer accesses.)
+
+ == Fix ==
+ * 1645ab93 (p54: fix crash during initialization)
+
+ This patch added a check for target_skb to determine where to queue the buffer. It can be cherry-picked into Disco.
+ Eoan got this patch from v5.2.1 upstream stable release update.
+
+ == Test ==
+ Test kernel could be found here:
+ https://people.canonical.com/~phlin/kernel/lp-1839693-p54usb/
+
+ This issue was reported against Bionic HWE 5.0 kernel, user confirmed
+ that the patched B-hwe kernel works as expected.
+
+ == Regression Potential ==
+ Low, change limited to p54usb driver, patch tested with positive test result.
+
+
+ == Original Bug Report ==
+
  I am using the Product: Dell Wireless 1450 Dual-band (802.11a/b/g) USB
  2.0 Adapter

  This relies on the p54usb driver. It works great on kernel 4.18. I
  upgraded to 5.0.0-3 and the device fails to start.

  On the older kernel, things seem good:

  [ 1255.546620] usb 3-1: new high-speed USB device number 3 using xhci_hcd
  [ 1255.704106] usb 3-1: New USB device found, idVendor=413c, idProduct=8104, bcdDevice=10.50
  [ 1255.704110] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
  [ 1255.704112] usb 3-1: Product: Dell Wireless 1450 Dual-band (802.11a/b/g) USB 2.0 Adapter
  [ 1255.704115] usb 3-1: Manufacturer: DELL
  [ 1255.830808] usb 3-1: reset high-speed USB device number 3 using xhci_hcd
  [ 1255.979753] usb 3-1: Loading firmware file isl3887usb
  [ 1255.980055] ieee80211 phy1: p54 detected a LM87 firmware
  [ 1255.980058] p54: rx_mtu reduced from 3240 to 2384
  [ 1255.980060] ieee80211 phy1: FW rev 2.13.25.0 - Softmac protocol 5.9
  [ 1255.980063] ieee80211 phy1: cryptographic accelerator WEP:YES, TKIP:YES, CCMP:YES
  [ 1256.974586] ieee80211 phy1: hwaddr 00:14:a5:c6:56:ca, MAC:isl3892 RF:Xbow
  [ 1256.976368] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
  ...

Read more...

Po-Hsu Lin (cypressyew) wrote :

Hi,
this temporary deb package will be replaced by the one in the updates.

So yes, running a dist-upgrade command to install a newer kernel will overwrite it.
And even if you try to install it again, if you didn't select to boot with this kernel you will be still using the latest kernel in the update.

The latest kernel will have this issue as this patch haven't land in our kernel tree yet, please follow this bug with the bug status (still in "in-progress" for Disco 5.0 kernel), this would probably land in the next sru-cycle.
Thanks.

Changed in linux (Ubuntu Disco):
status: In Progress → Fix Committed

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-disco' to 'verification-done-disco'. If the problem still exists, change the tag 'verification-needed-disco' to 'verification-failed-disco'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-disco
Dee Raj (deker0) wrote :
Download full text (3.6 KiB)

 If further testing is needed, send me the updated kernel files and I’ll install on my PC and test.

    On Friday, September 6, 2019, 9:11:39 AM EDT, Ubuntu Kernel Bot <email address hidden> wrote:

 This bug is awaiting verification that the kernel in -proposed solves
the problem. Please test the kernel and update this bug with the
results. If the problem is solved, change the tag 'verification-needed-
disco' to 'verification-done-disco'. If the problem still exists, change
the tag 'verification-needed-disco' to 'verification-failed-disco'.

If verification is not done by 5 working days from today, this fix will
be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how
to enable and use -proposed. Thank you!

** Tags added: verification-needed-disco

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1839693

Title:
  p54usb module in linux-modules-extra-5.0.0-23-generic does not work

Status in linux package in Ubuntu:
  Fix Released
Status in linux source package in Disco:
  Fix Committed
Status in linux source package in Eoan:
  Fix Released

Bug description:
  == SRU Justification ==
  User report that the p54usb driver will crash when trying to load it on 5.0 kernel for a Dell Wireless 1450 Dual-band (802.11a/b/g) USB 2.0 adapter. This was caused by commit e3554197 (p54: Use skb_peek_tail() instead of direct head pointer accesses.)

  == Fix ==
  * 1645ab93 (p54: fix crash during initialization)

  This patch added a check for target_skb to determine where to queue the buffer. It can be cherry-picked into Disco.
  Eoan got this patch from v5.2.1 upstream stable release update.

  == Test ==
  Test kernel could be found here:
  https://people.canonical.com/~phlin/kernel/lp-1839693-p54usb/

  This issue was reported against Bionic HWE 5.0 kernel, user confirmed
  that the patched B-hwe kernel can fix this issue.

  == Regression Potential ==
  Low, change limited to p54usb driver, patch tested with positive test result.

  == Original Bug Report ==

  I am using the Product: Dell Wireless 1450 Dual-band (802.11a/b/g) USB
  2.0 Adapter

  This relies on the p54usb driver. It works great on kernel 4.18. I
  upgraded to 5.0.0-3 and the device fails to start.

  On the older kernel, things seem good:

  [ 1255.546620] usb 3-1: new high-speed USB device number 3 using xhci_hcd
  [ 1255.704106] usb 3-1: New USB device found, idVendor=413c, idProduct=8104, bcdDevice=10.50
  [ 1255.704110] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
  [ 1255.704112] usb 3-1: Product: Dell Wireless 1450 Dual-band (802.11a/b/g) USB 2.0 Adapter
  [ 1255.704115] usb 3-1: Manufacturer: DELL
  [ 1255.830808] usb 3-1: reset high-speed USB device number 3 using xhci_hcd
  [ 1255.979753] usb 3-1: Loading firmware file isl3887usb
  [ 1255.980055] ieee80211 phy1: p54 detected a LM87 firmware
  [ 1255.980058] p54: rx_mtu reduced from 3240 to 2384
  [ 1255.980060] ieee80211 phy1: FW rev 2.13.25.0 - Softmac protocol 5.9
  [ 1255.980063] ieee80211 phy1: cryptographic accelerator WEP:YES, TKIP:YES, CCM...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers