Wifi stops responding sporadically on lenovo-yoga-720-15ikb

Bug #1838208 reported by Asif Youssuff on 2019-07-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

I can make this happen by trying to upload a large file using Firefox Nightly to https://send.firefox.com/ Within a few seconds (like 10-15) my wifi stops responding.

Restarting network manager via service network-manager restart temporarily resolves the issue.

This issue began appearing a week or so ago -- almost definitely not a month ago; my wifi used to be fine previously.

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: network-manager 1.18.0-1ubuntu5
ProcVersionSignature: Ubuntu 5.2.0-8.9-generic 5.2.0
Uname: Linux 5.2.0-8-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sun Jul 28 14:59:13 2019
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2018-10-31 (270 days ago)
InstallationMedia: Ubuntu 18.10 "Cosmic Cuttlefish" - Release amd64 (20181017.3)
IpRoute:
 default via 192.168.69.1 dev wlp1s0 proto dhcp metric 600
 169.254.0.0/16 dev wlp1s0 scope link metric 1000
 192.168.69.0/24 dev wlp1s0 proto kernel scope link src 192.168.69.45 metric 600
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager
UpgradeStatus: Upgraded to eoan on 2018-11-02 (268 days ago)
nmcli-dev:
 DEVICE TYPE STATE IP4-CONNECTIVITY IP6-CONNECTIVITY DBUS-PATH CONNECTION CON-UUID CON-PATH
 wlp1s0 wifi connected full limited /org/freedesktop/NetworkManager/Devices/2 dd-wrt-vap-5g 1 21dd3ba5-f26c-434a-8a95-a87ddd1eb8d5 /org/freedesktop/NetworkManager/ActiveConnection/1
 p2p-dev-wlp1s0 wifi-p2p disconnected none none /org/freedesktop/NetworkManager/Devices/3 -- -- --
 lo loopback unmanaged unknown unknown /org/freedesktop/NetworkManager/Devices/1 -- -- --
nmcli-nm:
 RUNNING VERSION STATE STARTUP CONNECTIVITY NETWORKING WIFI-HW WIFI WWAN-HW WWAN
 running 1.18.0 connected started full enabled enabled enabled enabled enabled
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: asif 1938 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 19.10
InstallationDate: Installed on 2018-10-31 (276 days ago)
InstallationMedia: Ubuntu 18.10 "Cosmic Cuttlefish" - Release amd64 (20181017.3)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 004: ID 13d3:5621 IMC Networks EasyCamera
 Bus 001 Device 003: ID 06cb:0081 Synaptics, Inc.
 Bus 001 Device 002: ID 8087:0a2b Intel Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: LENOVO 80X7
NonfreeKernelModules: wl
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.2.0-8-generic root=UUID=6c974fe8-3286-438d-9acd-d422be92ad9f ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 5.2.0-8.9-generic 5.2.0
RelatedPackageVersions:
 linux-restricted-modules-5.2.0-8-generic N/A
 linux-backports-modules-5.2.0-8-generic N/A
 linux-firmware 1.181
Tags: eoan wayland-session
Uname: Linux 5.2.0-8-generic x86_64
UpgradeStatus: Upgraded to eoan on 2018-11-02 (273 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 07/19/2018
dmi.bios.vendor: LENOVO
dmi.bios.version: 4MCN33WW(V2.05)
dmi.board.asset.tag: NO Asset Tag
dmi.board.name: LNVNB161216
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40709 WIN
dmi.chassis.asset.tag: NO Asset Tag
dmi.chassis.type: 31
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo YOGA 720-15IKB
dmi.modalias: dmi:bvnLENOVO:bvr4MCN33WW(V2.05):bd07/19/2018:svnLENOVO:pn80X7:pvrLenovoYOGA720-15IKB:rvnLENOVO:rnLNVNB161216:rvrSDK0J40709WIN:cvnLENOVO:ct31:cvrLenovoYOGA720-15IKB:
dmi.product.family: YOGA 720-15IKB
dmi.product.name: 80X7
dmi.product.sku: LENOVO_MT_80X7_BU_idea_FM_YOGA 720-15IKB
dmi.product.version: Lenovo YOGA 720-15IKB
dmi.sys.vendor: LENOVO

Asif Youssuff (yoasif) wrote :
summary: - Wifi stops responding sporadically
+ Wifi stops responding sporadically on lenovo-yoga-720-15ikb
affects: network-manager (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1838208

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Hui Wang (hui.wang) wrote :

What is the kernel module wl for? where is it in the /lib/modules/'uname -r'/?

cd /lib/modules/`uname -r`
find . -iname wl.ko

Kernel modules: iwlwifi, wl

Asif Youssuff (yoasif) wrote :

find . -iname wl.ko
./updates/dkms/wl.ko

Asif Youssuff (yoasif) wrote :

The module seems to be bcmwl

git bisect log
# bad: [ba36ad4f039514bc76d7ae37ebcea550349c98b5] UBUNTU: Ubuntu-5.2.0-8.9
# good: [f7908af84a9feac82717574870591fd09e8eeeb2] UBUNTU: Ubuntu-5.0.0-21.22
git bisect start 'Ubuntu-5.2.0-8.9' 'Ubuntu-5.0.0-21.22'
# good: [1c163f4c7b3f621efff9b28a47abb36f7378d783] Linux 5.0
git bisect good 1c163f4c7b3f621efff9b28a47abb36f7378d783
# skip: [6e865c7230140126cbac62e0aef5807108e46e63] Merge tag 'drm/tegra/for-5.2-rc1' of git://anongit.freedesktop.org/tegra/linux into drm-next
git bisect skip 6e865c7230140126cbac62e0aef5807108e46e63
# good: [77476360f173c127c191bfe8ca8113130ef283b8] drm/amd/display: Disconnect mpcc when changing tg
git bisect good 77476360f173c127c191bfe8ca8113130ef283b8
# bad: [422449238e9853458283beffed77562d4b40a2fa] Merge branch 'drm-next-5.2' of git://people.freedesktop.org/~agd5f/linux into drm-next
git bisect bad 422449238e9853458283beffed77562d4b40a2fa
# bad: [b5dd0c658c31b469ccff1b637e5124851e7a4a1c] Merge branch 'akpm' (patches from Andrew)
git bisect bad b5dd0c658c31b469ccff1b637e5124851e7a4a1c
# bad: [3478588b5136966c80c571cf0006f08e9e5b8f04] Merge branch 'locking-core-for-linus' of git://git.kernel.org/pub/scm/linux/kernel/git/tip/tip
git bisect bad 3478588b5136966c80c571cf0006f08e9e5b8f04
# good: [1a2566085650be593d464c4d73ac2d20ff67c058] Merge tag 'wireless-drivers-next-for-davem-2019-02-22' of git://git.kernel.org/pub/scm/linux/kernel/git/kvalo/wireless-drivers-next
git bisect good 1a2566085650be593d464c4d73ac2d20ff67c058
# bad: [18a4d8bf250a33c015955f0dec27259780ef6448] Merge git://git.kernel.org/pub/scm/linux/kernel/git/davem/net
git bisect bad 18a4d8bf250a33c015955f0dec27259780ef6448
# bad: [844f01da9301a71fbed1e768837f4a1a6aa60529] mlxsw: spectrum_acl: Put vchunk migrate start/end code into separate functions
git bisect bad 844f01da9301a71fbed1e768837f4a1a6aa60529
# bad: [e8b47b53a172e74dd9907eb7810f02a1d09fb29b] Merge branch 'for-upstream' of git://git.kernel.org/pub/scm/linux/kernel/git/bluetooth/bluetooth-next
git bisect bad e8b47b53a172e74dd9907eb7810f02a1d09fb29b
# bad: [6ca5081526228571a70ef0160fd44da3fe661ccb] net: dsa: microchip: remove unnecessary include headers
git bisect bad 6ca5081526228571a70ef0160fd44da3fe661ccb
# bad: [515d846773b05972b621675bbb344b9f80d47f26] Merge branch 'net-phy-aquantia-improve-and-extend-driver'
git bisect bad 515d846773b05972b621675bbb344b9f80d47f26
# bad: [9ce8439718b6dfef2509dc72ec841740b14cc6d5] mlxsw: reg: Add new port type-speed fields for PTYS register
git bisect bad 9ce8439718b6dfef2509dc72ec841740b14cc6d5
# good: [923b55cf5078f2fe2f11d1b3a9b3d5ecf07a5efc] Merge branch 'net-Wformat-fixes'
git bisect good 923b55cf5078f2fe2f11d1b3a9b3d5ecf07a5efc
# bad: [1e2f66ecebd30b6c0a455a5a46dedb957a6ccc50] mlxsw: spectrum: Query port connector type from firmware
git bisect bad 1e2f66ecebd30b6c0a455a5a46dedb957a6ccc50
# good: [1531be31973a23f97bd8844393cfd387e4647c8c] mlxsw: spectrum: Remove duplicate port link mode entry
git bisect good 1531be31973a23f97bd8844393cfd387e4647c8c

I'm not 100% this is the exact commit since it may be broken but not apparent in my testing.

Hope this helps.

Kai-Heng Feng (kaihengfeng) wrote :
Asif Youssuff (yoasif) wrote :

I am still seeing the issue in the latest mainline kernel -

uname -a
Linux Lenovo-YOGA-720-15IKB 5.3.0-050300rc3-generic #201908042232 SMP Mon Aug 5 02:36:00 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Asif Youssuff (yoasif) wrote :

Sorry, how do I install this? I don't want to mess anything up.

Asif Youssuff (yoasif) wrote :

Hi, this is still an issue -- can you provide some instructions on how to install the Linux firmware on Ubuntu? I can follow instructions. Thanks!

Kai-Heng Feng (kaihengfeng) wrote :

I always "mess" everything up by copying all files to /lib/firmware/.

Run `sudo apt --reinstall install linux-firmware` to install firmware from ubuntu archive.

Asif Youssuff (yoasif) wrote :

I copied the contents of linux-firmware-20190815 to /lib/firmware/ and rebooted with the v5.3-rc3 kernel.

The issue persists in this configuration. Wifi drops periodically and I must restart network-manager to be able to use it.

Kai-Heng Feng (kaihengfeng) wrote :

If restarting network-manager can fix the issue then it's less likely to be a kernel bug.

Kai-Heng Feng (kaihengfeng) wrote :

Can you please still attach dmesg with latest kernel/firmware when the issue happens?

Asif Youssuff (yoasif) wrote :

I will note that sometimes, restarting network-manager doesn't work, especially if I have put the machine to sleep prior to trying to access the network. Here's a dmesg where it did come back after network-manager restart.

Asif Youssuff (yoasif) wrote :
Download full text (4.5 KiB)

On 5.2.0-15-generic my WiFi stopped working and I see this in dmesg.

[52478.783342] iwlwifi 0000:01:00.0: Microcode SW error detected. Restarting 0x2000000.
[52478.783507] iwlwifi 0000:01:00.0: Start IWL Error Log Dump:
[52478.783510] iwlwifi 0000:01:00.0: Status: 0x00000080, count: 6
[52478.783511] iwlwifi 0000:01:00.0: Loaded firmware version: 36.8fd77bb3.0
[52478.783513] iwlwifi 0000:01:00.0: 0x00000EDC | ADVANCED_SYSASSERT
[52478.783514] iwlwifi 0000:01:00.0: 0x00A00220 | trm_hw_status0
[52478.783515] iwlwifi 0000:01:00.0: 0x00000000 | trm_hw_status1
[52478.783516] iwlwifi 0000:01:00.0: 0x0002486C | branchlink2
[52478.783517] iwlwifi 0000:01:00.0: 0x0003A7CE | interruptlink1
[52478.783518] iwlwifi 0000:01:00.0: 0x00000000 | interruptlink2
[52478.783519] iwlwifi 0000:01:00.0: 0x0BE7001C | data1
[52478.783520] iwlwifi 0000:01:00.0: 0x20000606 | data2
[52478.783521] iwlwifi 0000:01:00.0: 0x00000E4C | data3
[52478.783522] iwlwifi 0000:01:00.0: 0x2EC0909D | beacon time
[52478.783523] iwlwifi 0000:01:00.0: 0x55F27F6B | tsf low
[52478.783524] iwlwifi 0000:01:00.0: 0x000003B7 | tsf hi
[52478.783525] iwlwifi 0000:01:00.0: 0x00000000 | time gp1
[52478.783526] iwlwifi 0000:01:00.0: 0xC9EF0F37 | time gp2
[52478.783527] iwlwifi 0000:01:00.0: 0x00000001 | uCode revision type
[52478.783528] iwlwifi 0000:01:00.0: 0x00000024 | uCode version major
[52478.783529] iwlwifi 0000:01:00.0: 0x8FD77BB3 | uCode version minor
[52478.783530] iwlwifi 0000:01:00.0: 0x00000230 | hw version
[52478.783531] iwlwifi 0000:01:00.0: 0x00C89000 | board version
[52478.783532] iwlwifi 0000:01:00.0: 0x20000606 | hcmd
[52478.783533] iwlwifi 0000:01:00.0: 0x24022002 | isr0
[52478.783534] iwlwifi 0000:01:00.0: 0x00000000 | isr1
[52478.783535] iwlwifi 0000:01:00.0: 0x08001802 | isr2
[52478.783536] iwlwifi 0000:01:00.0: 0x00417CC1 | isr3
[52478.783537] iwlwifi 0000:01:00.0: 0x00000000 | isr4
[52478.783538] iwlwifi 0000:01:00.0: 0x0BA8001C | last cmd Id
[52478.783539] iwlwifi 0000:01:00.0: 0x00000000 | wait_event
[52478.783540] iwlwifi 0000:01:00.0: 0x000000C4 | l2p_control
[52478.783541] iwlwifi 0000:01:00.0: 0x00018030 | l2p_duration
[52478.783542] iwlwifi 0000:01:00.0: 0x00000007 | l2p_mhvalid
[52478.783543] iwlwifi 0000:01:00.0: 0x00000081 | l2p_addr_match
[52478.783544] iwlwifi 0000:01:00.0: 0x0000001D | lmpm_pmg_sel
[52478.783545] iwlwifi 0000:01:00.0: 0x29051704 | timestamp
[52478.783546] iwlwifi 0000:01:00.0: 0x00005868 | flow_handler
[52478.783615] iwlwifi 0000:01:00.0: Start IWL Error Log Dump:
[52478.783616] iwlwifi 0000:01:00.0: Status: 0x00000080, count: 7
[52478.783617] iwlwifi 0000:01:00.0: 0x00000070 | NMI_INTERRUPT_LMAC_FATAL
[52478.783618] iwlwifi 0000:01:00.0: 0x00000000 | umac branchlink1
[52478.783619] iwlwifi 0000:01:00.0: 0xC0086934 | umac branchlink2
[52478.783620] iwlwifi 0000:01:00.0: 0xC0083B0C | umac interruptlink1
[52478.783621] iwlwifi 0000:01:00.0: 0xC0083B0C | umac interruptlink2
[52478.783622] iwlwifi 0000:01:00.0: 0x00000800 | umac data1
[52478.783623] iwlwifi 0000:01:00.0: 0xC0083B0C | umac data2
[52478.783624] iwlwifi 0000:01:00.0: 0xDEADBEEF | umac data3
[52478.783624] iwlwifi 0000:01:00.0: 0x00000024 | umac major
[52478.783625] iwlwifi ...

Read more...

Asif Youssuff (yoasif) wrote :

This stopped happening at some point in the last week or so.

Changed in network-manager (Ubuntu):
status: New → Fix Released
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.