Revert x86/vdso linker changes from #1830890 as this causes glibc 2.29-0ubuntu3 FTBFS on eoan

Bug #1834315 reported by Alex Murray on 2019-06-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Xenial
Undecided
Unassigned

Bug Description

[Impact]
As reported in #1833067 and https://bugs.launchpad.net/ubuntu/+source/glibc/+bug/1830890/comments/7 some glibc testcases are still regressing on i386 after applying both the following commits:

commit 379d98ddf41344273d9718556f761420f4dc80b3
Author: Alistair Strachan <email address hidden>
Date: Fri Aug 3 10:39:31 2018 -0700

    x86: vdso: Use $LD instead of $CC to link

commit cd01544a268ad8ee5b1dfe42c4393f1095f86879
Author: Alistair Strachan <email address hidden>
Date: Fri Dec 14 14:36:37 2018 -0800

    x86/vdso: Pass --eh-frame-hdr to the linker

[Fix]
Revert both these patches to restore the original behaviour.

[Test]
ADT tests for glibc.

[Regression Potential]
Low. This restores the status quo before the original change to vdso/x86/Makefile to restore the original linker behaviour.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1834315

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu Xenial):
status: New → Incomplete
tags: added: eoan
Alex Murray (alexmurray) on 2019-06-26
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Alex Murray (alexmurray) on 2019-06-27
tags: removed: eoan
Seth Forshee (sforshee) wrote :

Just to be clear, these are both upstream commits. Is there any work going on upstream to resolve the issue?

Currently eoan is using a kernel copied forward from disco, but we should be putting a 5.2 kernel into eoan-proposed within the next couple of weeks. This is likely to be before we could expect to see them in a disco-proposed kernel, as the patch deadline for the next kernel SRU cycle has passed.

I agree that the likelihood of regressions is slim for us, as the changes were made only to support builds using clang. So I will go ahead and revert these in our 5.2 tree.

I'm not sure why there's a xenial nomination here for a ftbfs in eoan though ...

Changed in linux (Ubuntu Xenial):
assignee: nobody → Seth Forshee (sforshee)
importance: Undecided → Medium
status: Incomplete → In Progress
Seth Forshee (sforshee) wrote :

Applied reverts to the 5.2 kernel tree.

Changed in linux (Ubuntu Xenial):
assignee: Seth Forshee (sforshee) → nobody
importance: Medium → Undecided
status: In Progress → Incomplete
Changed in linux (Ubuntu):
assignee: nobody → Seth Forshee (sforshee)
importance: Undecided → Medium
status: Confirmed → Fix Committed
Alex Murray (alexmurray) wrote :

Seth - the reason this is targeted against xenial is that the launchpad builders are running the 4.4 xenial kernel - and so glibc *from eoan-proposed* FTBFS when building on launchpad - and it would appear to be as a result of this change. Oddly, I cannot reproduce the same failure locally using a xenial VM containing an eoan schroot.

One data point - for me glibc from eoan-proposed builds fine in an eoan schroot running on a bionic host with the hwe-edge kernel - so it is not clear this needs to be reverted for disco/eoan.

Seth Forshee (sforshee) wrote :

Okay, thanks for explaining. I'll remove the reverts from 5.2.

Changed in linux (Ubuntu):
assignee: Seth Forshee (sforshee) → nobody
status: Fix Committed → Invalid
Changed in linux (Ubuntu Xenial):
status: Incomplete → Confirmed
Changed in linux (Ubuntu Xenial):
status: Confirmed → Fix Committed

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-xenial' to 'verification-done-xenial'. If the problem still exists, change the tag 'verification-needed-xenial' to 'verification-failed-xenial'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-xenial
Alex Murray (alexmurray) wrote :

See the attached log showing a successful build of glibc from bionic on the launchpad staging build farm running the proposed kernel (4.4.0-155).

tags: added: verification-done-xenial
removed: verification-needed-xenial
Adam Conrad (adconrad) wrote :

Confirmed in production as well, eoan's glibc now builds again on x86.

Launchpad Janitor (janitor) wrote :
Download full text (30.5 KiB)

This bug was fixed in the package linux - 4.4.0-157.185

---------------
linux (4.4.0-157.185) xenial; urgency=medium

  * linux: 4.4.0-157.185 -proposed tracker (LP: #1837476)

  * systemd 229-4ubuntu21.22 ADT test failure with linux 4.4.0-156.183 (storage)
    (LP: #1837235)
    - Revert "block/bio: Do not zero user pages"
    - Revert "block: Clear kernel memory before copying to user"
    - Revert "bio_copy_from_iter(): get rid of copying iov_iter"

linux (4.4.0-156.183) xenial; urgency=medium

  * linux: 4.4.0-156.183 -proposed tracker (LP: #1836880)

  * BCM43602 802.11ac Wireless regression - PCI ID 14e4:43ba (LP: #1836801)
    - brcmfmac: add eth_type_trans back for PCIe full dongle

linux (4.4.0-155.182) xenial; urgency=medium

  * linux: 4.4.0-155.182 -proposed tracker (LP: #1834918)

  * Geneve tunnels don't work when ipv6 is disabled (LP: #1794232)
    - geneve: correctly handle ipv6.disable module parameter

  * Kernel modules generated incorrectly when system is localized to a non-
    English language (LP: #1828084)
    - scripts: override locale from environment when running recordmcount.pl

  * Handle overflow in proc_get_long of sysctl (LP: #1833935)
    - sysctl: handle overflow in proc_get_long

  * Xenial update: 4.4.181 upstream stable release (LP: #1832661)
    - x86/speculation/mds: Revert CPU buffer clear on double fault exit
    - x86/speculation/mds: Improve CPU buffer clear documentation
    - ARM: exynos: Fix a leaked reference by adding missing of_node_put
    - crypto: vmx - fix copy-paste error in CTR mode
    - crypto: crct10dif-generic - fix use via crypto_shash_digest()
    - crypto: x86/crct10dif-pcl - fix use via crypto_shash_digest()
    - ALSA: usb-audio: Fix a memory leak bug
    - ALSA: hda/hdmi - Consider eld_valid when reporting jack event
    - ALSA: hda/realtek - EAPD turn on later
    - ASoC: max98090: Fix restore of DAPM Muxes
    - ASoC: RT5677-SPI: Disable 16Bit SPI Transfers
    - mm/mincore.c: make mincore() more conservative
    - ocfs2: fix ocfs2 read inode data panic in ocfs2_iget
    - mfd: da9063: Fix OTP control register names to match datasheets for
      DA9063/63L
    - tty/vt: fix write/write race in ioctl(KDSKBSENT) handler
    - ext4: actually request zeroing of inode table after grow
    - ext4: fix ext4_show_options for file systems w/o journal
    - Btrfs: do not start a transaction at iterate_extent_inodes()
    - bcache: fix a race between cache register and cacheset unregister
    - bcache: never set KEY_PTRS of journal key to 0 in journal_reclaim()
    - ipmi:ssif: compare block number correctly for multi-part return messages
    - crypto: gcm - Fix error return code in crypto_gcm_create_common()
    - crypto: gcm - fix incompatibility between "gcm" and "gcm_base"
    - crypto: chacha20poly1305 - set cra_name correctly
    - crypto: salsa20 - don't access already-freed walk.iv
    - crypto: arm/aes-neonbs - don't access already-freed walk.iv
    - writeback: synchronize sync(2) against cgroup writeback membership switches
    - fs/writeback.c: use rcu_barrier() to wait for inflight wb switches going
      into workqueue when umount
    - ALSA: hda/realtek - Fix for Lenovo B...

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) on 2019-07-24
tags: added: cscc
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers