Kernel oops when pairing via bluetooth with cellphone

Bug #183311 reported by Adilson Oliveira on 2008-01-15
36
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by Vytas

Bug Description

Binary package hint: linux-ubuntu-modules-2.6.24-3-generic

Notebook Asus G1 running Hardy Alpha 3, kernel 2.6.24-3-generic. Bluetooth module don't report any errors but when trying to pair with a Motorolla cell phone, the whole process goes well until the message that the pairing was done shows up. At this moment the notebook freezes completely, there's no indication of what the oops is related to. No traces on the logs and even ssh to the box to try to catch something is useless, the system completely freezes becoming irresponsive even to SysRq. The only indication of a kernel oops is the Caps and Scroll leds flashing.
The same pairing procedure worked flawlessly with Gutsy.
I'll be glad to provide more information if requested.

Adilson Oliveira (agoliveira) wrote :

I was able to successfully pair with a Nokia bluetooth headphone so it narrows down a bit I guess.

Vytas (vytas) wrote :

I'm using Dell D620 Latitude laptop, latest hardy kernel (seems to be 2.6.24-5-generic at the moment).

When finishing pairing phone, I also get kernel-panic (lock keys blinking).
I also get the same caps and scroll blinking Adilson did.

$ dmesg | grep Blue
[ 22.851292] Bluetooth: Core ver 2.11
[ 22.851354] Bluetooth: HCI device and connection manager initialized
[ 22.851358] Bluetooth: HCI socket layer initialized
[ 20.788770] Bluetooth: HCI USB driver ver 2.9
[ 30.299517] Bluetooth: L2CAP ver 2.9
[ 30.299521] Bluetooth: L2CAP socket layer initialized
[ 30.439740] Bluetooth: RFCOMM socket layer initialized
[ 30.439757] Bluetooth: RFCOMM TTY layer initialized
[ 30.439760] Bluetooth: RFCOMM ver 1.8

Marking kernel bug confirmed because I reproduced it identically on different hardware
Should be high importance?

Vytas (vytas) wrote :

Still reproducible with 2.6.24-8 kernel and latest updates of today (02 16).

Do you have any ideas how should I debug this problem or find any relevant information?

Hi Guys,

Can you maybe check /var/log/kern.log.0 to see if anything is captured there? It will be really helpful to the kernel team if you could provide any additional log info to help start debugging. Do you notice anything output to a terminal when the Oops occurs? Even if you have to take a digital photo of your computer screen to capture any messages that will be helpful. Thanks.

Changed in linux-ubuntu-modules-2.6.24:
status: New → Incomplete
Vytas (vytas) wrote :

Kernel locks without writing anything to /var/log/kern.log.0 here.

Vytas (vytas) wrote :

The last messages that I can read in system logs (for example /var/log/daemon.log) are:

Feb 20 01:22:26 vytas-laptop NetworkManager: <debug> [1203466946.572525] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/bluetooth_acl_fde750345').
Feb 20 01:22:26 vytas-laptop hcid[5356]: pin_code_request (sba=00:1A:6B:31:33:24, dba=00:0F:DE:75:03:45)

So not much information ;(

Vytas (vytas) wrote :

I am unable to provide any further information, but the bug exists and is reproducible 100% on certain systems, and it is a severe bug (kernel panic, all unsaved data is lost) thus changing to Confirmed.

Changed in linux-ubuntu-modules-2.6.24:
status: Incomplete → Confirmed
Vytas (vytas) wrote :

By the way, this bug is only triggered when initiating connection from a phone (Sony Ericsson T630 in my case).
If I use Browse Device (from BT applet) -> Connect, the pairing goes fine.

Vytas (vytas) wrote :

Still unfixed in Hardy.

Andrew Fenn (andrewfenn) wrote :

I am getting this freeze in Hardy (2.6.24-16-generic) on my Samsung R55 while pairing with my Motorola A1200.

KOPRajs (zdenek-koprivik) wrote :

Hi,
I've got exactly the same bug on my Gentoo desktop PC. Getting kernel panic while pairing with my HTC TyTN WM6. My system is Athlon XP 2200+ and 2.6.24-gentoo-r4 kernel.
Kernel panic ocurs exactly when I send a PIN from the phone and instead of PIN request appearing on my screen I get the panic.
Reproduceable 100%.
Nothing in logs either.
I've tryied to panic it in console without X running to see the kernel panic message, but the backtrace was always totally different! Most times the bug was "Invalid instruction 0000".

I've tryied a few versions of BlueZ from 2.25 to 3.31 and found that it has nothning to do with it, the bug is the same and seems to be in the kernel itself.

I managed to reproduce this on another Gentoo 64-bit system too with 2.6.24-gentoo-r3 kernel, but there it's not happening for the first time, you need to send the PIN few times to get the kernel panic.

Affected devices:
HTC TyTN WM6 phone
Edimax bluetooth 2.0+EDR USB dongle

Some kind of patch would be nice.
Thx

Helle (lapidar-web) wrote :

With kernel 2.6.24-19 this bug still exists.
Pairing is with the mobile phone is possible, but any further action gives the complete freeze like described before:
>>No traces on the logs and even ssh to the box to try to catch something is >>useless, the system completely freezes becoming irresponsive even to SysRq. The >>only indication of a kernel oops is the Caps and Scroll leds flashing.

The only way to synchronize is using the kernel 2.6.25. (IMHO much more stable).

toster (vicmailbox) wrote :

The same problem is with both of my devices HP Ipaq 2210 and Dell Axim x51v. The notification for the pairing just starts disappearing when the system freeze. However, my Sony Ericsson W580i was paired without any problem.

toster@toster-laptop:~$ uname -a
Linux toster-laptop 2.6.24-19-generic #1 SMP Wed Jun 18 14:43:41 UTC 2008 i686 GNU/Linux

toster@toster-laptop:~$ lsb_release -rd
Description: Ubuntu 8.04.1
Release: 8.04

toster@toster-laptop:~$ LANG=C apt-cache policy bluetooth
bluetooth:
  Installed: 3.26-0ubuntu6
  Candidate: 3.26-0ubuntu6
  Version table:
 *** 3.26-0ubuntu6 0
        500 http://archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

toster@toster-laptop:~$ hciconfig -a
hci0: Type: USB
 BD Address: 00:10:C6:F8:B5:5C ACL MTU: 1017:8 SCO MTU: 64:8
 UP RUNNING PSCAN ISCAN
 RX bytes:960 acl:0 sco:0 events:26 errors:0
 TX bytes:354 acl:0 sco:0 commands:26 errors:0
 Features: 0xff 0xff 0x8d 0xfe 0x9b 0xf9 0x00 0x80
 Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
 Link policy: RSWITCH HOLD SNIFF PARK
 Link mode: SLAVE ACCEPT
 Name: 'toster-laptop-0'
 Class: 0x08010c
 Service Classes: Capturing
 Device Class: Computer, Laptop
 HCI Ver: 2.0 (0x3) HCI Rev: 0x204a LMP Ver: 2.0 (0x3) LMP Subver: 0x4127
 Manufacturer: Broadcom Corporation (15)

Zorchenhimer (zorchenhimer) wrote :

I'm getting this error as well. Immediately after the "Device Successfully paired" notification, the kernel panics. Running Ubuntu 8.04 on a Dell M1210 (XPS Laptop) trying to pair up with my Samsung SCH-u740 (Alias) phone.

Anthony Squire (tony11235) wrote :

I had the same thing happen to me today 3 times in a row. Thinkpad T60 with built-in bluetooth, and an LG 8100 phone. Running Hardy of course.

inquinador (pjpmendes) wrote :

I was having these regular freezes, sometimes 3 or 4 time in a row and had to force reboot every time.
Later on i noticed another freeze (this one reproducible) while connecting my WM6 PPC to DUN --activesync... that was already reported.
The following thought came to mind: "What if they are somehow related?"
After disconnecting my bluetooth adapter the random freezes completely disappeared, one week without any freezes...
Is anybody else having random freezes and bluetooth related freezes?

Hi guys,

Just a note that beginning with the Intrepid Ibex 8.10 development cycle the linux-ubuntu-modules package was merged with the linux kernel source package. I'm going to move this forward to the linux package.

Adilson, since you are the original bug reporter, can you confirm this is still an issue with the latest Intrepid Ibex Alpha release - http://www.ubuntu.com/testing . Helle made a comment that 2.6.25 was working so I'm hopeful that the 2.6.26 kernel which Intrepid is using will have similar results. Thanks.

Changed in linux-ubuntu-modules-2.6.24:
status: Confirmed → Incomplete

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Vytas (vytas) wrote :

Seems to be fixed for me with kernel (2.6.27-7-generic) in Intrepid series.

Vytas (vytas) wrote :

How can I mark that package in Hardy is unfixed?
Seems I've done it the wrong way :)

Changed in linux:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers