Touchpad does not respond IdeaPad L340

Bug #1831831 reported by Tristan Walker on 2019-06-06
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Lenovo IdeaPad L-340 upon installing Ubuntu 18.04.2 LTS, all other laptop inputs work except for touchpad. Touchpad does not respond to input of any kind - clicks, gestures, or otherwise.

dmesg | grep -i elan
[ 2.987373] i2c_hid i2c-ELAN0625:00: i2c-ELAN0625:00 supply vdd not found, using dummy regulator

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: linux-image-4.18.0-20-generic 4.18.0-20.21~18.04.1
ProcVersionSignature: Ubuntu 4.18.0-20.21~18.04.1-generic 4.18.20
Uname: Linux 4.18.0-20-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.6
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Jun 5 23:07:23 2019
InstallationDate: Installed on 2019-05-22 (15 days ago)
InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 (20190210)
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-signed-hwe
UpgradeStatus: No upgrade log present (probably fresh install)
---
ProblemType: Bug
ApportVersion: 2.20.9-0ubuntu7.6
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: tristan 1542 F.... pulseaudio
 /dev/snd/pcmC0D0p: tristan 1542 F...m pulseaudio
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 18.04
InstallationDate: Installed on 2019-05-22 (50 days ago)
InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 (20190210)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 04f2:b624 Chicony Electronics Co., Ltd
 Bus 001 Device 004: ID 8087:0aaa Intel Corp.
 Bus 001 Device 002: ID 0461:4d15 Primax Electronics, Ltd Dell Optical Mouse
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: LENOVO 81LG
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.18.0-21-generic root=UUID=c3fb3b60-c7d3-40a8-8787-51781e035183 ro quiet splash vt.handoff=1
ProcVersionSignature: Ubuntu 4.18.0-21.22~18.04.1-generic 4.18.20
RelatedPackageVersions:
 linux-restricted-modules-4.18.0-21-generic N/A
 linux-backports-modules-4.18.0-21-generic N/A
 linux-firmware 1.173.6
Tags: bionic
Uname: Linux 4.18.0-21-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 12/20/2018
dmi.bios.vendor: LENOVO
dmi.bios.version: ATCN14WW
dmi.board.asset.tag: NO Asset Tag
dmi.board.name: LNVNB161216
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40709 WIN
dmi.chassis.asset.tag: NO Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo IdeaPad L340-15IWL
dmi.modalias: dmi:bvnLENOVO:bvrATCN14WW:bd12/20/2018:svnLENOVO:pn81LG:pvrLenovoIdeaPadL340-15IWL:rvnLENOVO:rnLNVNB161216:rvrSDK0J40709WIN:cvnLENOVO:ct10:cvrLenovoIdeaPadL340-15IWL:
dmi.product.family: IdeaPad L340-15IWL
dmi.product.name: 81LG
dmi.product.sku: LENOVO_MT_81LG_BU_idea_FM_IdeaPad L340-15IWL
dmi.product.version: Lenovo IdeaPad L340-15IWL
dmi.sys.vendor: LENOVO

Tristan Walker (quotidius) wrote :
summary: - touchpad does not respond ELAN0625
+ Touchpad does not respond IdeaPad L340
affects: linux-signed-hwe (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1831831

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Kai-Heng Feng (kaihengfeng) wrote :

The latest HWE kernel should support your touchpad. Please run:
$ sudo apt install linux-generic-hwe-18.04-edge

And reboot.

sma (m-0622) wrote :

I did
$ sudo apt install linux-generic-hwe-18.04-edge [Version (5.0.0.20.76)]
and reboot, but the touchpad still doesn't respond.

Because I'm nosy, I booted the Daily-Build-Image "eoan-desktop-amd64" (last modified 2019-07-26) and the touchpad worked. It's a long time until October 2019 but it seems, that the touchpad will work with Ubuntu 19.10.

sma (m-0622) wrote :

Correction to my posting before:
Today I once again run
$ sudo apt install linux-generic-hwe-18.04-edge
and after reboot the touchpad responds! Great.

One problem still exists: rightclick on the touchpad is like leftclick. That means, the context menu doesn't open by rightclick on the touchpad.

sma (m-0622) wrote :

Sorry, my fault. Today I saw in GNOME-Tweaks that the setting for Mouseclick-Emulation was 'Finger' instead of 'Area' (I have a German Version, sorry for not knowing the correct English Words in the menues). Finally I can say, that the Touchpad works perfect in Ubuntu 18.04 LTS by running
$ sudo apt install linux-generic-hwe-18.04-edge

Thanks a lot to Kai-Heng Feng! :-)

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers