runpwtests03 from power_management_tests test suite in LTP failed

Bug #1830362 reported by Po-Hsu Lin on 2019-05-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Po-Hsu Lin
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Issue found on Disco with node glameow:
 startup='Fri May 24 10:57:20 2019'
 /opt/ltp/testcases/bin/runpwtests03.sh: 29: /opt/ltp/testcases/bin/runpwtests03.sh: total_cpus-=1: not found
 find: ‘/sys/devices/system/cpu/cpu40/cpufreq/’: No such file or directory
 /opt/ltp/testcases/bin/runpwtests03.sh: PASS: Checking cpu freq sysfs files
 Power_Management03 1 TPASS: CPUFREQ sysfs tests
 /opt/ltp/testcases/bin/runpwtests03.sh: 55: /opt/ltp/testcases/bin/runpwtests03.sh: total_cpus-=1: not found
 /opt/ltp/testcases/bin/runpwtests03.sh: 62: /opt/ltp/testcases/bin/runpwtests03.sh: cannot create /sys/devices/system/cpu/cpu40/cpufreq/scaling_governor: Directory nonexistent
 /opt/ltp/testcases/bin/runpwtests03.sh: FAIL: Unable to set governor -- performance for cpu40
 /opt/ltp/testcases/bin/runpwtests03.sh: 62: /opt/ltp/testcases/bin/runpwtests03.sh: cannot create /sys/devices/system/cpu/cpu40/cpufreq/scaling_governor: Directory nonexistent
 /opt/ltp/testcases/bin/runpwtests03.sh: FAIL: Unable to set governor -- powersave for cpu40
 Power_Management03 2 TFAIL: Changing governors
 cat: '/sys/devices/system/cpu/cpu*/cpufreq/scaling_available_frequencies': No such file or directory
 /opt/ltp/testcases/bin/runpwtests03.sh: 83: /opt/ltp/testcases/bin/runpwtests03.sh: total_cpus-=1: not found
 /opt/ltp/testcases/bin/runpwtests03.sh: PASS: Changing cpu frequencies
 Power_Management03 3 TPASS: Changing frequncies
 modprobe: invalid option -- 'l'
 modprobe: invalid option -- 'l'
 Power_Management03 4 TPASS: Loading and Unloading of governor kernel modules
 tag=runpwtests03 stime=1558695440 dur=2 exit=exited stat=1 core=no cu=28 cs=7

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: linux-image-5.0.0-15-generic 5.0.0-15.16
ProcVersionSignature: User Name 5.0.0-15.16-generic 5.0.6
Uname: Linux 5.0.0-15-generic x86_64
AlsaDevices:
 total 0
 crw-rw---- 1 root audio 116, 1 May 21 07:49 seq
 crw-rw---- 1 root audio 116, 33 May 21 07:49 timer
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay': 'aplay'
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord': 'arecord'
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CurrentDmesg:

Date: Fri May 24 11:07:37 2019
IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig': 'iwconfig'
MachineType: HP ProLiant DL360 Gen9
PciMultimedia:

ProcFB: 0 mgadrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-15-generic root=UUID=6422cfdd-2a69-4c0b-9784-6809a77ab980 ro
RelatedPackageVersions:
 linux-restricted-modules-5.0.0-15-generic N/A
 linux-backports-modules-5.0.0-15-generic N/A
 linux-firmware 1.178.1
RfKill: Error: [Errno 2] No such file or directory: 'rfkill': 'rfkill'
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/25/2017
dmi.bios.vendor: HP
dmi.bios.version: P89
dmi.board.name: ProLiant DL360 Gen9
dmi.board.vendor: HP
dmi.chassis.type: 23
dmi.chassis.vendor: HP
dmi.modalias: dmi:bvnHP:bvrP89:bd04/25/2017:svnHP:pnProLiantDL360Gen9:pvr:rvnHP:rnProLiantDL360Gen9:rvr:cvnHP:ct23:cvr:
dmi.product.family: ProLiant
dmi.product.name: ProLiant DL360 Gen9
dmi.product.sku: 780020-S01
dmi.sys.vendor: HP

Po-Hsu Lin (cypressyew) wrote :

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1830362

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Po-Hsu Lin (cypressyew) on 2019-06-25
tags: added: cosmic sru-20190603 ubuntu-ltp
Po-Hsu Lin (cypressyew) wrote :

Error caused by the cpu number calculation
http://lists.linux.it/pipermail/ltp/2019-June/012547.html

Changed in ubuntu-kernel-tests:
assignee: nobody → Po-Hsu Lin (cypressyew)
status: New → In Progress
Po-Hsu Lin (cypressyew) wrote :

Another patch to address the modprobe -l issue:
http://lists.linux.it/pipermail/ltp/2019-June/012555.html

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Po-Hsu Lin (cypressyew) on 2019-06-28
Changed in ubuntu-kernel-tests:
status: In Progress → Fix Committed
Po-Hsu Lin (cypressyew) wrote :

Didn't see this anymore.

Changed in ubuntu-kernel-tests:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers