memcg_usage_in_bytes from controllers test suite in LTP failed

Bug #1829984 reported by Po-Hsu Lin
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Fix Released
Undecided
Krzysztof Kozlowski
linux (Ubuntu)
Confirmed
Undecided
Unassigned
Xenial
New
Undecided
Unassigned
Bionic
Confirmed
Undecided
Unassigned
Cosmic
Confirmed
Undecided
Unassigned
linux-aws (Ubuntu)
New
Undecided
Unassigned
Xenial
New
Undecided
Unassigned
Bionic
New
Undecided
Unassigned
Cosmic
New
Undecided
Unassigned

Bug Description

 startup='Wed May 22 05:59:09 2019'
 memcg_usage_in_bytes_test 1 TINFO: Starting test 1
 sh: echo: I/O error
 memcg_usage_in_bytes_test 1 TINFO: set /dev/memcg/memory.use_hierarchy to 0 failed
 memcg_usage_in_bytes_test 1 TINFO: Running memcg_process --mmap-anon -s 4194304
 memcg_usage_in_bytes_test 1 TINFO: Warming up pid: 31689
 memcg_usage_in_bytes_test 1 TINFO: Process is still here after warm up: 31689
 memcg_usage_in_bytes_test 1 TFAIL: memory.usage_in_bytes is 4202496, 4194304 expected
 memcg_usage_in_bytes_test 2 TINFO: Starting test 2
 sh: echo: I/O error
 memcg_usage_in_bytes_test 2 TINFO: set /dev/memcg/memory.use_hierarchy to 0 failed
 memcg_usage_in_bytes_test 2 TCONF: mem+swap is not enabled
 tag=memcg_usage_in_bytes stime=1558504749 dur=1 exit=exited stat=33 core=no cu=5 cs=3

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: linux-image-4.15.0-50-generic 4.15.0-50.54
ProcVersionSignature: User Name 4.15.0-50.54-generic 4.15.18
Uname: Linux 4.15.0-50-generic x86_64
AlsaDevices:
 total 0
 crw-rw---- 1 root audio 116, 1 May 22 02:57 seq
 crw-rw---- 1 root audio 116, 33 May 22 02:57 timer
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay': 'aplay'
ApportVersion: 2.20.9-0ubuntu7.6
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord': 'arecord'
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CurrentDmesg:
 [14538.862950] cfg80211: Loading compiled-in X.509 certificates for regulatory database
 [14538.874559] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
Date: Wed May 22 07:17:43 2019
IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig': 'iwconfig'
Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: QEMU Standard PC (i440FX + PIIX, 1996)
PciMultimedia:

ProcFB: 0 cirrusdrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-50-generic root=UUID=576666e8-9e7f-40ee-934e-f1dce18323e5 ro
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-50-generic N/A
 linux-backports-modules-4.15.0-50-generic N/A
 linux-firmware 1.173.6
RfKill: Error: [Errno 2] No such file or directory: 'rfkill': 'rfkill'
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/01/2014
dmi.bios.vendor: SeaBIOS
dmi.bios.version: Ubuntu-1.8.2-1ubuntu1
dmi.chassis.type: 1
dmi.chassis.vendor: QEMU
dmi.chassis.version: pc-i440fx-xenial
dmi.modalias: dmi:bvnSeaBIOS:bvrUbuntu-1.8.2-1ubuntu1:bd04/01/2014:svnQEMU:pnStandardPC(i440FX+PIIX,1996):pvrpc-i440fx-xenial:cvnQEMU:ct1:cvrpc-i440fx-xenial:
dmi.product.name: Standard PC (i440FX + PIIX, 1996)
dmi.product.version: pc-i440fx-xenial
dmi.sys.vendor: QEMU

Revision history for this message
Po-Hsu Lin (cypressyew) wrote :
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1829984

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu Bionic):
status: New → Incomplete
Po-Hsu Lin (cypressyew)
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu Bionic):
status: Incomplete → Confirmed
Changed in linux (Ubuntu Cosmic):
status: New → Confirmed
Po-Hsu Lin (cypressyew)
Changed in ubuntu-kernel-tests:
status: New → Confirmed
Po-Hsu Lin (cypressyew)
tags: added: ubuntu-ltp
Po-Hsu Lin (cypressyew)
tags: added: linux-kvm sru-20190603
tags: added: cosmic
Sean Feole (sfeole)
tags: added: sru-20190930
Sean Feole (sfeole)
tags: added: sru-20200106
Sean Feole (sfeole)
tags: added: sru-20200217
tags: added: sru-20200921
tags: added: 5.4 aws focal
Revision history for this message
Kelsey Skunberg (kelsey-skunberg) wrote :

Spotted on Focal/linux-azure 5.4.0-1029.29

tags: added: azure
Revision history for this message
Kelsey Skunberg (kelsey-skunberg) wrote :

failed on Bionic/azure-4.15 : 4.15.0-1097.107 : amd64

tags: added: 4.15
Revision history for this message
Kelsey Skunberg (kelsey-skunberg) wrote :

Found on Groovy lowlatency 5.8.0-31.33

tags: added: sru-20210104
Revision history for this message
Kelsey Skunberg (kelsey-skunberg) wrote :

found on bionic/ibm-gt 4.15.0-1084.93

tags: added: ibm-gt
tags: added: sru-20210125
tags: added: hwe-5.4 sru-20210222
tags: added: sru-20210315
tags: added: hwe
Revision history for this message
Guilherme G. Piccoli (gpiccoli) wrote :

Found on Focal/linux-kvm, cycle sru-20210315

tags: added: kvm
Revision history for this message
Marcelo Cerri (mhcerri) wrote :

Still happening with linux-azure-4.15 4.15.0-1112.125 and its derivatives.

tags: added: 5.8 groovy
Revision history for this message
Marcelo Cerri (mhcerri) wrote :

Still happening with linux-azure 5.8.0-1027.29.

tags: added: sru-20210412
tags: added: hwe-5.8
tags: removed: ibm-gt
Revision history for this message
Guilherme G. Piccoli (gpiccoli) wrote :

Issue observed in F/KVM, cycle sru-20210412.

tags: added: fips
Revision history for this message
Guilherme G. Piccoli (gpiccoli) wrote :

Issue observed in B/KVM, cycle sru-20210412

tags: added: 5.11 hirsute sru-20210510
Revision history for this message
Guilherme G. Piccoli (gpiccoli) wrote :

Observed in F/KVM, cycle sru-20210510.

Revision history for this message
Guilherme G. Piccoli (gpiccoli) wrote :

Observed in B/KVM, cycle sru-20210510.

Revision history for this message
Ian May (ian-may) wrote :

focal/linux-aws: 5.4.0-1049.51

Revision history for this message
Guilherme G. Piccoli (gpiccoli) wrote :

Observed in H/KVM, cycle sru-20210510.

Changed in ubuntu-kernel-tests:
assignee: nobody → Krzysztof Kozlowski (krzk)
Changed in ubuntu-kernel-tests:
status: Confirmed → In Progress
Revision history for this message
Krzysztof Kozlowski (krzk) wrote :
Revision history for this message
Guilherme G. Piccoli (gpiccoli) wrote :

Issue observed in G/KVM, cycle sru-20210531 .

tags: added: sru-20210531
tags: added: realtime
Revision history for this message
Kleber Sacilotto de Souza (kleber-souza) wrote :

Also found with focal/linux-hwe-5.11 5.11.0-20.21~20.04.1.

tags: added: hwe-5.11
tags: added: impish
tags: added: sru-20210621
Changed in ubuntu-kernel-tests:
status: In Progress → Fix Released
Revision history for this message
Guilherme G. Piccoli (gpiccoli) wrote :

Observed this on B/oracle-5.4, cycle sru-20210621 .

tags: added: oracle
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers