cpuacct_100_100 from controllers test suite in LTP failed

Bug #1829978 reported by Po-Hsu Lin on 2019-05-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned
linux-aws (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

 startup='Wed May 22 06:50:45 2019'
 cpuacct 1 TINFO: timeout per run is 0h 5m 0s
 cpuacct 1 TINFO: cpuacct: /sys/fs/cgroup/cpu,cpuacct
 cpuacct 1 TINFO: Creating 100 subgroups each with 100 processes
 /opt/ltp/testcases/bin/cpuacct.sh: -2110094999: /opt/ltp/testcases/bin/cpuacct.sh: Cannot fork
 tag=cpuacct_100_100 stime=1558507845 dur=9 exit=exited stat=2 core=no cu=30 cs=53

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: linux-image-4.15.0-50-generic 4.15.0-50.54
ProcVersionSignature: User Name 4.15.0-50.54-generic 4.15.18
Uname: Linux 4.15.0-50-generic x86_64
AlsaDevices:
 total 0
 crw-rw---- 1 root audio 116, 1 May 22 02:57 seq
 crw-rw---- 1 root audio 116, 33 May 22 02:57 timer
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay': 'aplay'
ApportVersion: 2.20.9-0ubuntu7.6
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord': 'arecord'
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CurrentDmesg:

Date: Wed May 22 06:59:27 2019
IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig': 'iwconfig'
Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: QEMU Standard PC (i440FX + PIIX, 1996)
PciMultimedia:

ProcFB: 0 cirrusdrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-50-generic root=UUID=576666e8-9e7f-40ee-934e-f1dce18323e5 ro
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-50-generic N/A
 linux-backports-modules-4.15.0-50-generic N/A
 linux-firmware 1.173.6
RfKill: Error: [Errno 2] No such file or directory: 'rfkill': 'rfkill'
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/01/2014
dmi.bios.vendor: SeaBIOS
dmi.bios.version: Ubuntu-1.8.2-1ubuntu1
dmi.chassis.type: 1
dmi.chassis.vendor: QEMU
dmi.chassis.version: pc-i440fx-xenial
dmi.modalias: dmi:bvnSeaBIOS:bvrUbuntu-1.8.2-1ubuntu1:bd04/01/2014:svnQEMU:pnStandardPC(i440FX+PIIX,1996):pvrpc-i440fx-xenial:cvnQEMU:ct1:cvrpc-i440fx-xenial:
dmi.product.name: Standard PC (i440FX + PIIX, 1996)
dmi.product.version: pc-i440fx-xenial
dmi.sys.vendor: QEMU

Po-Hsu Lin (cypressyew) wrote :

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1829978

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu Bionic):
status: New → Incomplete
Po-Hsu Lin (cypressyew) wrote :

Test passed with Cosmic:
 tag=cpuacct_100_100 stime=1558480324
 cmdline="cpuacct.sh 100 100"
 contacts=""
 analysis=exit
 <<>>
 cpuacct 1 TINFO: timeout per run is 0h 5m 0s
 cpuacct 1 TINFO: cpuacct: /sys/fs/cgroup/cpu,cpuacct
 cpuacct 1 TINFO: Creating 100 subgroups each with 100 processes
 cpuacct 1 TPASS: cpuacct.usage is not equal to 0 for every subgroup
 cpuacct 1 TPASS: cpuacct.usage equal to subgroup*/cpuacct.usage
 cpuacct 2 TINFO: removing created directories

 Summary:
 passed 2
 failed 0
 skipped 0
 warnings 0

Changed in linux (Ubuntu Cosmic):
status: New → Fix Released
Po-Hsu Lin (cypressyew) on 2019-06-24
tags: added: linux-kvm sru-20190603 ubuntu-ltp
Sean Feole (sfeole) on 2019-09-25
tags: added: azure sru-20190902
Sean Feole (sfeole) on 2019-09-26
tags: added: aws linux-aws-edge
Sean Feole (sfeole) on 2019-10-10
no longer affects: linux (Ubuntu Cosmic)
no longer affects: linux-aws (Ubuntu Cosmic)
tags: added: sru-20190930
tags: added: disco
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers