Address performance issue w/ GICv4-based guests

Bug #1829942 reported by dann frazier on 2019-05-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Status tracked in Eoan
Cosmic
Undecided
dann frazier
Disco
Undecided
dann frazier
Eoan
Undecided
dann frazier

Bug Description

[Impact]
Performance is degraded when a guest is booted w/ vgic v4 support enabled.

[Test Case]
I used a HiSilicon D06 system w/ an Intel 82599 10Gbps NIC. I passed through a VF to a guest, and ran "netperf -H <host>" against a 10Gbps-capable target. With vgic v4 support, I'm only seeing 5-6Gbps. With vgic v3 support, this was in the 9Gbps spectrum. And, after applying the upstream fix, I'm also seeing >9Gbps w/ vgic v4 enabled.

Note: to enable vgic v4 support, pass "kvm-arm.vgic_v4_enable=1" on the host kernel cmdline.

[Fix]
ca71228b42a96 arm64: KVM: Always set ICH_HCR_EL2.EN if GICv4 is enabled

[Regression Risk]
The fix is restricted to the ARM/KVM subsystem.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1829942

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
dann frazier (dannf) on 2019-05-22
Changed in linux (Ubuntu Eoan):
status: Incomplete → In Progress
assignee: nobody → dann frazier (dannf)
Changed in linux (Ubuntu Disco):
status: New → In Progress
assignee: nobody → dann frazier (dannf)
dann frazier (dannf) on 2019-05-23
Changed in linux (Ubuntu Cosmic):
status: New → In Progress
assignee: nobody → dann frazier (dannf)
Changed in linux (Ubuntu Cosmic):
status: In Progress → Fix Committed

This patch has already been applied to Disco as part of the update to 5.0.12 upstream stable release (LP: #1830934).

Changed in linux (Ubuntu Disco):
status: In Progress → Fix Committed

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-cosmic' to 'verification-done-cosmic'. If the problem still exists, change the tag 'verification-needed-cosmic' to 'verification-failed-cosmic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-cosmic
dann frazier (dannf) wrote :

Verified. From within a guest:

$ netperf -H <IP>
MIGRATED TCP STREAM TEST from 0.0.0.0 (0.0.0.0) port 0 AF_INET to <IP> () port 0 AF_INET : demo
Recv Send Send
Socket Socket Message Elapsed
Size Size Size Time Throughput
bytes bytes bytes secs. 10^6bits/sec

131072 16384 16384 10.02 941.41

dann frazier (dannf) on 2019-06-18
tags: added: verification-done-cosmic verification-done-di
removed: verification-needed-cosmic
tags: added: verification-done-disco
removed: verification-done-di

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
Terry Rudd (terrykrudd) on 2019-08-06
Changed in linux (Ubuntu Cosmic):
status: Fix Committed → Invalid
Terry Rudd (terrykrudd) wrote :

Dann, is this still planned for Eoan?

On Wed, Aug 14, 2019 at 1:25 PM Terry Rudd <email address hidden> wrote:
>
> Dann, is this still planned for Eoan?

 This change is upstream in v5.1.

Changed in linux (Ubuntu Eoan):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers