Ethernet won't connect when cable is plugged in at boot

Bug #1826403 reported by Theron Muller
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Amine

Bug Description

When booting Ubuntu 19.04 with the Ethernet cable plugged in, after boot, network manager won't connect. Unplugging and plugging back in the cable with the system running doesn't work to establish a connection.

The workaround is to boot with the cable unplugged, then to plug it in after boot.

This problem emerged immediately following an upgrade from 18.10 to 19.04. On the first boot networking was fine, but from the first reboot a networking connection through the Ethernet cable couldn't be established if the cable was plugged in at boot.

This issue is also described here: https://askubuntu.com/questions/1135412/updated-to-19-04-and-no-ethernet-now/1135726#1135726 and here: https://ubuntu-mate.community/t/19-04-ethernet-wired-connection-refuses-to-connect-when-plugged-in-before-boot/19333/6

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: network-manager 1.16.0-0ubuntu2
ProcVersionSignature: Ubuntu 5.0.0-13.14-generic 5.0.6
Uname: Linux 5.0.0-13-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
CurrentDesktop: GNOME
Date: Thu Apr 25 21:50:27 2019
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto enp4s0f1
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2018-11-23 (153 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
IpRoute:
 default via 192.168.11.1 dev enp4s0f1 proto dhcp metric 100
 169.254.0.0/16 dev enp4s0f1 scope link metric 1000
 192.168.11.0/24 dev enp4s0f1 proto kernel scope link src 192.168.11.13 metric 100
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=false
 WWANEnabled=true
SourcePackage: network-manager
UpgradeStatus: Upgraded to disco on 2019-04-25 (0 days ago)
mtime.conffile..etc.NetworkManager.NetworkManager.conf: 2019-04-25T20:03:28.380204
nmcli-dev:
 DEVICE TYPE STATE IP4-CONNECTIVITY IP6-CONNECTIVITY DBUS-PATH CONNECTION CON-UUID CON-PATH
 enp4s0f1 ethernet connected full limited /org/freedesktop/NetworkManager/Devices/2 Automatic connection e906293b-df71-435b-8909-7d88ca006540 /org/freedesktop/NetworkManager/ActiveConnection/1
 wlp3s0 wifi unavailable limited limited /org/freedesktop/NetworkManager/Devices/3 -- -- --
 lo loopback unmanaged unknown unknown /org/freedesktop/NetworkManager/Devices/1 -- -- --
nmcli-nm:
 RUNNING VERSION STATE STARTUP CONNECTIVITY NETWORKING WIFI-HW WIFI WWAN-HW WWAN
 running 1.16.0 connected started full enabled enabled disabled enabled enabled

Revision history for this message
Theron Muller (theron) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Revision history for this message
Markus Birth (mbirth) wrote :

I have this, too, on a Raspberry Pi 3 with arm64 Ubuntu. However, I've also upgraded my Raspberry Pi 2 with armhf and there, NetworkManager still autoconnects just fine after boot. The configuration looks identical on both machines.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you report that upstream on https://gitlab.freedesktop.org/NetworkManager/NetworkManager/issues/ ?

Revision history for this message
Theron Muller (theron) wrote :

Dear Sebastian,
Thanks for your response. I've raised the bug upstream here: https://gitlab.freedesktop.org/NetworkManager/NetworkManager/issues/166

I'll try to keep this bug stream and that one coordinated.

Revision history for this message
Bast1aan (bast1aan) wrote :

This could well be related to this bug: https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1793763

I experience the same problem, not only during boot but also when waking up from sleep. All ethernet connectivity is dead for 30 minutes because the switch in my network seems to have detected an IP conflict. This does not occur if I put the plug in after boot.
Very annoying, my work arround is to use ifplugd for eth0 instead of NetworkManager

Revision history for this message
Sebastien Bacher (seb128) wrote :

Upstream said it's more likely to be a kernel or driver issue. Do you still see the problem in newer Ubuntu versions?

affects: network-manager (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Theron Muller (theron) wrote :

This is now resolved on my system. Thanks for following up.

You-Sheng Yang (vicamo)
Changed in linux (Ubuntu):
status: Incomplete → Invalid
Revision history for this message
Amine (amunraa) wrote :

Hello everyone
I don't know if this thread is still active but I'm facing the same problem with Ubuntu 20.04
I can provide all the necessary informations but I don't know what you will need.
Best regards

Revision history for this message
Amine (amunraa) wrote :

Ubuntu 20.04

Changed in linux (Ubuntu):
assignee: nobody → Amine Bouyzem (amunraa)
assignee: Amine Bouyzem (amunraa) → nobody
status: Invalid → Confirmed
Revision history for this message
Amine (amunraa) wrote :

Solved ! It was a cable problem ! change it and now everything works normal. I hope that would help.

Changed in linux (Ubuntu):
assignee: nobody → Amine (amunraa)
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.