Wireless switch on Eee PC needs pciehp to work correctly

Bug #182490 reported by Martijn vdS on 2008-01-13
32
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Eee Applet
New
Undecided
Unassigned
Linux
New
Undecided
Unassigned
NiceeePC
Undecided
Unassigned
acpi-support
New
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
Declined for Intrepid by Brian Murray

Bug Description

I've compiled my own new version of the ath-pci module, so I can use the wireless on my Eee PC, but there is still one issue. If you disable the wireless using the hotkey, the atheros driver goes nuts because it can't talk to the hardware anymore.

This is fixed if I load the 'pciehp' module, with the 'pciehp_force=1' option. This might not be the cleanest way of loading, but it works.

I think this should be done automatically on the Eee PC.

Martijn vdS (martijn) wrote :
Martijn vdS (martijn) wrote :
Martijn vdS (martijn) wrote :
Martijn vdS (martijn) wrote :
Martijn vdS (martijn) wrote :
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Tested my EeePC 701 (4G) with Intrepid Alpha 5. The wireless key still doesn't function out of the box.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
Jens Askengren (jens-askengren) wrote :

When tunning the command

  echo 0 > /proc/acpi/asus/wlan

the computer will hang. Is this begaviour caused by this bug?

Sitsofe Wheeler (sitsofe) wrote :

Jens:
Yes it is. The ath5k/madwifi drivers will not go crazy when the wifi card disappears if you have booted with the pciehp_force=1 .

Sitsofe Wheeler (sitsofe) wrote :

The 2.6.27 kernel does not fix this issue. The issue also appears in the 2.6.26 kernel.

dkg (dkg0) wrote :

I just posted a blog entry about this particular problem on debian:

  https://www.debian-administration.org/users/dkg/weblog/37

You may also want to look at debian's eeepc-acpi-scripts package, which adds some modprobe configuration:

0 pip:~# cat /etc/modprobe.d/eeepc
# module options specific for Asus EeePC

options pciehp pciehp_force=1 pciehp_slot_with_bus=1
0 pip:~#

  http://packages.qa.debian.org/eeepc-acpi-scripts

Adam McDaniel (adamrmcd) wrote :

> options pciehp pciehp_force=1 pciehp_slot_with_bus=1

pciehp_slot_with_bus?? .. that is new to me, and not a standard pciehp module parameter. (at least its not in 2.6.27.y.git or linux-tip.git)

Where/how did "pciehp_slot_with_bus" get added?

I have heard from EeePC >= 901 owners though that "pciehp_poll_time=1" is needed for the newer ralink wireless toggling, but that one is a standard parameter.

Eduardo Cereto (dudus) wrote :

The Acer Aspire One uses the same driver and also has problems with the switch. I'm not sure if the bug is related whatsoever. Please check bug #156997

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Sitsofe Wheeler (sitsofe) wrote :

The need for pciehp on the command line should go away with later kernels (for current EeePCs) as mjg59 has developed a patch for this. See http://mjg59.livejournal.com/100587.html and http://mjg59.livejournal.com/100587.html?thread=1258219#t1258219 .

It does look like the patch mentioned here is in the upstream kernel, but not available in the Jaunty kernel. This may be something that will have to wait for the Karmic release but that's something for the kernel team to decide. Below is the usptream git commit id for them to reference:

ogasawara@yoji:~/linux-2.6$ git log -p 5740294ca3a9b113fe146f2826effb69ca50008d

commit 5740294ca3a9b113fe146f2826effb69ca50008d

Author: Matthew Garrett <email address hidden>

Date: Tue Jan 20 16:17:48 2009 +0100

    eeepc-laptop: Implement rfkill hotplugging in eeepc-laptop

    The Eee implements rfkill by logically unplugging the wireless card from the

    PCI bus. Despite sending ACPI notifications, this does not appear to be

    implemented using standard ACPI hotplug - nor does the firmware provide the

    _OSC method required to support native PCIe hotplug. The only sensible choic

    appears to be to handle the hotplugging directly in the eeepc-laptop driver.

    Tested successfully on a 700, 900 and 901.

    Signed-off-by: Matthew Garrett <email address hidden>

    Signed-off-by: Corentin Chary <email address hidden>

    Signed-off-by: Len Brown <email address hidden>

Actually searching around some more it looks like Andy has thrown together a test kernel with this patch:

https://bugs.edge.launchpad.net/ubuntu/+source/linux/+bug/232170/comments/57

Would be great if anyone here could test and provide feedback. Thanks.

Martijn vdS (martijn) wrote :

That kernel works great for me! Enabling/disabling wifi now works, as long as the rfkill_input module is loaded.

Hi Martijn,

I'm going to mark this as a duplicate to bug 232170 as the patch and test kernel there works for you. Please continue to monitor the progress there. Thanks.

As per comment #19, I guess this bug can be closed as fix released?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers