Lenovo Yoga mouse is slow & laggy in bluetooth mode (low polling frequency)

Bug #1824559 reported by wysiwyg31 on 2019-04-12
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,
I have an issue with a lenovo yoga mouse.
This mouse has 2 working mode either bluetooth or with a provided usb dongle.
USB dongle works fine, but bluetooth don't.
Cursor is slow and laggy.
"evhz" (https://gitlab.com/iankelling/evhz) reports 22Hz in bluetooth mouse while USB mode and other mouse reports 125Hz.
Polling speed is too slow.

I tried different howto suggesting to change usbhid mousepoll value => does not help.
The mouse seems handled by btusb module, not usbhid (modprobe -r usbhid killed my other mouse, but not the lenovo, while modprobe -r btusb killed the lenovo).

I tried 2 laptops (XPS9370 with 18.04, kernel 4.18 and kernek 5.07 and an older dell Precision M6400 16.04 kernel 4.15).

Bluetooth pairing works well, either with gnome bluetooth interface or with "bluetoothctl"

Both laptops reports ~20-22Hz polling speed with evhz (and same laggy behavior)

I also tried 2 bluetooth interface on the XPS13 9370 : the integrated bluetooth and a Sabrent USB Bluetooth 4.0 (to connect with the Sabrent, I have switched off integrated bluetooth with rfkill).

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: bluetooth (not installed)
Uname: Linux 5.0.7-050007-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.6
Architecture: amd64
CurrentDesktop: GNOME
Date: Fri Apr 12 18:05:16 2019
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-xenial-amd64-20160624-2
EcryptfsInUse: Yes
InstallationDate: Installed on 2018-05-10 (337 days ago)
InstallationMedia: Ubuntu 16.04 "Xenial" - Build amd64 LIVE Binary 20160624-10:47
InterestingModules: rfcomm bnep btusb bluetooth
MachineType: Dell Inc. XPS 13 9370
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.7-050007-generic root=UUID=d36c5071-0243-427d-8fe1-7416c3b775f1 ro quiet splash vt.handoff=1
SourcePackage: bluez
UpgradeStatus: Upgraded to bionic on 2019-03-02 (40 days ago)
dmi.bios.date: 02/14/2019
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.8.1
dmi.board.name: 0F6P3V
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.8.1:bd02/14/2019:svnDellInc.:pnXPS139370:pvr:rvnDellInc.:rn0F6P3V:rvrA00:cvnDellInc.:ct10:cvr:
dmi.product.family: XPS
dmi.product.name: XPS 13 9370
dmi.product.sku: 07E6
dmi.sys.vendor: Dell Inc.
hciconfig:
 hci0: Type: Primary Bus: USB
  BD Address: 9C:B6:D0:8B:33:C6 ACL MTU: 1024:8 SCO MTU: 50:8
  UP RUNNING PSCAN
  RX bytes:12041 acl:294 sco:0 events:363 errors:0
  TX bytes:8633 acl:76 sco:0 commands:171 errors:0

wysiwyg31 (wysiwyg31) wrote :
wysiwyg31 (wysiwyg31) wrote :

Attached evhz output in case it helps.

wysiwyg31 (wysiwyg31) wrote :

Added bluetoothctl "info" output.

Daniel van Vugt (vanvugt) wrote :

Thanks for the detailed bug report. I suspect the low polling frequency has more to do with the kernel than with bluez, so reassigning there.

That is, unless the problem is one of interference. Please try moving away from any strong 2.4GHz wifi access points and turning off other bluetooth devices. Please also try a non-Linux device if you can find one.

affects: bluez (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete
Daniel van Vugt (vanvugt) wrote :

Please also try the Atheros kernel options mentioned in bug 1746164 (which is about Atheros wifi causing a low quality Bluetooth signal).

wysiwyg31 (wysiwyg31) wrote :

Hello Daniel,
Thank you for your answer!
OK for kernel assignment...to be honest, I was not sure where to assign it :)

Let me share last tests I did:
- upgrade to Bluez 5.50 (previously 5.48) (I added the bluez ppa and apt update / upgrade. then disconnect the mouse, re-pair it) => same situation.
- I paired with my work laptop (win7) : it works perfectly in Bluetooth.
- I tried different places (2 places at home, and now a third one at work) => works fine on my work laptop win7; not on my XPS with ubuntu.

I have read the bug 1746164 you mentioned, but:
- I tried 2 ubuntu laptop and my XPS13 9370 is based on ath10k (not ath9k) ? (I'm not sure for the other laptop). Is this bug applicable to ath10k ?
- I also tried a Sabrent bluetooth 4.0 usb stick...this one is based on CSR chip => issue is still there (with ~20Hz polling while it's 22Hz with internal bluetooth)
- I can still anyway try to check this issue from bug 1746164: do you think I can check it by turning OFF the wifi and test my mouse again ?

Hugo (petittwit) wrote :

Hi!
Similar problem with my old HP netbook (fresh ubuntu 18.04.02 install)

wysiwyg31 (wysiwyg31) wrote :

in case it bring some information, a similar issue was reported here on Antergos:

https://forum.antergos.com/topic/6800/bluetooth-mouse-10-hz-pollrate-evhz-slow-movement/

but with no solution too...

Brad Figg (brad-figg) on 2019-07-24
tags: added: ubuntu-certified
giors (giorgio-ciardo) wrote :

Hi!
Similar problem with a Lenovo T480 paired with M590 mice.
The solution found here
https://bbs.archlinux.org/viewtopic.php?pid=1857256#p1857256
works for me

wysiwyg31 (wysiwyg31) wrote :

Hi,
Following giors post #9 and a similar suggestion I get from a reddit user, I did the following:

sudo nano /var/lib/bluetooth/xx\:xx\:xx\:xx\:xx\:xx/yy\:yy\:yy\:yy\:yy\:yy/info

where xx:xx.... is pc bluetooth address and yy:yy... is the mouse bluetooth address.

In the file, I added the section at the end:

[ConnectionParameters]
MinInterval=6
MaxInterval=7
Latency=0
Timeout=216

the value was proposed by this reddit user, I did not do any specific tuning.

then, I restarted bluetooth service with:
systemctl restart bluetooth

So far, it works! the mouse is fast and evhz gives this:

Lenovo YOGA Mouse: Latest 1000Hz, Average 183Hz
Lenovo YOGA Mouse: Latest 125Hz, Average 183Hz
Lenovo YOGA Mouse: Latest 111Hz, Average 184Hz
Lenovo YOGA Mouse: Latest 125Hz, Average 170Hz
Lenovo YOGA Mouse: Latest 111Hz, Average 170Hz
Lenovo YOGA Mouse: Latest 111Hz, Average 170Hz
Lenovo YOGA Mouse: Latest 111Hz, Average 171Hz
Lenovo YOGA Mouse: Latest 125Hz, Average 157Hz
Lenovo YOGA Mouse: Latest 111Hz, Average 157Hz
Lenovo YOGA Mouse: Latest 55Hz, Average 156Hz
Lenovo YOGA Mouse: Latest 125Hz, Average 156Hz
Lenovo YOGA Mouse: Latest 16Hz, Average 154Hz
Lenovo YOGA Mouse: Latest 11Hz, Average 153Hz
Lenovo YOGA Mouse: Latest 125Hz, Average 154Hz
Lenovo YOGA Mouse: Latest 111Hz, Average 140Hz
Lenovo YOGA Mouse: Latest 125Hz, Average 140Hz
Lenovo YOGA Mouse: Latest 111Hz, Average 140Hz
Lenovo YOGA Mouse: Latest 111Hz, Average 140Hz

Patricio Inzaghi (duckmanito) wrote :

I have Ubuntu 18.04 on a Dell XPS 13 with a Logitech bluetooth mouse m720 triathlon with the same issue (20Hz polling rate by default). Following the steps given by wysiwyg31 in #10 (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1824559/comments/10) solved my issue.

Shuhao (shuhao) wrote :

I just reproduced this issue with a bluetooth mouse 3600 on 18.04.3 LTS on a thinkpad x230.

XPS 15 9570 Ubuntu 18.04 Linux 5.2.10
Logitech MX Master (M-R0052)

Pierre Equoy (pieq) wrote :

Device: XPS 13 7390
Image: 19.10 Beta
Kernel: updated to 5.3.0-13-generic (from 5.3.0-10-generic)

Mice tested: Logitech M585, Microsoft Designer Mouse

With kernel 5.3.0-10-generic (the default on 19.10 beta image), I experience exactly the same issue as originally described. After updating to kernel 5.3.0-13-generic, the issue is gone and both mice cursors respond very smoothly.

Po-Hsu Lin (cypressyew) on 2019-10-08
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Pierre Equoy (pieq) wrote :

Device: XPS 13 7390
Image: 19.10 Final
Kernel: 5.3.0-19-generic

Mice tested: Logitech M585, Microsoft Designer Mouse

The issue is gone.

@wysiwyg31: could you give it a try? You can boot a live session of Ubuntu 19.10 on your device and try to pair your Bluetooth mouse.

If it works for you, I'll mark the issue as Fix Released.

wysiwyg31 (wysiwyg31) wrote :

Hi @pieq, following your message I launched download of Ubuntu 19.10 image.
I will test with live session as suggested (as I keep my laptop on LTS for the moment)

wysiwyg31 (wysiwyg31) wrote :

Hi @pieq, juste tested with ubuntu 19.10 live session (I just paired the mouse with bluetooth GUI and moved the cursor around with the lenevo mouse).
The cursor is slow and laggy with the lenovo mouse (it's ok with trackpad).

Somewhat it seems not solved with ubuntu 19.10 for my mouse.

wysiwyg31 (wysiwyg31) wrote :

Hi, I migrate my laptop to Manjaro, but kernell 5.6.8-1 is still slow and laggy with the yoga mouse

Felipe Butcher (felipebutcher) wrote :

Funny I was having this problem, or at least similar, and I found out the wifi was interfering. Moving the router away from the laptop resolved the issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers