Vertical line screen flickers randomly appears on built-in laptop display only

Bug #1824415 reported by Oleksandr Varchenko on 2019-04-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

The issue is similar to:
 https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1785912

the short video with the problem
https://photos.app.goo.gl/i5dHrQUDV1T2gp8o9

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xorg 1:7.7+19ubuntu7.1
ProcVersionSignature: Ubuntu 4.15.0-47.50-generic 4.15.18
Uname: Linux 4.15.0-47-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.6
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Thu Apr 11 22:42:06 2019
DistUpgraded: Fresh install
DistroCodename: bionic
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation UHD Graphics 620 [8086:5917] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company UHD Graphics 620 [103c:83b2]
InstallationDate: Installed on 2018-12-03 (129 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
MachineType: HP HP EliteBook 840 G5
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-47-generic root=UUID=4b3ca7ee-f7ef-4f10-ae37-d86fdeb64942 ro quiet splash vt.handoff=1
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/12/2018
dmi.bios.vendor: HP
dmi.bios.version: Q78 Ver. 01.04.00
dmi.board.name: 83B2
dmi.board.vendor: HP
dmi.board.version: KBC Version 04.53.00
dmi.chassis.asset.tag: F51020
dmi.chassis.type: 10
dmi.chassis.vendor: HP
dmi.modalias: dmi:bvnHP:bvrQ78Ver.01.04.00:bd09/12/2018:svnHP:pnHPEliteBook840G5:pvr:rvnHP:rn83B2:rvrKBCVersion04.53.00:cvnHP:ct10:cvr:
dmi.product.family: 103C_5336AN HP EliteBook
dmi.product.name: HP EliteBook 840 G5
dmi.sys.vendor: HP
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.95-1~18.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 18.2.8-0ubuntu0~18.04.2
version.libgl1-mesa-glx: libgl1-mesa-glx 18.2.8-0ubuntu0~18.04.2
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

Daniel van Vugt (vanvugt) wrote :

Sorry, but this looks to me like a broken (or just poorly connected) LCD panel in the laptop. Not a software problem.

I've had similar problems myself before, and the fix each time was to either replace the LCD panel, or to just reconnect its wires (sometimes the problem is just a bad connection).

As a first point of call you should return the laptop to where you bought it, or contact HP Support about a warranty claim.

summary: - Screen flickers randomly appears on built-in laptop display only
+ Vertical line screen flickers randomly appears on built-in laptop
+ display only
affects: xorg (Ubuntu) → ubuntu
Changed in ubuntu:
status: New → Invalid

Hi Danniel, it may be true, but have not this issue in windows.
Also see this https://photos.app.goo.gl/Ff7KgctcrY6JFXv88

Daniel van Vugt (vanvugt) wrote :

Yes, unfortunately that is also my experience...

The Windows 10 kernel renders the screen differently to the Linux kernel. So some hardware problems manifest only in Linux and not in Windows. I guess that suggests the i915 Linux kernel driver could do better in signal error handling, like Windows. I remember thinking the same when I had a similar LCD panel fault some time ago.

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Invalid → New

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

It's looks like a bug with linux intel display drivers and chromium forks...

https://bugs.chromium.org/p/chromium/issues/detail?id=606152#c73

Daniel van Vugt (vanvugt) wrote :

I think that's a different flickering. That bug is about the Chromium web browser. This bug is about a hardware defect affecting bright/white areas of the LCD, and the fact that Linux handles hardware defects less elegantly than Windows does.

So this remains a Linux kernel bug if anything.

Daniel van Vugt (vanvugt) wrote :

As stated in comment #2:

As a first point of call you should return the laptop to where you bought it, or contact HP Support about a warranty claim.

I'll try to have a replacement, however, it really happens only in Chrome and electron applications ( see chromium forks)

Kai-Heng Feng (kaihengfeng) wrote :

First things first - please test mainline kernel:
Would it be possible for you to test the latest upstream kernel? Refer
to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest
v5.1-rc4 kernel [0].

If this bug is fixed in the mainline kernel, please add the following
tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag:
'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as
"Confirmed”, and attach dmesg.

Thanks in advance.

[0] https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.1-rc4/

Just tried to use v5.1.0-050100rc5, and unfortunately it still there.
When Chrome shows dynamic SVG it happens at once.

tags: added: kernel-bug-exists-upstream
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers