FTBFS: need build-dep: gcc-4.1-hppa64 [hppa]

Bug #182335 reported by LaMont Jones on 2008-01-12
4
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

In addition to binutils-hppa64, hppa needs the 64-bit compiler. I don't know if that is sufficient to completely fix things or not, but it's a definite step in the right direction.

thanks,

Hi LaMont,

I recall Tim is addressing this issue. I'll go ahead and reassign this to him. Tim, if I'm mistaken, obviously please feel free to unassign this from yourself. Thanks.

Changed in linux-ubuntu-modules-2.6.24:
assignee: nobody → timg-tpi
importance: Undecided → Medium
status: New → Triaged
status: Triaged → In Progress
Tim Gardner (timg-tpi) wrote :

The kernel has a BuildDepends on gcc-4.1-hppa64 [hppa] as well as binutils-hppa64 [hppa]. However, linux-ubuntu-modules also needs these tools. I faced this same issue with powerpc. The fix is to add the tools version dependencies to the linux-headers-ABI-FLAVOUR package. This has been done for the upcoming -9 kernel series.

Changed in linux-ubuntu-modules-2.6.24:
milestone: none → hardy-alpha-6
status: In Progress → Fix Committed
Tim Gardner (timg-tpi) wrote :

Fix released with 2.6.24-10.16 kernel headers package which added the gcc-4.1 build dependency.

Changed in linux-ubuntu-modules-2.6.24:
assignee: timg-tpi → nobody
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers