linux-cloud-tools-common 3.13.0-166.216 in Trusty is missing contents of /usr/sbin

Bug #1819869 reported by Tobias Koch on 2019-03-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Andy Whitcroft
Trusty
Undecided
Unassigned

Bug Description

Version 3.13.0-165.215 of linux-cloud-tools-common has the following contents

/.
/usr
/usr/sbin
/usr/sbin/hv_vss_daemon
/usr/sbin/hv_kvp_daemon
/usr/sbin/hv_fcopy_daemon
/usr/sbin/hv_get_dhcp_info
/usr/sbin/hv_set_ifconfig
/usr/sbin/hv_get_dns_info
/usr/share
/usr/share/man
/usr/share/man/man8
/usr/share/man/man8/hv_kvp_daemon.8.gz
/usr/share/doc
/usr/share/doc/linux-cloud-tools-common
/usr/share/doc/linux-cloud-tools-common/changelog.Debian.gz
/usr/share/doc/linux-cloud-tools-common/copyright
/etc
/etc/init
/etc/init/hv-vss-daemon.conf
/etc/init/hv-fcopy-daemon.conf
/etc/init/hv-kvp-daemon.conf

whereas version 3.13.0-166.216 only contains

/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/linux-cloud-tools-common
/usr/share/doc/linux-cloud-tools-common/copyright
/usr/share/doc/linux-cloud-tools-common/changelog.Debian.gz
/etc
/etc/init
/etc/init/hv-vss-daemon.conf
/etc/init/hv-kvp-daemon.conf
/etc/init/hv-fcopy-daemon.conf

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1819869

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: trusty
Tobias Koch (tobijk) wrote :

This is a packaging issue, so logs should be irrelevant.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu Trusty):
status: New → In Progress
Changed in linux (Ubuntu):
status: Confirmed → Invalid
Andy Whitcroft (apw) on 2019-03-13
Changed in linux (Ubuntu):
status: Invalid → In Progress
importance: Undecided → High
assignee: nobody → Andy Whitcroft (apw)
tags: added: id-5c88b2cecc73e1431fae0041
Stefan Bader (smb) on 2019-03-13
Changed in linux (Ubuntu Trusty):
status: In Progress → Fix Committed
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'. If the problem still exists, change the tag 'verification-needed-trusty' to 'verification-failed-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Tobias Koch (tobijk) wrote :

I have verified that version 3.13.0-167.217 contains the missing files and that after installation hv_kvp_daemon and hv_vss_daemon are active.

tags: added: verified-trusty
removed: verification-needed-trusty
Tobias Koch (tobijk) on 2019-03-14
tags: added: verified-done-trusty
removed: verified-trusty
tags: added: verification-done-trusty
removed: verified-done-trusty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.13.0-167.217

---------------
linux (3.13.0-167.217) trusty; urgency=medium

  * linux: 3.13.0-167.217 -proposed tracker (LP: #1819917)

  * Packaging resync (LP: #1786013)
    - [Packaging] resync getabis
    - [Packaging] update helper scripts
    - [Packaging] resync retpoline extraction

  * linux-cloud-tools-common 3.13.0-166.216 in Trusty is missing contents of
    /usr/sbin (LP: #1819869)
    - Revert "UBUNTU: [Packaging] skip cloud tools packaging when not building
      package"

 -- Stefan Bader <email address hidden> Wed, 13 Mar 2019 15:46:51 +0100

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
Brad Figg (brad-figg) on 2019-07-24
tags: added: cscc
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers