pull cirrus.ko into main kernel package

Bug #1818879 reported by Andreas Hasenack on 2019-03-06
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-vesa (Ubuntu)
High
Unassigned

Bug Description

In disco, xorg stopped shipping a cirrus module/driver, instead relying on the kernel one. But the kernel one is in the linux-modules-extra-<version>-generic package, which is not installed by default in vms.

That breaks some assumptions: uvtool, for example, doesn't specify a video device when creating a vm, and the default in libvirt in such cases is to use cirrus. As a conseguence, disco VMs created by tools that do not specify a default video device won't have the cirrus.ko module, and X won't start there.

It's a bit more complicated, however, because X just tries other fallbacks, but they also don't work. In particular, vesa doesn't work:

[ 25.547] (EE) VESA(0): Specified fbbpp (24) is not a permitted value

(full log at http://paste.ubuntu.com/p/d6ypgxzkyv/)

We can change uvtool and specify a video device instead of leaving it blank (see bug #1818877), but there might be other tools out there spawning guests without telling them which video device to use, and they would also fail.

Andreas Hasenack (ahasenack) wrote :

Another alternative would be to have vesa specify a working bpp value, if that is the only problem there.

Andreas Hasenack (ahasenack) wrote :

Adding a test for xorg for their consideration.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1818879

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Daniel van Vugt (vanvugt) wrote :

Are you suggesting anything in Xorg needs fixing, or is the Xorg task just an FYI because it's related?

affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
status: New → Incomplete

@Daniel - on one hand it is also a change in xorg that makes the driver missing now - so an FYI for that.
But in an IRC discussion there were two potential paths to resolve this issue overall:
- make the cirrus.ko available in the non -extra package so that it works out of the box using this driver
- tjaaltonen identified the message around fbbpp (24) which could be a fix in X source to get base VESA working even without cirrus.ko being in place

We don't mind which path is chosen to fix it, the kernel change seems the more straight forward one to me, but OTOH if a fix for the 24bit Vesa is found that would eliminate the new dependency on the kernel module which would be even nicer.

ProblemType: Bug
AlsaDevices:
 total 0
 crw-rw---- 1 root audio 116, 1 Mar 7 08:12 seq
 crw-rw---- 1 root audio 116, 33 Mar 7 08:12 timer
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay': 'aplay'
ApportVersion: 2.20.10-0ubuntu23
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord': 'arecord'
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CRDA: N/A
DistroRelease: Ubuntu 19.04
IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig': 'iwconfig'
Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: QEMU Standard PC (i440FX + PIIX, 1996)
Package: xorg-server
PciMultimedia:

ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.19.0-13-generic root=PARTUUID=2fdafb75-7df7-4d62-8628-5213673bd445 ro console=tty1 console=ttyS0
ProcVersionSignature: User Name 4.19.0-13.14-generic 4.19.20
RelatedPackageVersions:
 linux-restricted-modules-4.19.0-13-generic N/A
 linux-backports-modules-4.19.0-13-generic N/A
 linux-firmware N/A
RfKill: Error: [Errno 2] No such file or directory: 'rfkill': 'rfkill'
Tags: disco uec-images
Uname: Linux 4.19.0-13-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm audio cdrom dialout dip floppy netdev plugdev sudo video
_MarkForUpload: True
dmi.bios.date: 04/01/2014
dmi.bios.vendor: SeaBIOS
dmi.bios.version: 1.10.2-1ubuntu1
dmi.chassis.type: 1
dmi.chassis.vendor: QEMU
dmi.chassis.version: pc-i440fx-bionic
dmi.modalias: dmi:bvnSeaBIOS:bvr1.10.2-1ubuntu1:bd04/01/2014:svnQEMU:pnStandardPC(i440FX+PIIX,1996):pvrpc-i440fx-bionic:cvnQEMU:ct1:cvrpc-i440fx-bionic:
dmi.product.name: Standard PC (i440FX + PIIX, 1996)
dmi.product.version: pc-i440fx-bionic
dmi.sys.vendor: QEMU

tags: added: apport-collected disco uec-images

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Just the plain Disco kernel environment as you get it when spawning a new guest - data provided changing state of both bug tasks back.

Changed in xorg-server (Ubuntu):
status: Incomplete → New
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Timo Aaltonen (tjaalton) wrote :

ajax gave a patch to fix selecting a better default bpp, so that'll fix the server to start even without cirrus.ko

affects: xorg-server (Ubuntu) → xserver-xorg-video-vesa (Ubuntu)
Changed in xserver-xorg-video-vesa (Ubuntu):
status: New → Confirmed
Changed in xserver-xorg-video-vesa (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-vesa - 1:2.4.0-2

---------------
xserver-xorg-video-vesa (1:2.4.0-2) unstable; urgency=medium

  * Cherry-pick a commit to fix default bpp selection. (LP: #1818879)

 -- Timo Aaltonen <email address hidden> Fri, 08 Mar 2019 10:46:08 +0200

Changed in xserver-xorg-video-vesa (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers