18.04.2 breaks xrdp

Bug #1817225 reported by Rushi on 2019-02-21
58
This bug affects 10 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
xorg-server (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
xrdp-hwe-18.04 (Ubuntu)
High
Timo Aaltonen
Bionic
Undecided
Unassigned

Bug Description

I have observed the following on two different computers:

On both computers, running Ubuntu 18.04, I am able to install xrdp and log in remotely using a third computer via Reminna or Windows RDP client without any problems.

If I do a fresh install of Ubuntu 18.04.2 and install xrdp OR if I update my working 18.04 installation by running

sudo apt-get install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04

then xrdp stops working. That is, when I login using an RDP client, I am presented with the xrdp login screen, but when I select xorg and try to login with my username and password, I see a blue screen for about a minute and then

connecting to sesman ip 127.0.0.1
sesman connect ok
sending login info to session manager, please wait...
login successful for display 10
started connecting
connection problem, giving up
some problem

The only difference between the working configuration and the broken one is Ubuntu 18.04 vs 18.04.2 (OR HWE installed using the above command).

Out of the two computers I tried one has nvidia graphics and one has intel on-board graphics. For the nvidia computer, I tried both nvidia and nouveau drivers to no avail.

Not sure if this is a problem with xrdp or xorg.
---
ProblemType: Bug
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC2: rushik 4016 F.... pulseaudio
 /dev/snd/controlC1: rushik 4016 F.... pulseaudio
 /dev/snd/controlC0: rushik 4016 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 18.04
HibernationDevice: RESUME=UUID=007a0916-b97e-4f06-b096-9694f8b3085c
InstallationDate: Installed on 2019-01-11 (41 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
MachineType: System manufacturer System Product Name
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.18.0-15-generic root=UUID=5c3c3434-9b1d-40dd-8388-8005cf88989e ro quiet splash vt.handoff=1
ProcVersionSignature: Ubuntu 4.18.0-15.16~18.04.1-generic 4.18.20
RelatedPackageVersions:
 linux-restricted-modules-4.18.0-15-generic N/A
 linux-backports-modules-4.18.0-15-generic N/A
 linux-firmware 1.173.3
Tags: bionic
Uname: Linux 4.18.0-15-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 01/04/2019
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0802
dmi.board.asset.tag: Default string
dmi.board.name: ROG STRIX Z390-E GAMING
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: Default string
dmi.chassis.version: Default string
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0802:bd01/04/2019:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnROGSTRIXZ390-EGAMING:rvrRev1.xx:cvnDefaultstring:ct3:cvrDefaultstring:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: System Product Name
dmi.product.sku: ASUS_MB_CNL
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Rushi (rushik-1986) on 2019-02-21
description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1817225/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1817225

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected bionic
description: updated
Rushi (rushik-1986) wrote : CRDA.txt

apport information

apport information

apport information

Rushi (rushik-1986) wrote : Lspci.txt

apport information

Rushi (rushik-1986) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Rushi (rushik-1986) wrote :

Ran

apport-collect 1817225

and changed the status of the bug to 'Confirmed'.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-hwe-18.04 (Ubuntu):
status: New → Confirmed
Ron Widell (r-widell) wrote :

It also affects Kubuntu 18.04.2

cat /etc/issue
Ubuntu 18.04.2 LTS \n \l

I moved /var/log/xrdp.log and /var/log/xrdp-sesman.log to a different location so they'd be smaller and easier to parse by booting a live system, then restarted this system.

Unfortunately, this time the xrdp daemon failed to start.

# systemctl status xrdp.service
● xrdp.service - xrdp daemon
   Loaded: loaded (/lib/systemd/system/xrdp.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2019-03-20 23:00:28 CDT; 8min ago
     Docs: man:xrdp(8)
           man:xrdp.ini(5)
  Process: 1668 ExecStart=/usr/sbin/xrdp $XRDP_OPTIONS (code=exited, status=1/FAILURE)
  Process: 1651 ExecStartPre=/bin/sh /usr/share/xrdp/socksetup (code=exited, status=0/SUCCESS)

Mar 20 23:00:28 birdie systemd[1]: Starting xrdp daemon...
Mar 20 23:00:28 birdie systemd[1]: xrdp.service: Control process exited, code=exited status=1
Mar 20 23:00:28 birdie systemd[1]: xrdp.service: Failed with result 'exit-code'.
Mar 20 23:00:28 birdie systemd[1]: Failed to start xrdp daemon.

No sense trying to make a connection, and no xrdp.log was created. xrdp-sesman.log is pretty sparse:

# cat /var/log/xrdp-sesman.log
[20190320-22:55:28] [DEBUG] libscp initialized
[20190320-22:55:28] [DEBUG] Testing if xrdp-sesman can listen on 127.0.0.1 port 3350.
[20190320-22:55:28] [INFO ] starting xrdp-sesman with pid 1476
[20190320-22:55:29] [DEBUG] Closed socket 5 (AF_INET6 ::1 port 3350)
[20190320-22:55:29] [INFO ] listening to port 3350 on 127.0.0.1
[20190320-22:55:30] [INFO ] shutting down sesman 1
[20190320-22:55:30] [DEBUG] Closed socket 7 (AF_INET6 ::1 port 3350)
[20190320-23:00:27] [DEBUG] libscp initialized
[20190320-23:00:27] [DEBUG] Testing if xrdp-sesman can listen on 127.0.0.1 port 3350.
[20190320-23:00:27] [INFO ] starting xrdp-sesman with pid 1612
[20190320-23:00:27] [DEBUG] Closed socket 5 (AF_INET6 ::1 port 3350)
[20190320-23:00:28] [INFO ] listening to port 3350 on 127.0.0.1
[20190320-23:00:28] [INFO ] shutting down sesman 1
[20190320-23:00:28] [DEBUG] Closed socket 7 (AF_INET6 ::1 port 3350)

I'll also attach the logs from when the daemon would start but the attempted connections (from a Windows 7 machine and an openSUSE machine using Krdc) consistently failed.

no longer affects: xorg-hwe-18.04 (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
status: New → Confirmed
Changed in xorg-server (Ubuntu):
status: New → Confirmed
Changed in xrdp (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

​​​​please test on cosmic or disco

Changed in xorg-server (Ubuntu):
status: Confirmed → Incomplete
Thiago Martins (martinx) wrote :

So, there is a need to rebuild xrdp against HWE 18.04.

Maybe Ubuntu should provide a new binary package, let's say "xrdp-hwe-18.04"

For now, I've recompiled the same xrdp from Ubuntu 18.04, on Ubuntu 18.04.2 and uploaded to my "XRP PPA", here:

https://launchpad.net/~martinx/+archive/ubuntu/xrdp-hwe-18.04

To enjoy xrdp on Ubuntu 18.04 with HWE, just do:

    sudo add-apt-repository ppa:martinx/xrdp-hwe-18.04
    sudo apt install xrdp xorgxrdp

;-)

Thiago Martins (martinx) wrote :

And here is the xrdp-0.9.9 and xorgxrdp-0.2.9 for Bionic HWE!

https://launchpad.net/~martinx/+archive/ubuntu/xrdp-next

Awesome Friday night! LOL

Thiago Martins (martinx) wrote :

I'll maintain the following repo:

https://launchpad.net/~martinx/+archive/ubuntu/xrdp-hwe-18.04

...until Ubuntu fixes it in an LTS version, maybe 20.04? That's okay...

Rushi (rushik-1986) wrote :

I can confirm that this works. Thank you Thiago!

Timo Aaltonen (tjaalton) wrote :

Ok, so xrdp in bionic builds modules for the xserver, which won't work with the HWE xserver. These modules got since split from src:xrdp as src:xorgxrdp. Note that xrdp in bionic did not have these modules, so this issue is new with bionic HWE and wasn't expected.

So it does look like xrdp in bionic would need a HWE version. BTW, does your xrdp-next built against HWE work with stock X?

Timo Aaltonen (tjaalton) on 2019-05-06
Changed in linux (Ubuntu):
status: Confirmed → Invalid
Changed in xorg-server (Ubuntu):
status: Incomplete → Invalid
Changed in xrdp (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
Timo Aaltonen (tjaalton) wrote :

src:xrdp-hwe-18.04 uploaded to ppa:canonical-x/x-staging, please test!

Changed in xrdp (Ubuntu):
status: Confirmed → Incomplete
Timo Aaltonen (tjaalton) wrote :

..by making sure xrdp-hwe-18.04 is installed

Ken VanDine (ken-vandine) wrote :

Confirmed, your staging PPA fixes it for our Hyper-V image

Changed in xrdp (Ubuntu):
importance: Undecided → High
status: Incomplete → In Progress

Hello Rushi, or anyone else affected,

Accepted xrdp-hwe-18.04 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xrdp-hwe-18.04/0.9.5-2~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
Steve Langasek (vorlon) on 2019-08-08
Changed in xrdp (Ubuntu):
status: In Progress → Fix Committed
affects: xrdp (Ubuntu) → xrdp-hwe-18.04 (Ubuntu)
Ken VanDine (ken-vandine) wrote :

Confirmed this works in the Hyper-V 18.04 desktop image.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Changed in linux (Ubuntu Bionic):
status: New → Invalid
Changed in xorg-server (Ubuntu Bionic):
status: New → Invalid
Changed in xrdp-hwe-18.04 (Ubuntu Bionic):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xrdp-hwe-18.04 - 0.9.5-2~18.04.1

---------------
xrdp-hwe-18.04 (0.9.5-2~18.04.1) bionic; urgency=medium

  * Rename for 18.04.3 HWE stack update. (LP: #1817225)
    - build only xorgxrdp-hwe-18.04 binary

 -- Timo Aaltonen <email address hidden> Tue, 23 Jul 2019 23:52:02 +0300

Changed in xrdp-hwe-18.04 (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xrdp-hwe-18.04 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers