Ubuntu boot failure. 4.18.0-14 boot stalls. (does not boot)

Bug #1814555 reported by dexter on 2019-02-04
136
This bug affects 26 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Cosmic
High
Unassigned

Bug Description

Today my Ubuntu (18.10) did an auto-upgrade to 4.18.0-14-generic, requested a reboot, and was unable to boot. After the "Starting Load/Save RF Kill Switch Status..." line it is waiting forever. (Or/and doing something behind the scenes. After a while, even the HDD indicator led go out.)

This is a permanent error, so kernel 4.18.0-14 does NOT boot.
I was able to boot with kernel 4.18.0-13. (By pressing Shift when grub starts.)

My configuration is "nothing fancy", possibly-except the locale (ISO-8859-2, hu and en), Xcfe4, gdm3, gnome-screensaver.
I have already upgraded to the latest packages. (sudo apt-get dist-upgrade)

dexter (rekoghllgsuz) wrote :

(Journalctl log.)

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1814555/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1814555

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: cosmic
Stefan Bader (smb) wrote :
Download full text (6.3 KiB)

Extracted from the failure log, it is the i915 (Intel graphics) driver crashing:

febr 04 15:52:16 hn kernel: [drm] RC6 disabled, disabling runtime PM support
febr 04 15:52:16 hn kernel: BUG: unable to handle kernel NULL pointer dereference at 0000000000000008
febr 04 15:52:16 hn kernel: PGD 0 P4D 0
febr 04 15:52:16 hn kernel: Oops: 0000 [#1] SMP PTI
febr 04 15:52:16 hn kernel: CPU: 3 PID: 557 Comm: systemd-udevd Not tainted 4.18.0-14-generic #15-Ubuntu
febr 04 15:52:16 hn kernel: Hardware name: SAMSUNG ELECTRONICS CO., LTD. NP-580-JA03DE/P580 , BIOS 06JM.M014.20100903.KSY 09/03/2010
febr 04 15:52:16 hn kernel: RIP: 0010:gen4_render_ring_flush+0x60/0x110 [i915]
febr 04 15:52:16 hn kernel: Code: 00 48 89 df e8 51 fe ff ff 48 3d 00 f0 ff ff 77 6c 44 89 20 48 8d 48 44 c7 40 04 02 40 00 7a 48 8b 53 78 48 8b 92 10 02 00 00 <48> 8b 52 08 48 c7 40 0c 00 00 00 00 83 ca 04 89 50 08 48 8d 50 14
febr 04 15:52:16 hn kernel: RSP: 0018:ffff9b2c80fc7978 EFLAGS: 00010287
febr 04 15:52:16 hn kernel: RAX: ffff9b2c90305000 RBX: ffff8bb5912b6880 RCX: ffff9b2c90305044
febr 04 15:52:16 hn kernel: RDX: 0000000000000000 RSI: 00000000000001a8 RDI: 0000000000000150
febr 04 15:52:16 hn kernel: RBP: ffff9b2c80fc7988 R08: 0000000000000001 R09: 0000000000000004
febr 04 15:52:16 hn kernel: R10: 0000000000000002 R11: ffff8bb5912b6880 R12: 0000000002000022
febr 04 15:52:16 hn kernel: R13: ffff8bb5912b6880 R14: ffff8bb58e230600 R15: ffff8bb58e6c8000
febr 04 15:52:16 hn kernel: FS: 00007fb6a9ccd8c0(0000) GS:ffff8bb597d80000(0000) knlGS:0000000000000000
febr 04 15:52:16 hn kernel: CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
febr 04 15:52:16 hn kernel: CR2: 0000000000000008 CR3: 000000010ddec000 CR4: 00000000000006e0
febr 04 15:52:16 hn kernel: Call Trace:
febr 04 15:52:16 hn kernel: i915_request_alloc+0x24e/0x370 [i915]
febr 04 15:52:16 hn kernel: i915_gem_init+0x26b/0x470 [i915]
febr 04 15:52:16 hn kernel: i915_driver_load+0xab8/0xd80 [i915]
febr 04 15:52:16 hn kernel: ? mutex_lock+0x12/0x30
febr 04 15:52:16 hn kernel: i915_pci_probe+0x46/0x60 [i915]
febr 04 15:52:16 hn kernel: local_pci_probe+0x46/0x90
febr 04 15:52:16 hn kernel: pci_device_probe+0x11c/0x1a0
febr 04 15:52:16 hn kernel: driver_probe_device+0x2e3/0x460
febr 04 15:52:16 hn kernel: __driver_attach+0xe4/0x110
febr 04 15:52:16 hn kernel: ? driver_probe_device+0x460/0x460
febr 04 15:52:16 hn kernel: bus_for_each_dev+0x74/0xb0
febr 04 15:52:16 hn kernel: ? kmem_cache_alloc_trace+0x165/0x1d0
febr 04 15:52:16 hn kernel: driver_attach+0x1e/0x20
febr 04 15:52:16 hn kernel: bus_add_driver+0x159/0x230
febr 04 15:52:16 hn kernel: ? 0xffffffffc0a96000
febr 04 15:52:16 hn kernel: driver_register+0x70/0xc0
febr 04 15:52:16 hn kernel: ? 0xffffffffc0a96000
febr 04 15:52:16 hn kernel: __pci_register_driver+0x57/0x60
febr 04 15:52:16 hn kernel: i915_init+0x55/0x58 [i915]
febr 04 15:52:16 hn kernel: do_one_initcall+0x4a/0x1c4
febr 04 15:52:16 hn kernel: ? _cond_resched+0x19/0x30
febr 04 15:52:16 hn kernel: ? kmem_cache_alloc_trace+0x165/0x1d0
febr 04 15:52:16 hn kernel: ? do_init_module+0x27/0x220
febr 04 15:52:16 hn kernel: do_init_module+0x60/0x220
febr 04 15:52:16 hn kernel:...

Read more...

Timo Aaltonen (tjaalton) wrote :

revert this:

commit 06e562e7f515292ea7721475950f23554214adde
Author: Chris Wilson <email address hidden>
Date: Mon Nov 5 09:43:05 2018 +0000

    drm/i915/ringbuffer: Delay after EMIT_INVALIDATE for gen4/gen5

    commit fb5bbae9b1333d44023713946fdd28db0cd85751 upstream.

Timo Aaltonen (tjaalton) wrote :

or pick

commit 5179749925933575a67f9d8f16d0cc204f98a29f
Author: Chris Wilson <email address hidden>
Date: Tue Dec 4 14:15:16 2018 +0000

    drm/i915: Allocate a common scratch page

from drm-intel-next, will be in 4.18.21

Stefan Bader (smb) wrote :

Prepared a test kernel (though unsigned) which does the revert. The debs can be found at: http://people.canonical.com/~smb/lp1814555/

jokrebel (jokrebel) on 2019-02-07
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
jokrebel (jokrebel) wrote :

same problem here with a nearly virgin 18.10 installation. The new kernel stopps booting with the grub background. Even when remove quiet splash there only comes up:

4.18.0-14 generic wird geladen....
initiale Ramdisk wird geladen ....

then the HD works on for some seconds (and then stops) but nothing else is posted

jokrebel (jokrebel) wrote :

hmm "Remember, this bug report is a duplicate of bug #1813657.
Comment here only if you think the duplicate status is wrong."

not sure; but #1813657 talks about 18.04 but my system is 18.10

driver in use i915

Stefan Bader (smb) wrote :

It says based on 18.04 but the kernel is the same as here (the 18.10 4.18 version).

Stefan Bader (smb) wrote :

Actually I fixed up duplication to point at this report as this is the one that the replacement kernel will automatically close once the update is ready.

Changed in linux (Ubuntu Cosmic):
importance: Undecided → High
status: New → Fix Committed
Changed in linux (Ubuntu):
status: Confirmed → Invalid
joenindho (joenindho) wrote :

hi..

it happened with me too,Ubuntu 18.10 on lenovo 3000 g410.
i had to fresh install my laptop twice before knowing this is a bug.

Right know i have to boot up from previous kernel. (4.18.0-10-generic).
sorry english is not my native,and not knowing linux very well..

P.D. (paed808) wrote :

@jokrebel Yeah, the 4.18 kernel is available in the 18.04 repositories, and thus is available as an optional kernel to install in the Linux Mint update manager, it doesn't just affect 18.10 (although you have to opt to install the kernel manually)

P.D. (paed808) wrote :

@Stefan Bader I confirm that your test kernel boots up fine.

Jan Schnackenberg (yehaa) wrote :

@Stefan Bader: I just installed the kernel from comment #8 and can confirm that it boots without issues.

I'm looking forward for this to hit the repositories, because currently apt won't install anything anymore until I fix the "broken installs" (reinstall the official kernel).

Khaled El Mously (kmously) wrote :

@Jan Schnackenberg: That's strange. A kernel with a boot-regression should not really have an effect on apt

Maybe "apt-get update --fix-missing" could fix that?

Jan Schnackenberg (yehaa) wrote :

Sorry for this OT discussion, just to explain my comment:

I had to "dpkg --force-depends -r linux-image-4.18.0-14-generic" because otherwise dpkg did not allow me to install the "unsigned" package from the link above. Now apt tells me, that the dependencies are borked and I need to use "--fix-broken" and that then tells me it needs to remove the "unsigned" kernel and reinstall the one that caused the issue in this bug.

Anyhow. I'll wait for a kernel-update on my on computer and then will manually fix/update the packages on my fathers machine.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 4.18.0-15.16

---------------
linux (4.18.0-15.16) cosmic; urgency=medium

  * Ubuntu boot failure. 4.18.0-14 boot stalls. (does not boot) (LP: #1814555)
    - Revert "drm/i915/ringbuffer: Delay after EMIT_INVALIDATE for gen4/gen5"

  * Userspace break as a result of missing patch backport (LP: #1813873)
    - tty: Don't hold ldisc lock in tty_reopen() if ldisc present

 -- Stefan Bader <email address hidden> Thu, 07 Feb 2019 11:24:34 +0100

Changed in linux (Ubuntu Cosmic):
status: Fix Committed → Fix Released
fyo (fyo) wrote :

4.18.0-15.16 is available in -proposed and does not boot.

Bader's test kernel above works.

Greg Ward (gward) wrote :

Fix works for me (I opened duplicate #1815152): I apt upgraded to linux-modules-4.18.0-15-generic 4.18.0-15.16, and now my system boots just fine. Thanks!

fyo (fyo) wrote :

Changed to works for me. I had installed 4.18.0-15.16 from the -proposed repo prior to #19, but a search of kern.log shows that I apparently failed to select it on boot for some inexplicable reason.

So, yes, fix works. Great. Thanks!

P.D. (paed808) wrote :

Confirmed fixed even in 18.04

jokrebel (jokrebel) wrote :

After newly update my 18.10 (under the old -13 kernel) it installed 4.18.0-15 which now is back to boot fine.
Thanks a lot

Yonsy (yonsy) wrote :

In my case (Ubuntu 18.04.2) my machine boot normally, suspend and restore normally if the suspension is only for less than two hours roughly. if the restore is tried later, the machine resume but no keyboard active, only mouse/touchpad (Dell Inspiron 13 5000, i7 8550u)

Colin Law (colin-law) wrote :

@yonsy your problem is not caused by this bug, which completely prevents booting.

Antoine (antoine671) wrote :

Fixed for me too, thanks a lot.

Török Edwin (edwintorok) wrote :

I confirm that 4.18.0-15.16 has fixed the problem for me too on a Lenovo X300, thanks.

Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
P.D. (paed808) on 2019-02-14
tags: added: verification-done-bionic
removed: verification-needed-bionic
Steve Redshaw (steveredshaw) wrote :

Mint 19.1 now boots using the latest kernel 4.18.0-15.16

Zingam (registrirayme) wrote :

I upgraded Ubuntu to 18.04.2 HWE and my laptop Dell Inspiron 7567 cannot reach the login screen with the kernel 4.18.0-15.16 now. Older kernels login normally.

tags: added: verification-failed-bionic
removed: verification-done-bionic
Zingam (registrirayme) wrote :

Inspiron 7567 has Intel HD 630 and NVIDIA 1050Ti. NVIDIA propr. driver never worked for me.
I used UKUU and tried a few kernels past 4.18.x and none of them worked. I had to uninstall them and I use 4.15, which lets the laptop to boot normally.
Although I have noticed a few graphical glitches after installing 18.04.2 HWE.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers