powerpc/pmu/ebb test in ubuntu_kernel_selftest failed with "error while loading shared libraries" on Bionic/Cosmic PowerPC

Bug #1812805 reported by Po-Hsu Lin on 2019-01-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Po-Hsu Lin
linux (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Po-Hsu Lin
Cosmic
Undecided
Po-Hsu Lin

Bug Description

== Justification ==
The selftests/powerpc/pmu/ebb test will fail on Ubunut PowerPC with:
   error while loading shared libraries: R_PPC64_ADDR16_HI reloc at
   0x00000f046fb04550 for symbol `' out of range

This is because the Ubuntu toolchain builds has PIE enabled by default.

== Fix ==
98415da0 (selftests/powerpc/pmu: Link ebb tests with -no-pie)

This fix will use -no-pie flag to build the test.

Patch already landed in Disco, and can be cherry-picked for B/C.
For Xenial, we don't have this test in our tree thus it can be ignored.

== Test ==
Patch verified on a Bionic P9 system, all the ebb tests will pass.

== Regression Potential ==
None.
This patchset is just for the kernel testing tool.

== Original Bug Report ==
In linux/tools/testing/selftests/powerpc/pmu/ebb:

selftests: reg_access_test
========================================
./reg_access_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x00000e3dcc384550 for symbol `' out of range
not ok 1..1 selftests: reg_access_test [FAIL]
selftests: event_attributes_test
========================================
./event_attributes_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x0000059efa3c4af0 for symbol `' out of range
not ok 1..2 selftests: event_attributes_test [FAIL]
selftests: cycles_test
========================================
./cycles_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x00000baa1a664750 for symbol `' out of range
not ok 1..3 selftests: cycles_test [FAIL]
selftests: cycles_with_freeze_test
========================================
./cycles_with_freeze_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x000003b22e124920 for symbol `' out of range
not ok 1..4 selftests: cycles_with_freeze_test [FAIL]
selftests: pmc56_overflow_test
========================================
./pmc56_overflow_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x00000a07e9bb47e0 for symbol `' out of range
not ok 1..5 selftests: pmc56_overflow_test [FAIL]
selftests: ebb_vs_cpu_event_test
========================================
./ebb_vs_cpu_event_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x000001b0f3644820 for symbol `' out of range
not ok 1..6 selftests: ebb_vs_cpu_event_test [FAIL]
selftests: cpu_event_vs_ebb_test
========================================
./cpu_event_vs_ebb_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x00000ac0538147e0 for symbol `' out of range
not ok 1..7 selftests: cpu_event_vs_ebb_test [FAIL]
selftests: cpu_event_pinned_vs_ebb_test
========================================
./cpu_event_pinned_vs_ebb_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x00000d1eaeab4800 for symbol `' out of range
not ok 1..8 selftests: cpu_event_pinned_vs_ebb_test [FAIL]
selftests: task_event_vs_ebb_test
========================================
./task_event_vs_ebb_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x0000034ed21e4730 for symbol `' out of range
not ok 1..9 selftests: task_event_vs_ebb_test [FAIL]
selftests: task_event_pinned_vs_ebb_test
========================================
./task_event_pinned_vs_ebb_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x00000a5b9a844780 for symbol `' out of range
not ok 1..10 selftests: task_event_pinned_vs_ebb_test [FAIL]
selftests: multi_ebb_procs_test
========================================
./multi_ebb_procs_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x000008b649fb4870 for symbol `' out of range
not ok 1..11 selftests: multi_ebb_procs_test [FAIL]
selftests: multi_counter_test
========================================
./multi_counter_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x0000063184dc4970 for symbol `' out of range
not ok 1..12 selftests: multi_counter_test [FAIL]
selftests: pmae_handling_test
========================================
./pmae_handling_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x00000e62316248d0 for symbol `' out of range
not ok 1..13 selftests: pmae_handling_test [FAIL]
selftests: close_clears_pmcc_test
========================================
./close_clears_pmcc_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x00000f02572846c0 for symbol `' out of range
not ok 1..14 selftests: close_clears_pmcc_test [FAIL]
selftests: instruction_count_test
========================================
./instruction_count_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x00000ef1f78f4ae0 for symbol `' out of range
not ok 1..15 selftests: instruction_count_test [FAIL]
selftests: fork_cleanup_test
========================================
./fork_cleanup_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x00000adc96c34700 for symbol `' out of range
not ok 1..16 selftests: fork_cleanup_test [FAIL]
selftests: ebb_on_child_test
========================================
./ebb_on_child_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x00000a96aed74790 for symbol `' out of range
not ok 1..17 selftests: ebb_on_child_test [FAIL]
selftests: ebb_on_willing_child_test
========================================
./ebb_on_willing_child_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x00000275daf747b0 for symbol `' out of range
not ok 1..18 selftests: ebb_on_willing_child_test [FAIL]
selftests: back_to_back_ebbs_test
========================================
./back_to_back_ebbs_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x000005eb74dd47f0 for symbol `' out of range
not ok 1..19 selftests: back_to_back_ebbs_test [FAIL]
selftests: lost_exception_test
========================================
./lost_exception_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x000002a39f5c4830 for symbol `' out of range
not ok 1..20 selftests: lost_exception_test [FAIL]
selftests: no_handler_test
========================================
./no_handler_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x00000ac7d0b64650 for symbol `' out of range
not ok 1..21 selftests: no_handler_test [FAIL]
selftests: cycles_with_mmcr2_test
========================================
./cycles_with_mmcr2_test: error while loading shared libraries: R_PPC64_ADDR16_HI reloc at 0x00000c8d2f3347e0 for symbol `' out of range
not ok 1..22 selftests: cycles_with_mmcr2_test [FAIL]

For the ptrace in powerpc (powerpc/ptrace):
test: ptrace_tm_spd_gpr
tags: git_version:c186097-dirty
!! killing ptrace_tm_spd_gpr
!! child died by signal 15
failure: ptrace_tm_spd_gpr
not ok 1..3 selftests: ptrace-tm-spd-gpr [FAIL]

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: linux-image-4.15.0-43-generic 4.15.0-43.46
ProcVersionSignature: Ubuntu 4.15.0-43.46-generic 4.15.18
Uname: Linux 4.15.0-43-generic ppc64le
AlsaDevices:
 total 0
 crw-rw---- 1 root audio 116, 1 Jan 22 04:30 seq
 crw-rw---- 1 root audio 116, 33 Jan 22 04:30 timer
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay': 'aplay'
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: ppc64el
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord': 'arecord'
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
Date: Tue Jan 22 06:56:25 2019
IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig': 'iwconfig'
Lsusb:
 Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
PciMultimedia:

ProcFB:

ProcKernelCmdLine: root=/dev/mapper/mpath0-part2 ro console=hvc0
ProcLoadAvg: 0.08 0.02 0.02 1/1489 41341
ProcSwaps:
 Filename Type Size Used Priority
 /swap.img file 8388544 0 -2
ProcVersion: Linux version 4.15.0-43-generic (buildd@bos02-ppc64el-020) (gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3)) #46-Ubuntu SMP Thu Dec 6 14:43:28 UTC 2018
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-43-generic N/A
 linux-backports-modules-4.15.0-43-generic N/A
 linux-firmware 1.173.3
RfKill: Error: [Errno 2] No such file or directory: 'rfkill': 'rfkill'
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
VarLogDump_list: total 0
cpu_cores: Number of cores present = 20
cpu_coreson: Number of cores online = 20
cpu_dscr: DSCR is 0
cpu_freq:
 min: 3.694 GHz (cpu 159)
 max: 3.694 GHz (cpu 1)
 avg: 3.694 GHz
cpu_runmode:
 Could not retrieve current diagnostics mode,
 No kernel interface to firmware
cpu_smt: SMT=8

Po-Hsu Lin (cypressyew) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Didn't see this:
    ptrace-tm-spd-gpr [FAIL]

on Power9 with the same kernel.

Po-Hsu Lin (cypressyew) wrote :

For the ptrace issue, please refer to bug 1813127

Po-Hsu Lin (cypressyew) on 2019-01-24
summary: - powerpc test in ubuntu_kernel_selftest failed on Bionic PowerPC
+ powerpc/pmu/ebb test in ubuntu_kernel_selftest failed on Bionic PowerPC
summary: - powerpc/pmu/ebb test in ubuntu_kernel_selftest failed on Bionic PowerPC
+ powerpc/pmu/ebb test in ubuntu_kernel_selftest failed on Bionic/Cosmic
+ PowerPC
Po-Hsu Lin (cypressyew) on 2019-04-23
Changed in linux (Ubuntu Bionic):
assignee: nobody → Po-Hsu Lin (cypressyew)
status: New → In Progress
Po-Hsu Lin (cypressyew) wrote :

Patch already applied in Disco.

summary: - powerpc/pmu/ebb test in ubuntu_kernel_selftest failed on Bionic/Cosmic
- PowerPC
+ powerpc/pmu/ebb test in ubuntu_kernel_selftest failed with "error while
+ loading shared libraries" on Bionic/Cosmic PowerPC
Changed in ubuntu-kernel-tests:
assignee: nobody → Po-Hsu Lin (cypressyew)
Changed in linux (Ubuntu Cosmic):
assignee: nobody → Po-Hsu Lin (cypressyew)
Changed in ubuntu-kernel-tests:
status: New → In Progress
Changed in linux (Ubuntu Cosmic):
status: New → In Progress
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
tags: added: cosmic
Po-Hsu Lin (cypressyew) on 2019-04-24
description: updated
Changed in linux (Ubuntu Bionic):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Cosmic):
status: In Progress → Fix Committed
Changed in ubuntu-kernel-tests:
status: In Progress → Fix Committed
status: Fix Committed → In Progress

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
Po-Hsu Lin (cypressyew) wrote :

Passed with the proposed Bionic kernel.

tags: added: verification-done-bionic
removed: verification-needed-bionic

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-cosmic' to 'verification-done-cosmic'. If the problem still exists, change the tag 'verification-needed-cosmic' to 'verification-failed-cosmic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-cosmic
Po-Hsu Lin (cypressyew) on 2019-05-21
Changed in ubuntu-kernel-tests:
status: In Progress → Fix Released
Po-Hsu Lin (cypressyew) wrote :

Passed with proposed Cosmic kernel.

tags: added: verification-done-cosmic
removed: verification-needed-cosmic
Launchpad Janitor (janitor) wrote :
Download full text (3.8 KiB)

This bug was fixed in the package linux - 4.15.0-51.55

---------------
linux (4.15.0-51.55) bionic; urgency=medium

  * linux: 4.15.0-51.55 -proposed tracker (LP: #1829219)

  * disable a.out support (LP: #1818552)
    - [Config] Disable a.out support

  * [UBUNTU] qdio: clear intparm during shutdown (LP: #1828394)
    - s390/qdio: clear intparm during shutdown

  * ftrace in ubuntu_kernel_selftests hang with Cosmic kernel (LP: #1826385)
    - kprobes/x86: Fix instruction patching corruption when copying more than one
      RIP-relative instruction

  * touchpad not working on lenovo yoga 530 (LP: #1787775)
    - Revert "UBUNTU: SAUCE: i2c:amd Depends on ACPI"
    - Revert "UBUNTU: SAUCE: i2c:amd move out pointer in union i2c_event_base"
    - Revert "UBUNTU: SAUCE: i2c:amd I2C Driver based on PCI Interface for
      upcoming platform"
    - i2c: add helpers to ease DMA handling
    - i2c: add a message flag for DMA safe buffers
    - i2c: add extra check to safe DMA buffer helper
    - i2c: Add drivers for the AMD PCIe MP2 I2C controller
    - [Config] Update config for AMD MP2 I2C driver
    - [Config] Update I2C_AMD_MP2 annotations

  * tm-unavailable in powerpc/tm failed on Bionic Power9 (LP: #1813129)
    - selftests/powerpc: Check for pthread errors in tm-unavailable
    - selftests/powerpc: Skip tm-unavailable if TM is not enabled

  * cp_abort in powerpc/context_switch from ubunut_kernel_selftests failed on
    Bionic P9 (LP: #1813134)
    - selftests/powerpc: Remove redundant cp_abort test

  * bionic/linux: completely remove snapdragon files from sources (LP: #1827880)
    - [Packaging] remove snapdragon dead files
    - [Config] update configs after snapdragon removal

  * The noise keeps occurring when Headset is plugged in on a Dell machine
    (LP: #1827972)
    - ALSA: hda/realtek - Fixed Dell AIO speaker noise

  * Geneve tunnels don't work when ipv6 is disabled (LP: #1794232)
    - geneve: correctly handle ipv6.disable module parameter

  * There are 4 HDMI/Displayport audio output listed in sound setting without
    attach any HDMI/DP monitor (LP: #1827967)
    - ALSA: hda/hdmi - Read the pin sense from register when repolling
    - ALSA: hda/hdmi - Consider eld_valid when reporting jack event

  * Headphone jack switch sense is inverted: plugging in headphones disables
    headphone output (LP: #1824259)
    - ASoC: rt5645: Headphone Jack sense inverts on the LattePanda board

  * CTAUTO:DevOps:860.50:devops4fp1:Error occurred during LINUX Dmesg error
    Checking for all LINUX clients for devops4p10 (LP: #1766201)
    - SAUCE: integrity: downgrade error to warning

  * Screen freeze after resume from S3 when HDMI monitor plugged on Dell
    Precision 7740 (LP: #1825958)
    - PCI: Restore resized BAR state on resume

  * potential memory corruption on arm64 on dev release (LP: #1827437)
    - driver core: Postpone DMA tear-down until after devres release

  * powerpc/pmu/ebb test in ubuntu_kernel_selftest failed with "error while
    loading shared libraries" on Bionic/Cosmic PowerPC (LP: #1812805)
    - selftests/powerpc/pmu: Link ebb tests with -no-pie

  * unnecessary request_queue freeze (LP: #1815733)
    - block: av...

Read more...

Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 4.18.0-21.22

---------------
linux (4.18.0-21.22) cosmic; urgency=medium

  * linux: 4.18.0-21.22 -proposed tracker (LP: #1829186)

  * disable a.out support (LP: #1818552)
    - [Config] Turn off a.out support

  * ftrace in ubuntu_kernel_selftests hang with Cosmic kernel (LP: #1826385)
    - kprobes/x86: Fix instruction patching corruption when copying more than one
      RIP-relative instruction

  * touchpad not working on lenovo yoga 530 (LP: #1787775)
    - Revert "UBUNTU: SAUCE: i2c:amd Depends on ACPI"
    - Revert "UBUNTU: SAUCE: i2c:amd move out pointer in union i2c_event_base"
    - Revert "UBUNTU: SAUCE: i2c:amd I2C Driver based on PCI Interface for
      upcoming platform"
    - i2c: add extra check to safe DMA buffer helper
    - i2c: Add drivers for the AMD PCIe MP2 I2C controller
    - [Config] Update config for AMD MP2 I2C driver
    - [Config] Update I2C_AMD_MP2 annotations

  * Geneve tunnels don't work when ipv6 is disabled (LP: #1794232)
    - geneve: correctly handle ipv6.disable module parameter

  * There are 4 HDMI/Displayport audio output listed in sound setting without
    attach any HDMI/DP monitor (LP: #1827967)
    - ALSA: hda/hdmi - Read the pin sense from register when repolling
    - ALSA: hda/hdmi - Consider eld_valid when reporting jack event

  * Headphone jack switch sense is inverted: plugging in headphones disables
    headphone output (LP: #1824259)
    - ASoC: rt5645: Headphone Jack sense inverts on the LattePanda board

  * CTAUTO:DevOps:860.50:devops4fp1:Error occurred during LINUX Dmesg error
    Checking for all LINUX clients for devops4p10 (LP: #1766201)
    - SAUCE: integrity: downgrade error to warning

  * potential memory corruption on arm64 on dev release (LP: #1827437)
    - driver core: Postpone DMA tear-down until after devres release

  * powerpc/pmu/ebb test in ubuntu_kernel_selftest failed with "error while
    loading shared libraries" on Bionic/Cosmic PowerPC (LP: #1812805)
    - selftests/powerpc/pmu: Link ebb tests with -no-pie

  * unnecessary request_queue freeze (LP: #1815733)
    - block: avoid setting nr_requests to current value
    - block: avoid setting none scheduler if it's already none

  * Kprobe event string type argument failed in ftrace from
    ubuntu_kernel_selftests on B/C i386 (LP: #1825780)
    - selftests/ftrace: Fix kprobe string testcase to not probe notrace function

  * False positive test result in run_netsocktests from net in
    ubuntu_kernel_selftest (LP: #1825777)
    - selftests/net: correct the return value for run_netsocktests

 -- Stefan Bader <email address hidden> Wed, 15 May 2019 13:18:36 +0200

Changed in linux (Ubuntu Cosmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers