Boot failure on Dell Precision 5820 with Intel Xeon W-2123 CPU

Bug #1812758 reported by Kevin on 2019-01-21
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

So I'm trying to install Ubuntu 16.04.5 (happens on 18.04 as well) on a Dell Precision 5820 with a GTX 1080 in it. These machines are lease refreshes.

I created a UEFI image of 16.04.5, selected "Install Ubuntu" and then starts throwing a bunch of error messages stating

[33.192238] nouveau 0000:05:00.0: DRM: base-0: timeout

repeating over and over again. It never gets past this.

I tried the suggestions of adding "nomodeset" in grub when I'm booting. It progresses a little further but hangs at "failed to start Ubuntu Installation Service, please run journalctl to see what failed". I can't see what failed as I can't get a prompt since nothing is installed. I don't know where to go debug from here.

My computer boots to a black screen, what options do I have to fix it?

Graphics issues after/while installing Ubuntu 16.04/16.10 with NVIDIA graphics

Ubuntu 16.04 Installation Issue Boots Into Black Screen or Freezes - Nouveau/Nvidia Driver issue 1080ti

Ubuntu 16.04 installation blank screen

Ubuntu 16.04 unable to boot with GTX 1080

etc.

However, I tried Ubuntu 16.04.1 LTS and did NOT have the issues with the video and was successfully able to install Ubuntu 16.04.1. Unfortunately, 16.04.1 didn't support the integrated Intel i219-LM network card. I tried 16.04.2, 16.04.3, 16.04.4 and they all exhibit the same behavior as 16.04.5 with the video.

Just as a test, I installed 16.04.1, installed broadcom NIC (which was successfully detected), and upgraded from 16.04.1 --> 16.04.5 with apt-get and had no video issues after reboot (I didn't install the video drivers), in addition, after it was upgraded to 16.04.5 the Intel 219-LM drivers were added and would work. I have a workaround, but it's REALLY annoying.

The kicker in this is that the Dell Precision 5810 worked 100% correctly. Put the USB boot drive in, select the drive in UEFI to boot and everything works out of the box.

I'm working on gathering more logs of this issue and testing different kernel versions.

TJ (tj) on 2019-01-21
summary: - Boot failure on Dell Dell Precision 5820 with Intel Xeon W-2123 CPU
+ Boot failure on Dell Precision 5820 with Intel Xeon W-2123 CPU
Changed in linux (Ubuntu):
status: New → In Progress
assignee: nobody → TJ (tj)
Kevin (kvasko) wrote :
Download full text (3.5 KiB)

A workaround...but not a complete work around...

So I do believe I figured out a "solution" but it literally makes zero sense and indicates a problem with the Dell BIOS and potentially some oversight in the kernel?

Built 16.04.5 Desktop image with Rufus 3.3.1400.

Partition Scheme: MBR

Target system: BIOS (or UEFI-CSM)

All other options default.

1.0 So with the computer in UEFI Boot, Secure boot off.

Hit F12 to get into "One time boot menu".

In the "One time boot menu" you can select "Legacy" and UEFI boot options (e.g. USB Boot Device under legacy menu, and then under UEFI it shows the devices one being this Kingston USB device as a boot option).

1.1 In the UEFI Boot mode if you select the UEFI device, the system will not boot as describe above, no combination of nomodeset, acpi=off, noapci will work. The system hangs at a blinking cursor or in some type of error code as listed above.

1.2 In the UEFI boot mode if you select the USB boot drive under LEGACY, it boots into the selection screen correctly of (Install Ubuntu, Try Ubuntu, etc. menu). You will have to add the F6 options of nomodeset, acpi=off, noapci and then select the "Install Ubuntu" option and then the important part...YOU CANNOT BE USING ONE OF THE DISPLAY PORTS ON THE VIDEO CARD, YOU HAVE TO BE USING THE DVI PORT! At this point you will have the Desktop installer functioning.

I didn't really like this "solution" since you would have to be using the DVI port, so I dug some more...

2.0 I switched the machine into "LEGACY BOOT MODE, SECURE BOOT MODE OFF". In the one time boot option (when you hit F12 during POST) the boot menu will still show "LEGACY Boot Options" and "UEFI Boot Options". The same as before. However the results are different.

2.1 While in LEGACY boot mode in the one time boot option if you select the USB boot drive under LEGACY you get the SAME interaction as what I stated in 1.2. (e.g. to get the Installer Desktop GUI to show you have to add the nomodeset, acpi=off, noapci flags and then be plugged into the DVI port)

2.2 This is where it gets fun...while in LEGACY boot mode, select the USB boot device under the UEFI menu. The "Try Ubuntu, Install Ubuntu menu option shows", hit 'e' to edit the boot string, add the "nomodeset" flag hit F10, AND IT BOOTS CORRECTLY, with the DisplayPorts.

So why is this stupid? The computer has to be IN LEGACY BOOT MODE AND you must select the boot option from the UEFI menu. Which makes literally zero sense. Why would I need to put the computer in LEGACY mode to only select the boot option from the UEFI menu. You have to add the nomodeset option as well, but the options you have to select are quite absurd to me.

So for anyone running into this with BIOS 1.8 in a Dell Precision 5820.

    Create USB drive that will boot in UEFI mode. You can use Rufus that will boot in UEFI mode or Legacy mode, but I doubt this matters.

        Set the computer to LEGACY BOOT MODE (THIS IS IMPORTANT)

        When the computer is posting hit F12 to enter in the one time boot menu.

        Select the USB device to boot from WITHIN the UEFI menu (you will see both).

        Highlight the "Install Ubuntu" option and hit 'e'. On the "Li...

Read more...

TJ (tj) wrote :

Have you used the service tag to see if you can get a link to the Dell Ubuntu 16.04 installation images?

"For those who purchased their system from Dell with Ubuntu already installed, there are recovery images on their system and if fitting a new hard drive they can download an installation image by going to the Dell Support site and entering the systems service tag or express service code and selecting Drivers and Downloads."

From https://www.dell.com/support/article/uk/en/ukbsdt1/sln151664/how-to-install-ubuntu-linux-on-your-dell-pc?lang=en

Alternatively you may need to contact Dell support directly - that might be the better option here since presumably Dell have configured these images to 'just work' and save you some time needing to debug it.

TJ (tj) wrote :

Here is another related experience which may give some insight:

https://ubuntuforums.org/showthread.php?t=2381899

TJ (tj) wrote :

Related Canonical/Ubuntu hardware certification for this model. Notes suggest Dell-installed image is/may not be the same as used by Ubuntu.

https://certification.ubuntu.com/hardware/201707-25590/

TJ (tj) on 2019-01-22
Changed in linux (Ubuntu):
status: In Progress → Incomplete
assignee: TJ (tj) → nobody
Kai-Heng Feng (kaihengfeng) wrote :

- Does your system have a video output from integrated GPU? Use it for installation.
- Booth with kernel parameter "nouveau.modeset=0"
- Install Ubuntu and Nvidia proprietary graphics driver.
- Reboot and now it's ok to use to Nvidia as video output.

Kevin (kvasko) wrote :

@Kai-Heng Feng (kaihengfeng)

It does not have an integrated GPU. I've tried several other GPUs.

I've done the installation with nomodeset kernel parameters and noapci and a few others. Got it to install, installed the GPU drivers, however it still wouldn't boot properly/consistently without parameters such as noapci. Unfortunately, adding noapci causes the system to only detect 1 CPU core.

I'm going to try and get some more logs. I honestly feel this is some type of regression.

@TJ (tj)

So the information you posted about the certification from Dell is on 16.04.1. If I create a boot media with that version, the machine boots without problem, however 16.04.1 doesn't have new enough drivers to support the on board NIC card. As soon as I upgrade to 16.04.2+ things start breaking.

I'm going to try and work on this today and see if I can produce some kernel logs.

Kevin (kvasko) wrote :

I had some luck with Dell after I told them to give me a different machine. Finally got in touch with someone with Dell support that checked their knowledge base.

There is an option in the Dell BIOS that has to do with "Intel VMD Technology". The solution that Dell provided was to disable the VMD feature (e.g.mark it as disabled) and in the PCIE Devices list: uncheck all devices and reboot.

After doing that, 16.04 and 18.04 now seem to boot without any kernel flags (as long as the nouveau driver supports the card). I'm still doing testing to make sure that this is a work around where the machine will see all devices instead of just 1 core.

Will report back with the results.

Kevin (kvasko) wrote :

I was able to install 18.04 without issue. It looks like the solution to disable "Intel VMD Technology" in the BIOS solved the issue.

Kevin (kvasko) wrote :

What status should this bug be moved to?

Obviously there is something fishy going on with Intel VMD being enabled, but I'm not using it so it doesn't impact me in this case. Should I get any logs to assist in figuring out why enabling VMD causes the system not boot properly?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.