Backported commit breaks audio (fixed upstream)

Bug #1811566 reported by Jaime Pérez on 2019-01-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Status tracked in Disco
Cosmic
Medium
Po-Hsu Lin
Disco
Medium
Unassigned

Bug Description

== Justification ==
Commit 648e921888ad96ea3dc922739e96716ad3225d7f (clk: x86: Stop marking clocks as CLK_IS_CRITICAL) backported to Cosmic kernel fixed the bug that keeps unused clocks on, but it is breaking the audio support on some Chromebooks (Swanky / Clapper/ Gnawty) since we were not using
the right clock in the cht_bsw_max98090_ti machine driver.

== Fix ==
a182ecd (ASoC: intel: cht_bsw_max98090_ti: Add quirk for boards
 using pmc_plt_clk_0)
984bfb3 (ASoC: intel: cht_bsw_max98090_ti: Add pmc_plt_clk_0 quirk)
94ea56c (ASoC: intel: cht_bsw_max98090_ti: Add pmc_plt_clk_0 quirk)

These 3 patches can be cherry-picked to Cosmic.

== Test ==
Test kernel with these 3 patches could be found in:
http://people.canonical.com/~phlin/kernel/lp-1811566-chromebook-Gnawty/

Bug reporter stated that this kernel can fix the audio issue as expected.

== Regression potential ==
Low,
changes are limited in the cht_bsw_max98090_ti driver with a new DMI based quirk table that contains these 3 Chromebook models and some logic to determine the right clock to use.

It seems that commit 648e921888ad96ea3dc922739e96716ad3225d7f was backported to ubuntu's 4.18 kernel. That commit breaks audio for some devices (chromebook gnawty) (from 4.19 on). Now 4.19, 4.20, 5.0 are fixed, with patch on commit:

47148001ae12292984ba1b38d9babefb9a46cd3e
ASoC: intel: cht_bsw_max98090_ti: Add pmc_plt_clk_0 quirk for Chromebook Gnawty

Bug reported:

https://bugzilla.kernel.org/show_bug.cgi?id=201787

Jaime Pérez (jaime-91) on 2019-01-13
Changed in linux (Ubuntu):
status: New → Fix Released
status: Fix Released → New
description: updated
description: updated
Jaime Pérez (jaime-91) on 2019-01-13
tags: added: regression

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1811566

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Jaime Pérez (jaime-91) wrote :

No need of logs, as is reported and fixed upstream

Changed in linux (Ubuntu):
status: Incomplete → New

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1811566

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Po-Hsu Lin (cypressyew) on 2019-01-14
tags: added: cosmic disco
Po-Hsu Lin (cypressyew) wrote :

This patch:
    ASoC: intel: cht_bsw_max98090_ti: Add pmc_plt_clk_0 quirk for Chromebook
is actually with SHA1:
    94ea56cff506c769a509c5dd87904c7fe3806a81

And this patch could be found in the Disco kernel, applied 3 days ago:
    https://kernel.ubuntu.com/git/ubuntu/ubuntu-disco.git/commit/?h=master-next&id=a0c45e39dad82e08fbcafb96201c6714b792e60b

For this patch to land on Cosmic 4.18, it will need:
    1. a182ecd (ASoC: intel: cht_bsw_max98090_ti: Add quirk for boards using pmc_plt_clk_0)
    2. 984bfb3 (ASoC: intel: cht_bsw_max98090_ti: Add pmc_plt_clk_0 quirk for Chromebook Clapper)
    3. 94ea56c (ASoC: intel: cht_bsw_max98090_ti: Add pmc_plt_clk_0 quirk for Chromebook Gnawty)

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Po-Hsu Lin (cypressyew) wrote :

Hello Jaime,
I've built a test kernel with commits mentioned in comment #4
can you give this Cosmic test kernel a try to see if it can fix your audio issue?
http://people.canonical.com/~phlin/kernel/lp-1811566-chromebook-Gnawty/

Thanks!

Changed in linux (Ubuntu):
assignee: nobody → Po-Hsu Lin (cypressyew)
status: Confirmed → In Progress
Jaime Pérez (jaime-91) wrote :

It does, as expected

Po-Hsu Lin (cypressyew) on 2019-01-15
description: updated
Stefan Bader (smb) on 2019-01-15
Changed in linux (Ubuntu Disco):
importance: Undecided → Medium
Changed in linux (Ubuntu Cosmic):
importance: Undecided → Medium
status: New → In Progress
Po-Hsu Lin (cypressyew) on 2019-01-16
Changed in linux (Ubuntu Cosmic):
assignee: nobody → Po-Hsu Lin (cypressyew)
Changed in linux (Ubuntu Disco):
assignee: Po-Hsu Lin (cypressyew) → nobody
status: In Progress → Fix Released
tags: removed: disco
Changed in linux (Ubuntu Cosmic):
status: In Progress → Fix Committed
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-cosmic' to 'verification-done-cosmic'. If the problem still exists, change the tag 'verification-needed-cosmic' to 'verification-failed-cosmic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-cosmic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers