raw_skew in timer from the ubuntu_kernel_selftests failed on Bionic

Bug #1811194 reported by Po-Hsu Lin on 2019-01-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Medium
Dan Streetman
Cosmic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

[impact]

autopkgtest failure during test for linux pkg.

ADJ_OFFSET during test causes skew, and test to fail.

[test case]

this only happens intermittently, but frequently on the autopkgtests.

when it happens it looks like:

20:46:54 DEBUG| [stdout] WARNING: ADJ_OFFSET in progress, this will cause inaccurate results
20:48:54 DEBUG| [stdout] Estimating clock drift: 16.881(est) 27.184(act) [FAILED]

when it happens with a patched kernel it looks like:

01:04:35 DEBUG| [stdout] WARNING: ADJ_OFFSET in progress, this will cause inaccurate results
01:06:35 DEBUG| [stdout] Estimating clock drift: 14.52(est) 13.641(act) [OK]

[regression potential]

since this skips the test in question, it might miss an actual regression that the test should have caught; however, since ADJ_OFFSET is not always in progress during the test, if a real regression happens for this test, then it should correctly fail for test runs which have no concurrent ADJ_OFFSET and thus don't skip the test.

[other info]

original description:
---

This issue cannot be reproduced across all of our SUTs, issue found on node secchi (3 out of 3).
And sometimes on node amaura (2 out of 4)

selftests: raw_skew
========================================
WARNING: ADJ_OFFSET in progress, this will cause inaccurate results
Estimating clock drift: 29.255(est) 30.529(act) [FAILED]
Bail out!
Pass 0 Fail 0 Xfail 0 Xpass 0 Skip 0 Error 0
1..0
not ok 1..7 selftests: raw_skew [FAIL]

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: linux-image-4.15.0-43-generic 4.15.0-43.46
ProcVersionSignature: User Name 4.15.0-43.46-generic 4.15.18
Uname: Linux 4.15.0-43-generic x86_64
AlsaDevices:
 total 0
 crw-rw---- 1 root audio 116, 1 Jan 10 03:58 seq
 crw-rw---- 1 root audio 116, 33 Jan 10 03:58 timer
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay': 'aplay'
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord': 'arecord'
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
Date: Thu Jan 10 06:25:41 2019
IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig': 'iwconfig'
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 0b1f:03e9 Insyde Software Corp.
 Bus 001 Device 002: ID 0000:0001
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Intel Corporation S2600WFT
PciMultimedia:

ProcFB: 0 astdrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-43-generic root=UUID=9210e07a-fd34-474c-b77e-f7508f27e234 ro console=ttyS0,115200n8
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-43-generic N/A
 linux-backports-modules-4.15.0-43-generic N/A
 linux-firmware 1.173.2
RfKill: Error: [Errno 2] No such file or directory: 'rfkill': 'rfkill'
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/12/2016
dmi.bios.vendor: Intel Corporation
dmi.bios.version: SE5C620.86B.01.00.0294.101220161543
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: S2600WFT
dmi.board.vendor: Intel Corporation
dmi.board.version: H48104-410
dmi.chassis.asset.tag: ....................
dmi.chassis.type: 23
dmi.chassis.vendor: ...............................
dmi.chassis.version: ..................
dmi.modalias: dmi:bvnIntelCorporation:bvrSE5C620.86B.01.00.0294.101220161543:bd10/12/2016:svnIntelCorporation:pnS2600WFT:pvr....................:rvnIntelCorporation:rnS2600WFT:rvrH48104-410:cvn...............................:ct23:cvr..................:
dmi.product.family: Family
dmi.product.name: S2600WFT
dmi.product.version: ....................
dmi.sys.vendor: Intel Corporation

Po-Hsu Lin (cypressyew) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Po-Hsu Lin (cypressyew) on 2019-01-10
description: updated
Dan Streetman (ddstreet) wrote :

I believe this is fixed (worked around, by skipping the test when ADJ_OFFSET is detected) by upstream commit 1416270f4a1ae83ea84156ceba19a66a8f88be1f:

commit 1416270f4a1ae83ea84156ceba19a66a8f88be1f
Author: John Stultz <email address hidden>
Date: Tue May 29 19:12:18 2018 -0700

    selftest: timers: Tweak raw_skew to SKIP when ADJ_OFFSET/other clock adjustments are in progress

This commit is included upstream in v4.19, already included in cosmic (and disco) via bug 1794597, already included in xenial via bug 1798587.

Does not appear that it's in bionic yet.

Changed in linux (Ubuntu Disco):
status: Confirmed → Fix Released
Changed in linux (Ubuntu Cosmic):
status: New → Fix Released
Changed in linux (Ubuntu Xenial):
status: New → Fix Released
Changed in linux (Ubuntu Bionic):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Dan Streetman (ddstreet)
Dan Streetman (ddstreet) on 2019-02-01
Changed in linux (Ubuntu Bionic):
importance: Low → Medium
Dan Streetman (ddstreet) on 2019-02-01
description: updated
Changed in linux (Ubuntu Bionic):
status: In Progress → Fix Committed
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
Po-Hsu Lin (cypressyew) wrote :

Passed with the proposed Bionic kernel - 4.15.0-47.50

 selftests: raw_skew
 ========================================
 WARNING: ADJ_OFFSET in progress, this will cause inaccurate results
 Estimating clock drift: 0.553(est) 0.89(act) [OK]
 Pass 0 Fail 0 Xfail 0 Xpass 0 Skip 0 Error 0
 1..0
 ok 1..7 selftests: raw_skew [PASS]

tags: added: verification-done-bionic
removed: verification-needed-bionic
Changed in ubuntu-kernel-tests:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (25.4 KiB)

This bug was fixed in the package linux - 4.15.0-47.50

---------------
linux (4.15.0-47.50) bionic; urgency=medium

  * linux: 4.15.0-47.50 -proposed tracker (LP: #1819716)

  * Packaging resync (LP: #1786013)
    - [Packaging] resync getabis
    - [Packaging] update helper scripts
    - [Packaging] resync retpoline extraction

  * C++ demangling support missing from perf (LP: #1396654)
    - [Packaging] fix a mistype

  * arm-smmu-v3 arm-smmu-v3.3.auto: CMD_SYNC timeout (LP: #1818162)
    - iommu/arm-smmu-v3: Fix unexpected CMD_SYNC timeout

  * Crash in nvme_irq_check() when using threaded interrupts (LP: #1818747)
    - nvme-pci: fix out of bounds access in nvme_cqe_pending

  * CVE-2019-9213
    - mm: enforce min addr even if capable() in expand_downwards()

  * CVE-2019-3460
    - Bluetooth: Check L2CAP option sizes returned from l2cap_get_conf_opt

  * amdgpu with mst WARNING on blanking (LP: #1814308)
    - drm/amd/display: Don't use dc_link in link_encoder
    - drm/amd/display: Move wait for hpd ready out from edp power control.
    - drm/amd/display: eDP sequence BL off first then DP blank.
    - drm/amd/display: Fix unused variable compilation error
    - drm/amd/display: Fix warning about misaligned code
    - drm/amd/display: Fix MST dp_blank REG_WAIT timeout

  * tun/tap: unable to manage carrier state from userland (LP: #1806392)
    - tun: implement carrier change

  * CVE-2019-8980
    - exec: Fix mem leak in kernel_read_file

  * raw_skew in timer from the ubuntu_kernel_selftests failed on Bionic
    (LP: #1811194)
    - selftest: timers: Tweak raw_skew to SKIP when ADJ_OFFSET/other clock
      adjustments are in progress

  * [Packaging] Allow overlay of config annotations (LP: #1752072)
    - [Packaging] config-check: Add an include directive

  * CVE-2019-7308
    - bpf: move {prev_,}insn_idx into verifier env
    - bpf: move tmp variable into ax register in interpreter
    - bpf: enable access to ax register also from verifier rewrite
    - bpf: restrict map value pointer arithmetic for unprivileged
    - bpf: restrict stack pointer arithmetic for unprivileged
    - bpf: restrict unknown scalars of mixed signed bounds for unprivileged
    - bpf: fix check_map_access smin_value test when pointer contains offset
    - bpf: prevent out of bounds speculation on pointer arithmetic
    - bpf: fix sanitation of alu op with pointer / scalar type from different
      paths
    - bpf: add various test cases to selftests

  * CVE-2017-5753
    - bpf: properly enforce index mask to prevent out-of-bounds speculation
    - bpf: fix inner map masking to prevent oob under speculation

  * BPF: kernel pointer leak to unprivileged userspace (LP: #1815259)
    - bpf/verifier: disallow pointer subtraction

  * squashfs hardening (LP: #1816756)
    - squashfs: more metadata hardening
    - squashfs metadata 2: electric boogaloo
    - squashfs: more metadata hardening
    - Squashfs: Compute expected length from inode size rather than block length

  * efi/arm/arm64: Allow SetVirtualAddressMap() to be omitted (LP: #1814982)
    - efi/arm/arm64: Allow SetVirtualAddressMap() to be omitted

  * Update ENA driver to version 2.0.3K (LP: #1816806)...

Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers