boot-hanger

Bug #1810407 reported by kiewitt on 2019-01-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

my Dell Inspiron-15-3552 with Linux version 4.15.0-43-generic has sometimes a boot-hanger.
Then Linux does not come up.
The very first lines of syslog gives the advice to investigate the WLAN named wlp1s0 (-> Attachment).

Sincerely
Peter
---
ApportVersion: 2.20.1-0ubuntu2.18
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: peter 1740 F.... pulseaudio
CurrentDesktop: XFCE
DistroRelease: Linux 18.3
HibernationDevice: RESUME=UUID=e70c1188-343e-45c4-a61d-0fbffb3c9fc8
InstallationDate: Installed on 2018-11-01 (63 days ago)
InstallationMedia: Linux Mint 18.3 "Sylvia" - Release amd64 20171213
MachineType: Dell Inc. Inspiron 15-3552
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-43-generic root=UUID=06c86e11-8588-49b6-a40b-b214dba0c0a5 ro quiet splash nomedeset
ProcVersionSignature: Ubuntu 4.15.0-43.46~16.04.1-generic 4.15.18
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-43-generic N/A
 linux-backports-modules-4.15.0-43-generic N/A
 linux-firmware 1.157.21
Tags: sylvia
Uname: Linux 4.15.0-43-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 03/06/2018
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 4.4.0
dmi.board.name: 079W3P
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvr4.4.0:bd03/06/2018:svnDellInc.:pnInspiron15-3552:pvr4.4.0:rvnDellInc.:rn079W3P:rvrA00:cvnDellInc.:ct8:cvrNotSpecified:
dmi.product.family: Inspiron
dmi.product.name: Inspiron 15-3552
dmi.product.version: 4.4.0
dmi.sys.vendor: Dell Inc.

kiewitt (p-thoms) wrote :
kiewitt (p-thoms) wrote :
Steve Langasek (vorlon) on 2019-01-03
affects: plymouth (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1810407

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: bionic

apport information

tags: added: apport-collected sylvia
description: updated
kiewitt (p-thoms) wrote : CRDA.txt

apport information

apport information

apport information

kiewitt (p-thoms) wrote : Lspci.txt

apport information

kiewitt (p-thoms) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

kiewitt (p-thoms) wrote : RfKill.txt

apport information

kiewitt (p-thoms) wrote : UdevDb.txt

apport information

apport information

kiewitt (p-thoms) on 2019-01-03
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
kiewitt (p-thoms) wrote :

update kern.log for Boothanger
Boothanger: kern3_err.log
Boot ok: kern4_ok.log

to see some difference in kern.log use Filter
- Oops
- PGD
- backlight

kiewitt (p-thoms) wrote :
Kai-Heng Feng (kaihengfeng) wrote :

Would it be possible for you to test the latest upstream kernel? Refer
to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest
v5.0 kernel [0].

If this bug is fixed in the mainline kernel, please add the following
tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag:
'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as
"Confirmed”, and attach dmesg.

Thanks in advance.

[0] https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.0/

Hello Kai,

I would try, so I start right now a Backup.

But I am not able to set any command decision by myself.

Therefore the only chance to setup is giving me
ready-to-use-command-lines that I paste into the terminal.

Could you help me with command lines, Kai?

Peter

Am 11.03.19 um 07:02 schrieb Kai-Heng Feng:
> Would it be possible for you to test the latest upstream kernel? Refer
> to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest
> v5.0 kernel [0].
>
> If this bug is fixed in the mainline kernel, please add the following
> tag 'kernel-fixed-upstream'.
>
> If the mainline kernel does not fix this bug, please add the tag:
> 'kernel-bug-exists-upstream'.
>
> Once testing of the upstream kernel is complete, please mark this bug as
> "Confirmed”, and attach dmesg.
>
> Thanks in advance.
>
> [0] https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.0/
>

Kai-Heng Feng (kaihengfeng) wrote :

Before trying mainline kernel, please remove "nomodeset" and test again.

kiewitt (p-thoms) wrote :

Hello,

this is an update of
excessive boot trials after Kernel-Update:
start time (round about)
3rd of April
5:45 fail
5:48 fail
5:51 fail
5:53 good
6:54 good
6: 33 fail
8:34 fail
8:36 fail
8:37 fail
8:39 fail
8:44 fail
8:45 good
9:29 good
10:17 good
11:14 fail
11:19 good
14:23 good
14:55 fail

kiewitt (p-thoms) wrote :

Most time when I see the Grub selection menue the boot sequence is ok.
In case of boot failing it seems that there will never be a grub menue.

kiewitt (p-thoms) wrote :

Hello,

I think the hanger has faded away.
Maybe the most inmpact faded away by deleting nomodeset.

So, my way from beginning:
- delete "quiet splash"
sudo nano /etc/default/grub
sudo update-grub

- Release Upgrade from Sylvia to Tessa
started Timeshift (System Restore Utility)
sudo apt-get install mintupgrade
mintupgrade check
mintupgrade download
mintupgrade upgrade

- boot without "nomodeset"
sudo nano /etc/default/grub
sudo update-grub

- Inbetween the Release-Upgrade the separated Microcode of the CPU were changed, I guess deleted

- The first "splash" offers some strange displayings, but they dont bother the boot sequence

Peter

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers