HDMI Audio failing after resuming from sleep

Bug #1809316 reported by Juan Martinez on 2018-12-20

This bug report will be marked for expiration in 56 days if no further activity occurs. (find out why)

18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

This issue occurs in both 16.04 and 18.04 on Dell Precision 7530

Before sleep, the sound settings show a single HDMI / Displayport "HDA NVidia" sound device (see attachment)

Afterwards, there are several 'copies' of this device (see attachment) - No sound comes out of any of the HDMI devices

Screen Captures + Logs included in .zip attached

Juan Martinez (cubislo) wrote :
Daniel van Vugt (vanvugt) wrote :
Download full text (3.8 KiB)

Your kernel log suggests the problem is originating in the kernel:

[ 277.166493] snd_hda_codec_hdmi hdaudioC1D0: out of range cmd 0:4:707:ffffffbf
[ 304.848228] snd_hda_codec_hdmi hdaudioC1D0: Unable to sync register 0x4f0100. -5
[ 304.848234] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 304.848237] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 304.848240] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 304.848242] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 304.848479] snd_hda_codec_hdmi hdaudioC1D0: out of range cmd 0:4:707:ffffffff
[ 304.860523] snd_hda_codec_hdmi hdaudioC1D0: out of range cmd 0:4:707:ffffffff
[ 305.156349] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 305.156358] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 305.156362] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 305.156367] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 305.476298] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 305.476306] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 305.476311] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 305.476316] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 305.796253] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 305.796262] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 305.796266] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 305.796271] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 306.116223] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 306.116231] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 306.116236] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 306.116241] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 306.436169] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 306.436172] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 306.436174] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 306.436175] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 306.756142] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 306.756151] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 306.756156] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 306.756160] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 307.076117] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 307.076125] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 307.076129] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 307.076134] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 307.396093] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 307.396102] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 307.396109] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 307.396115] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD buf size -1
[ 310.556670] snd_hda_codec_hdmi...

Read more...

affects: gnome-shell (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1809316

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

ProblemType: Bug
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
DistroRelease: Ubuntu 18.04
InstallationDate: Installed on 2019-01-03 (0 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 002: ID 04f3:25ec Elan Microelectronics Corp.
 Bus 001 Device 004: ID 1bcf:2b96 Sunplus Innovation Technology Inc.
 Bus 001 Device 003: ID 0a5c:5834 Broadcom Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. Precision 7530
NonfreeKernelModules: nvidia_modeset nvidia
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-43-generic root=UUID=89239537-83fb-4668-9120-bb13ce96bc1f ro quiet splash vt.handoff=1
ProcVersionSignature: Ubuntu 4.15.0-43.46-generic 4.15.18
PulseList:
 Error: command ['pacmd', 'list'] failed with exit code 1: Home directory not accessible: Permission denied
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-43-generic N/A
 linux-backports-modules-4.15.0-43-generic N/A
 linux-firmware 1.173.2
Tags: bionic
Uname: Linux 4.15.0-43-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

_MarkForUpload: True
dmi.bios.date: 09/10/2018
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.4.2
dmi.board.name: 03RV2M
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.4.2:bd09/10/2018:svnDellInc.:pnPrecision7530:pvr:rvnDellInc.:rn03RV2M:rvrA00:cvnDellInc.:ct10:cvr:
dmi.product.family: Precision
dmi.product.name: Precision 7530
dmi.sys.vendor: Dell Inc.

tags: added: apport-collected bionic

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Juan Martinez (cubislo) on 2019-01-07
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Kai-Heng Feng (kaihengfeng) wrote :

This should be solved by later kernel release. Does this issue still occur?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers