Initrd of pc-kernel snap contains out-of-date packages

Bug #1808768 reported by Robert Liu
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

The build script does not install package updates during generate the pc-kernel snap.

I met this bug #1783810 when I was verify my Ubuntu Core 18 image on KVM.
The system stuck at resizing the writable partition. the resize script of initrd called sgdisk to achieve the resizing. Inside sgdisk, it use libuuid1 to get random bytes and generate UUIDs. After I extracted the kernel snap, I found it is still using libuuid1 2.31.1-0.4ubuntu3 which is not the latest version. At this moment, Bionic has 2.31.1-0.4ubuntu3.2.
Then I added commands to make the build script installing package updates. After that, the system can boot correctly without any problem.

I am wondering if there is any concern to pull updates before building?

The attachment is my patch to pull updates.

Snippet of console output, before patch
[ 2.491404] usbcore: registered new interface driver usb-storage
[ 2.503788] sdhci: Secure Digital Host Controller Interface driver
[ 2.505627] sdhci: Copyright(c) Pierre Ossman
[ 2.548485] initrd: found more than 10% free space on disk, resizing /dev/sda3
[ 2.550345] initrd: partition to full disk size, see /dev/kmsg for details
[ 2.912472] clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0x255b2dea34c, max_idle_ns: 440795243480 ns
## several keystrokes here, or the boot process won't continue
[ 351.361426] random: crng init done
[ 351.423462] fixing backup GPT
[ 352.435735] systemd-udevd[240]: passed device to netlink monitor 0x55e45653e330
[ 352.443221] sda: sda1 sda2 sda3
[ 352.445486] The operation has completed successfully.

Snippet of console output, after patch
[ 2.548203] usbcore: registered new interface driver usb-storage
[ 2.561439] sdhci: Secure Digital Host Controller Interface driver
[ 2.562878] sdhci: Copyright(c) Pierre Ossman
[ 2.602093] initrd: found more than 10% free space on disk, resizing /dev/sda3
[ 2.603900] initrd: partition to full disk size, see /dev/kmsg for details
## block a few seconds, until timeout.
[ 2.912418] clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0x255b2dea34c, max_idle_ns: 440795243480 ns
[ 9.174552] random: fast init done
[ 9.179127] random: parted: uninitialized urandom read (16 bytes read)
[ 9.183726] random: parted: uninitialized urandom read (16 bytes read)
[ 9.190606] random: parted: uninitialized urandom read (16 bytes read)
[ 9.230419] fixing backup GPT
[ 9.236989] random: crng init done
[ 9.238102] random: 5 urandom warning(s) missed due to ratelimiting
[ 10.245047] systemd-udevd[259]: passed device to netlink monitor 0x56376c45b150
[ 10.253093] sda: sda1 sda2 sda3
[ 10.256202] The operation has completed successfully.

Revision history for this message
Robert Liu (robertliu) wrote :
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1808768

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Robert Liu (robertliu)
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Jesse Sung (wenchien)
tags: added: dawson originate-from-1808480
Revision history for this message
Stefan Bader (smb) wrote :

This bug report was made for tracking changes on how snaps are being produced. Unfortunately this is not reflecting well with Launchpad because the required changes had to be made in git trees which not directly map to a source package in Launchpad's mind.
I have applied the changes to both makefiles (xenial and bionic) so the next snaps being done should be fixed. But again there will not be an automatic state change on this bug report.

Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Jesse Sung (wenchien)
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in hwe-next:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments