Lenovo Ideapad 330 touchpad isn't being recognised by Ubuntu. To work I have to use an external mouse.

Bug #1808625 reported by Ankit Jee on 2018-12-15
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

My laptop is Lenovo Ideapad 330.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubuntu-release-upgrader-core 1:18.04.29
ProcVersionSignature: Ubuntu 4.15.0-42.45-generic 4.15.18
Uname: Linux 4.15.0-42-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: ubuntu:GNOME
Date: Sat Dec 15 17:13:44 2018
InstallationDate: Installed on 2018-12-11 (3 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_IN:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_IN
 SHELL=/bin/bash
SourcePackage: ubuntu-release-upgrader
Symptom: dist-upgrade
UpgradeStatus: No upgrade log present (probably fresh install)
---
ProblemType: Bug
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ankit 1270 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 18.04
InstallationDate: Installed on 2018-12-11 (5 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 174f:241a Syntek
 Bus 001 Device 002: ID 0cf3:e500 Atheros Communications, Inc.
 Bus 001 Device 004: ID 0000:3825
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: LENOVO 81DE
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-42-generic root=UUID=32510822-c7f5-4d12-bb6d-9457af6abf37 ro quiet splash vt.handoff=1
ProcVersionSignature: Ubuntu 4.15.0-42.45-generic 4.15.18
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-42-generic N/A
 linux-backports-modules-4.15.0-42-generic N/A
 linux-firmware 1.173.2
Tags: bionic
Uname: Linux 4.15.0-42-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 06/13/2018
dmi.bios.vendor: LENOVO
dmi.bios.version: 8TCN44WW
dmi.board.asset.tag: NO Asset Tag
dmi.board.name: LNVNB161216
dmi.board.vendor: LENOVO
dmi.board.version: SDK0Q55722 WIN
dmi.chassis.asset.tag: NO Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo ideapad 330-15IKB
dmi.modalias: dmi:bvnLENOVO:bvr8TCN44WW:bd06/13/2018:svnLENOVO:pn81DE:pvrLenovoideapad330-15IKB:rvnLENOVO:rnLNVNB161216:rvrSDK0Q55722WIN:cvnLENOVO:ct10:cvrLenovoideapad330-15IKB:
dmi.product.family: ideapad 330-15IKB
dmi.product.name: 81DE
dmi.product.version: Lenovo ideapad 330-15IKB
dmi.sys.vendor: LENOVO

Ankit Jee (ankitjee) wrote :
Juhani Numminen (jsonic) on 2018-12-15
affects: ubuntu-release-upgrader (Ubuntu) → xorg (Ubuntu)
summary: - Mouse pad of laptop isn't being recognised by Ubuntu. To work I have to
- use an external one.
+ Lenovo Ideapad 330 touchpad isn't being recognised by Ubuntu. To work I
+ have to use an external one.
affects: xorg (Ubuntu) → linux (Ubuntu)
summary: Lenovo Ideapad 330 touchpad isn't being recognised by Ubuntu. To work I
- have to use an external one.
+ have to use an external mouse.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1808625

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated
Ankit Jee (ankitjee) wrote : CRDA.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Kai-Heng Feng (kaihengfeng) wrote :

Should be fixed by this commit:

commit 938f45008d8bc391593c97508bc798cc95a52b9b
Author: Donald Shanty III <email address hidden>
Date: Wed Jul 4 15:50:47 2018 +0000

    Input: elan_i2c - add ACPI ID for lenovo ideapad 330

    This allows Elan driver to bind to the touchpad found in Lenovo Ideapad 330
    series laptops.

    Signed-off-by: Donald Shanty III <email address hidden>
    Cc: <email address hidden>
    Signed-off-by: Dmitry Torokhov <email address hidden>

Download full text (3.8 KiB)

 I didn't understood the solution you gave me. The input command you provided, where should it be entered ?
    On Tuesday, 18 December, 2018, 12:36:24 PM IST, Kai-Heng Feng <email address hidden> wrote:

 Should be fixed by this commit:

commit 938f45008d8bc391593c97508bc798cc95a52b9b
Author: Donald Shanty III <email address hidden>
Date:  Wed Jul 4 15:50:47 2018 +0000

    Input: elan_i2c - add ACPI ID for lenovo ideapad 330

    This allows Elan driver to bind to the touchpad found in Lenovo Ideapad 330
    series laptops.

    Signed-off-by: Donald Shanty III <email address hidden>
    Cc: <email address hidden>
    Signed-off-by: Dmitry Torokhov <email address hidden>

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1808625

Title:
  Lenovo Ideapad 330 touchpad isn't being recognised by Ubuntu. To work
  I have to use an external mouse.

Status in linux package in Ubuntu:
  Confirmed

Bug description:
  My laptop is Lenovo Ideapad 330.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: ubuntu-release-upgrader-core 1:18.04.29
  ProcVersionSignature: Ubuntu 4.15.0-42.45-generic 4.15.18
  Uname: Linux 4.15.0-42-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.5
  Architecture: amd64
  CrashDB: ubuntu
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Dec 15 17:13:44 2018
  InstallationDate: Installed on 2018-12-11 (3 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
  PackageArchitecture: all
  ProcEnviron:
  LANGUAGE=en_IN:en
  PATH=(custom, no user)
  XDG_RUNTIME_DIR=<set>
  LANG=en_IN
  SHELL=/bin/bash
  SourcePackage: ubuntu-release-upgrader
  Symptom: dist-upgrade
  UpgradeStatus: No upgrade log present (probably fresh install)
  ---
  ProblemType: Bug
  ApportVersion: 2.20.9-0ubuntu7.5
  Architecture: amd64
  AudioDevicesInUse:
  USER        PID ACCESS COMMAND
  /dev/snd/controlC0:  ankit      1270 F.... pulseaudio
  CurrentDesktop: ubuntu:GNOME
  DistroRelease: Ubuntu 18.04
  InstallationDate: Installed on 2018-12-11 (5 days ago)
  InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
  Lsusb:
  Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
  Bus 001 Device 003: ID 174f:241a Syntek
  Bus 001 Device 002: ID 0cf3:e500 Atheros Communications, Inc.
  Bus 001 Device 004: ID 0000:3825
  Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: LENOVO 81DE
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-42-generic root=UUID=32510822-c7f5-4d12-bb6d-9457af6abf37 ro quiet splash vt.handoff=1
  ProcVersionSignature: Ubuntu 4.15.0-42.45-generic 4.15.18
  RelatedPackageVersions:
  linux-restricted-modules-4.15.0-42-generic N/A
  linux-backports-modules-4.15.0-42-generic  N/A
  linux-firmware                            1.173.2
  Tags:  bionic
  Uname: Linux 4.15.0-42-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 06/13/2018
  dmi.bios.vendor: LENOVO
  dmi.bios...

Read more...

Kai-Heng Feng (kaihengfeng) wrote :

Should be solved in all Ubuntu kernels.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers