Touchpad not detected

Bug #1806695 reported by Dan Schwarz on 2018-12-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Laptop Model: Lenovo ideapad 330-15ARR
Model Name: 81D2

Ubuntu Version: 18.04 LTS
cat /proc/version_signature
Ubuntu 4.15.0-42.45-generic 4.15.18

The touchpad didn't worked from the beginning and seems to be not detected.
/proc/bus/input/devices doesn't show it.

Dmesg output:
~$ dmesg | grep -i i2c
[ 1.268675] i2c /dev entries driver
[ 1.454039] i2c_hid i2c-ELAN061E:00: i2c-ELAN061E:00 supply vdd not found, using dummy regulator

~$ dmesg | grep -i i8042
[ 0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-42-generic root=UUID=014f4a02-c22c-4497-beef-d038781a3158 ro quiet splash i8042.reset i8042.nomux=1 i8042.nopnp i8042.noloop vt.handoff=1
[ 0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-42-generic root=UUID=014f4a02-c22c-4497-beef-d038781a3158 ro quiet splash i8042.reset i8042.nomux=1 i8042.nopnp i8042.noloop vt.handoff=1
[ 1.252982] i8042: PNP detection disabled
[ 1.267585] serio: i8042 KBD port at 0x60,0x64 irq 1
[ 1.267589] serio: i8042 AUX port at 0x60,0x64 irq 12
[ 1.278595] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input3

and lspci -vnvn attached
---
ProblemType: Bug
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: rednblk 1643 F.... pulseaudio
 /dev/snd/controlC0: rednblk 1643 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 18.04
InstallationDate: Installed on 2018-12-03 (0 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
MachineType: LENOVO 81D2
Package: linux (not installed)
ProcFB: 0 amdgpudrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-42-generic root=UUID=014f4a02-c22c-4497-beef-d038781a3158 ro quiet splash i8042.nopnp vt.handoff=1
ProcVersionSignature: Ubuntu 4.15.0-42.45-generic 4.15.18
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-42-generic N/A
 linux-backports-modules-4.15.0-42-generic N/A
 linux-firmware 1.173.2
Tags: bionic
Uname: Linux 4.15.0-42-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 08/16/2018
dmi.bios.vendor: LENOVO
dmi.bios.version: 7VCN44WW
dmi.board.asset.tag: NO Asset Tag
dmi.board.name: LNVNB161216
dmi.board.vendor: LENOVO
dmi.board.version: SDK0E50510 NO DPK
dmi.chassis.asset.tag: NO Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo ideapad 330-15ARR
dmi.modalias: dmi:bvnLENOVO:bvr7VCN44WW:bd08/16/2018:svnLENOVO:pn81D2:pvrLenovoideapad330-15ARR:rvnLENOVO:rnLNVNB161216:rvrSDK0E50510NODPK:cvnLENOVO:ct10:cvrLenovoideapad330-15ARR:
dmi.product.family: ideapad 330-15ARR
dmi.product.name: 81D2
dmi.product.version: Lenovo ideapad 330-15ARR
dmi.sys.vendor: LENOVO

Dan Schwarz (rednblk) wrote :
description: updated

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1806695

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: bionic

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Dan Schwarz (rednblk) wrote :

this was fixed on 4.20

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers