ELANTECH touchpad detected as PS/2 Logitech Wheel Mouse on Compaq Presario 21-N1F3AR

Bug #1803474 reported by Florencia on 2018-11-15
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

Hello, I formerly had installed Ubuntu 18.04 with the same problem, my touchpad was detected as a generic PS2 mouse so I thought that if I upgraded my Ubuntu version (currently 18.10) my problem would be solved. I tried several fixes that I found on different forums with my previous version but they didn't work. I'm not an advanced user and I was looking forward to finally switch to linux but this is a big problem for me. I attached some files except cat /var/log/Xorg.0.log > Xorg.0.log

cat: /var/log/Xorg.0.log: No existe el archivo o el directorio (missing file or directory)

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: linux-image-4.18.0-11-generic 4.18.0-11.12
ProcVersionSignature: Ubuntu 4.18.0-11.12-generic 4.18.12
Uname: Linux 4.18.0-11-generic x86_64
ApportVersion: 2.20.10-0ubuntu13.1
Architecture: amd64
 /dev/snd/controlC0: flor 2769 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Wed Nov 14 22:27:10 2018
InstallationDate: Installed on 2018-11-10 (4 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 058f:3822 Alcor Micro Corp.
 Bus 001 Device 002: ID 8087:07dc Intel Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: COMPAQ Presario 21 VerK
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.18.0-11-generic root=UUID=39b22cde-4b65-4213-8812-e830a36afe55 ro quiet splash vt.handoff=1
 linux-restricted-modules-4.18.0-11-generic N/A
 linux-backports-modules-4.18.0-11-generic N/A
 linux-firmware 1.175
SourcePackage: linux
UpgradeStatus: Upgraded to cosmic on 2018-11-14 (0 days ago)
dmi.bios.date: 02/27/2016
dmi.bios.vendor: COMPAQ
dmi.bios.version: fd
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: K21
dmi.board.vendor: EA
dmi.board.version: Type2 - Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnCOMPAQ:bvrfd:bd02/27/2016:svnCOMPAQ:pnPresario21VerK:pvrTBDbyOEM:rvnEA:rnK21:rvrType2-BoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.family: Type1Family
dmi.product.name: Presario 21 VerK
dmi.product.sku: Type1Sku0
dmi.product.version: TBD by OEM
dmi.sys.vendor: COMPAQ

Florencia (flxren) wrote :
Florencia (flxren) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.20 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.20-rc2

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Florencia (flxren) wrote :

Hello, I am using Ubuntu Budgie (19.04) now and having the exact same problem. I stopped using the previous version because it was useless to me. Current kernel version is 5.1.0-050100rc6-generic

Changed in linux (Ubuntu):
status: Expired → Confirmed
Hui Wang (hui.wang) wrote :

There is some error during initialization in elantech driver.

[ 2.675983] psmouse serio2: elantech: assuming hardware version 3 (with firmware version 0x254f00)
[ 2.880105] psmouse serio2: elantech: elantech_send_cmd query 0x02 failed.
[ 2.880108] psmouse serio2: elantech: failed to query capabilities.

Florencia (flxren) wrote :

Thank you so much, it was as simple as adding GRUB_CMDLINE_LINUX="i8042.nomux=1 i8042.reset" on grub, updating and rebooting.

You-Sheng Yang (vicamo) wrote :

@flxren, I don't have the hardware so I didn't have a try on the viable solution. I thought it takes a dkms to fix? Could you also help comment some more detailed steps, so others' with the same hardware may have another reference?

Kai-Heng Feng (kaihengfeng) wrote :

Are both "i8042.nomux=1" "i8042.reset" required to make touchpad work, or just one of the parameter can make the touchpad work?

Brad Figg (brad-figg) on 2019-07-24
tags: added: cscc
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers