[drm:intel_display_resume [i915]] *ERROR* Restoring old state failed with -22

Bug #1802578 reported by Alexander Karlstad on 2018-11-09
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

This error appears in my journal quite often after resuming laptop from suspend and when un-docking the machine in the meantime.

When docked, I usually only enable two external displays. Un-docked I only have the built-in display on the laptop. This was working flawlessly in 18.04 but is extremely buggy now after having upgraded to 18.10 for some reason.

When this happens, my screen(s) remain pitch black. Switching to TTYs and back does not help. CTRL+ALT+F1 gives me the GDM login, but when entering password it seems it switches to TTY2 (or whatever is at CTRL+ALT+F2), and the screen(s) remain black.

Logging in in a TTY and trying to "DISPLAY=:0.0 gnome-shell --replace" does not help.

<super>+P does not work (is this shortcut combination removed?).

At last when I ran "xrandr --auto" the session I had crashed and I had to re-login, but at least this time I got my desktop.

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: linux-image-4.18.0-10-generic 4.18.0-10.11
ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
Uname: Linux 4.18.0-10-generic x86_64
ApportVersion: 2.20.10-0ubuntu13
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: alexander 23057 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
Date: Fri Nov 9 20:34:53 2018
HibernationDevice: RESUME=/swapfile
InstallationDate: Installed on 2018-05-02 (190 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
MachineType: LENOVO 20HN0013MX
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.18.0-10-generic root=/dev/mapper/ubuntu--vg-root ro quiet splash net.ifnames=0 vt.handoff=1
RelatedPackageVersions:
 linux-restricted-modules-4.18.0-10-generic N/A
 linux-backports-modules-4.18.0-10-generic N/A
 linux-firmware 1.175
SourcePackage: linux
UpgradeStatus: Upgraded to cosmic on 2018-11-01 (7 days ago)
dmi.bios.date: 09/14/2018
dmi.bios.vendor: LENOVO
dmi.bios.version: R0IET55W (1.33 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20HN0013MX
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40697 WIN
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrR0IET55W(1.33):bd09/14/2018:svnLENOVO:pn20HN0013MX:pvrThinkPadX270:rvnLENOVO:rn20HN0013MX:rvrSDK0J40697WIN:cvnLENOVO:ct10:cvrNone:
dmi.product.family: ThinkPad X270
dmi.product.name: 20HN0013MX
dmi.product.sku: LENOVO_MT_20HN_BU_Think_FM_ThinkPad X270
dmi.product.version: ThinkPad X270
dmi.sys.vendor: LENOVO

description: updated
description: updated

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

I am testing the latest mainline kernel now, version 4.19.0-041900-generic #201810221809.

Issue occurred again today, but I could not find the same error in the journal this time. Could perhaps be non-kernel related?

Changed in linux (Ubuntu):
importance: Undecided → Medium

Keeps happening, but it does appear to be docking station related. After getting some more errors today I got to Google and find that #1552040 might be the bug causing this with me. So perhaps a duplicate of that.

I can confirm that this is happening less frequent after applying workaround from bug 1552040.

Brad Figg (brad-figg) on 2019-07-24
tags: added: ubuntu-certified
tags: added: cscc
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers