realtek rtl8185 driver wont work I can't get online wireless

Bug #180240 reported by tony on 2008-01-04
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hal

I tried the ndiswrapper -utils and it did not work. system freezes up when I try to connect.
I did this,
installed from ubuntu cd ndiswrapper and ndiswrapper-common
copy driver from windows xp install CD
file wlandrv2.sys and rtl8029.sys and put them in a folder on the desktop and named it driver.
$ cd Desktop/Driver/
$ sudo ndiswrapper -i <wlandrv2.sys>.inf
$ sudo modprobe ndiswrapper

repeated last step with every session when it froze

then new terminal
$ sudo iwlist wlan0 scan
$ sudo iwconfig wlan0 channel (my-channel) essid (my-essid) mode (my-mode)
$ sudo ifup wlan0

when I did the scan it said no signal, lots of noise. so I don't think it worked.

I went on though and finished
installed wifi-radar
applications-internet-wifi-radar
opened it and clicked edit but couldn't edit
so I couldn't
enter # sudo modprobe ndiswrapper (with out #)
save and close

what did I do wrong?

ProblemType: Bug
Architecture: amd64
Date: Thu Jan 3 19:25:45 2008
DistroRelease: Ubuntu 7.10
Package: hal 0.5.9.1-6ubuntu5
PackageArchitecture: amd64
SourcePackage: hal
Uname: Linux tony-laptop 2.6.22-14-generic #1 SMP Tue Dec 18 05:28:27 UTC 2007 x86_64 GNU/Linux

tony (gillettetg) wrote :
Caroline Ford (secretlondon) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description didn't include enough information.

Please include the information requested at [WWW] https://wiki.ubuntu.com/DebuggingHardwareDetection as separate attachments.

Caroline Ford (secretlondon) wrote :

hal -> linux

Hi Tony,

I noticed you are running the 2.6.22 from Gutsy. The Hardy Heron Alpha series is currently under development and contains an updated version of the kernel. It would be helpful if you could test the latest Hardy Alpha release: http://www.ubuntu.com/testing . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. Thanks.

Changed in linux:
status: New → Incomplete

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

We are closing this bug report because it lacks the information we need
to investigate the problem, as described in the previous comments.
Please reopen it if you can give us the missing information, and don't
hesitate to submit bug reports in the future. To reopen the bug report
you can click on the current status, under the Status column, and change
the Status back to "New". Thanks again!

 status invalid
 assignee nobody

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkit554ACgkQ06FgkPZwicQT3wCfVM7L7F6Ujc7yDZZ6c0Giuqak
qzYAnRcNUm6G3ryllJXb0RZHjXV83np0
=XFP7
-----END PGP SIGNATURE-----

Changed in linux:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers