[ICL] Split Lock Disable

Bug #1801002 reported by quanxian on 2018-11-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
intel
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Description
Enable model specific feature that will cause an #AC exception to be issued instead of a split-lock cycle. This can be used by developers to identify any "split locks" in the code.

Complete list of commits:
147b502bda338f4f2dff19faaa5829b691305ea5 2238246ff8d533a5f2327d1f953375876d8a013c 6650cdd9a8ccf00555dbbe743d58541ad8feb6a7 a6a60741035bb48ca8d9f92a138958818148064c db8c33f8b5bea59d00ca12dcd6b65d01b1ea98ef dbaba47085b0c2aa793ce849750164bd3765e163 f11421ba4af706cb4f5703de34fa77fba8472776 f6a892ddd53e555362dbf64d31b47fde0f550ec4 3ab0762d1edfda6ccbc08f636acab42c103c299f 48fd5b5ee714714f4cf9f9e1cba3b49b1fd40ed6 8b9a18a9f2494144fe23fe630d0734310fa65301

Target Kernel: 5.7
Target Release: 20.10

quanxian (quanxian-wang) on 2018-11-01
information type: Public → Private
quanxian (quanxian-wang) on 2019-02-15
description: updated
quanxian (quanxian-wang) on 2019-05-06
description: updated
tags: added: intel-kernel-19.10
removed: intel-kernel-19.04
quanxian (quanxian-wang) on 2019-05-20
description: updated
quanxian (quanxian-wang) on 2019-10-23
description: updated
tags: added: intel-kernel-20.04
removed: intel-kernel-19.10
quanxian (quanxian-wang) on 2019-12-20
description: updated
quanxian (quanxian-wang) wrote :

147b502bda338f4f2dff19faaa5829b691305ea5 db8c33f8b5bea59d00ca12dcd6b65d01b1ea98ef f11421ba4af706cb4f5703de34fa77fba8472776 f6a892ddd53e555362dbf64d31b47fde0f550ec4

Changed in intel:
status: New → Fix Committed
quanxian (quanxian-wang) wrote :

+1 more
fdbfb51ae760d1bba3f89e4fa00da83016ec4dbe

quanxian (quanxian-wang) wrote :

Complete Lists of commits: v5.7
147b502bda338f4f2dff19faaa5829b691305ea5 2238246ff8d533a5f2327d1f953375876d8a013c 6650cdd9a8ccf00555dbbe743d58541ad8feb6a7 a6a60741035bb48ca8d9f92a138958818148064c db8c33f8b5bea59d00ca12dcd6b65d01b1ea98ef dbaba47085b0c2aa793ce849750164bd3765e163 f11421ba4af706cb4f5703de34fa77fba8472776 f6a892ddd53e555362dbf64d31b47fde0f550ec4 fdbfb51ae760d1bba3f89e4fa00da83016ec4dbe

description: updated
quanxian (quanxian-wang) wrote :

3 more
3ab0762d1edfda6ccbc08f636acab42c103c299f 48fd5b5ee714714f4cf9f9e1cba3b49b1fd40ed6 8b9a18a9f2494144fe23fe630d0734310fa65301

description: updated
quanxian (quanxian-wang) on 2020-05-13
description: updated
tags: added: intel-kernel-20.10
removed: intel-kernel-20.04
quanxian (quanxian-wang) on 2020-06-22
information type: Private → Public

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1801002

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: groovy
quanxian (quanxian-wang) on 2020-11-16
Changed in intel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers