Lenovo V130-14IGM: Touchpad not working due to missing ACPI in kernel

Bug #1789252 reported by mm on 2018-08-27
This bug affects 8 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

The kernel driver elan_i2c_core.c is missing the elan_acpi_id for the touchpad used in the Lenovo V130-14IGM laptop. The elan_acpi_id for the touchpad used in the Lenovo V130-14IGM is ELAN0615.
I got the touchpad working by building my own patched kernel with "{ "ELAN0615", 0 }," added in drivers/input/mouse/elan_i2c_core.c.
Though the touchpad is working properly since using the custom kernel, I get masses of the following kernel errors:
[ xxx.xxx ] elan_i2c i2c-ELAN0615:01: invalid report id data (ff)


Lenovo V130-14IGM


Ubuntu 18.04.1 x64 with standard kernel doesn't recognize the touchpad. With my custom kernel (currently Ubuntu mainline kernel v4.18-rc8) it is working with the mentioned kernel errors.

Can someone please commit the mentioned elan_acpi_id in the kernel?

mm (mtl-0) on 2018-08-27
tags: added: touch
tags: added: kernel-bug
removed: touch
j. william cupp (jwilliamcupp) wrote :

I have a brand new Lenovo 130-15IKB and have discovered the touchpad is ELAN0620:01. Seems like this whole line of touchpads needs to have support added in the kernel.

Hermann Lorenz (hermann53) wrote :

Please include the touchpad of Lenovo V130-14IGM in the kernel.
I hope for a quick solution, as this should not be a big thing.

Thanks to folks.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kernel-package (Ubuntu):
status: New → Confirmed
Kai W (kaiomatico) wrote :

I'm also affected and installing the latest mainline kernels somehow does not fix this issue. Can somebody please upload a self-compiled kernel? Thanks in advance.

Kevin Malon (kmalonbuk) wrote :

I habe the same problem. Bought a new laptop yesterday and can't use it good because of this bug. It is such a small change :( I tried to build a kernel on my one without success. My laptop shows me ELAN0618 when i type in "dmesg | grep -i elan".

It would be so nice if someone could fix this fast. Please developers. It is a one line change which helps so many people

Jeremias Kleer (jeremias.kleer) wrote :

I had the same problem with the Lenovo V130-14IGM: No touchpad functionality.
I tried with Ubuntu 18.10, compiling the kernel with mm's one-line-modification. Kernel 4.18... current one - I don't remember.
But back on 18.04, with my own kernel, it succeeded. Kernel 4.15.0-42.45.

At least I have touchpad for my new Laptop

Marco (koansoftware) wrote :

Same problem:
Ubuntu 18.04.1 x64 with standard kernel doesn't recognize the touchpad.
No touchpad functionality.

juliogilabert (juliogilabert) wrote :

I have the same problem with the touchpad of my lenovo v130-15ikb

According to commit on github, the elan0615 might be supported in kernel 5.1

Further the elan_isr interrupt service routine got modified. So maybe it is the end of "elan_i2c i2c-ELAN0615:01: invalid report id data (ff)"


mm (mtl-0) wrote :

The 5.1 mainline kernel basically works for me - "ELAN0615 was added, touchpad is working.

Sadly the kernel errors "[ xxx.xxx ] elan_i2c i2c-ELAN0615:01: invalid report id data (ff)" are still here and the suspend mode doesn't work for me (Lenovo V130-14IGM) on this kernel.

Leonardo Horovitz (lenilucho) wrote :

Same issue here, v130-14IGM and Ubuntu 19.04, the touchpad is not recognized and doesn't work.

Augusto (augusto1311) wrote :

Hi, I actualized my kernel to 5.1.3 and now the touchpad works! But still have problems with the suspend mode. I have a Lenovo v130-15IGM, Ubuntu 19.04 x64

On my Lenovo V130-14IGM with xubuntu 18.04 with custom kernel I CAN suspend.

2 observations/drawbacks with my laptop:
* after suspend, TYPED my password and logged in, no further key presses are recognized until I click with touchpad the xubuntu-menu
* very rarely the touchpad stops working, not recognizing anything. Then I have to reboot. Occured once in this month.

Juhani Numminen (jsonic) on 2020-03-17
affects: kernel-package (Ubuntu) → linux (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers