rtl8723be wifi does not work under linux-modules-extra-4.15.0-33-generic

Bug #1788997 reported by a on 2018-08-25
This bug affects 20 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

=== SRU Justification ===
Realtek 8723be's ant_sel parameter stops working since 4.15.0-33.36.

The commit that causes the regression works in mainline, so there are
some functional dependencies are not in 4.15.

Finding those dependencies can be hard since I don't have the hardware
to test with, also pulling new commits may cause new regression. So the
safest way to deal with this bug is to simply revert the regression

User confirmed reverting the commit can fix the issue.

[Regression Potential]
Low. Realtek 8723be works without this commit.

=== Original Bug Report ===
When starting Xubuntu 18.04.1 LTS on a laptop HP 1S-af023ng with kernel 4.15.0-32.35 amd64, wifi via rtl8723be works OK.

Using actual 4.15.0-33.36 amd64 instead, rtl8723be doesn't find any wifi networks and thus there is no connection. Changing the antenna setup in /etc/modprobe.d/rtl8723be_options.conf doesn't help either; as a workaround an external wifi device (Gigaset USB Adapter 108) works.

The expectation is that wifi through rtl8723be will still work under 4.15.0-33.36 as it did previously.
ProblemType: Bug
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
 /dev/snd/controlC1: al 1234 F.... pulseaudio
 /dev/snd/controlC0: al 1234 F.... pulseaudio
CurrentDesktop: XFCE
DistroRelease: Ubuntu 18.04
EcryptfsInUse: Yes
InstallationDate: Installed on 2018-05-27 (89 days ago)
InstallationMedia: Xubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
MachineType: Hewlett-Packard HP Notebook
Package: linux (not installed)
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-33-generic root=UUID=32ea87b7-f595-4137-a54b-55838586f720 ro quiet splash vt.handoff=1
ProcVersionSignature: Ubuntu 4.15.0-33.36-generic 4.15.18
 linux-restricted-modules-4.15.0-33-generic N/A
 linux-backports-modules-4.15.0-33-generic N/A
 linux-firmware 1.173.1
Tags: bionic
Uname: Linux 4.15.0-33-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 04/01/2015
dmi.bios.vendor: Insyde
dmi.bios.version: F.02
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 8137
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 99.02
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrF.02:bd04/01/2015:svnHewlett-Packard:pnHPNotebook:pvrType1ProductConfigId:rvnHewlett-Packard:rn8137:rvr99.02:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.family: 103C_5335KV G=N L=CON B=HP
dmi.product.name: HP Notebook
dmi.product.version: Type1ProductConfigId
dmi.sys.vendor: Hewlett-Packard

CVE References

Paul White (paulw2u) on 2018-08-25
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1788997

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
a (rqcv1762) wrote : AlsaInfo.txt

apport information

tags: added: apport-collected bionic
description: updated
a (rqcv1762) wrote : CRDA.txt

apport information

a (rqcv1762) wrote : CurrentDmesg.txt

apport information

a (rqcv1762) wrote : IwConfig.txt

apport information

a (rqcv1762) wrote : Lspci.txt

apport information

a (rqcv1762) wrote : Lsusb.txt

apport information

a (rqcv1762) wrote : ProcCpuinfo.txt

apport information

apport information

a (rqcv1762) wrote : ProcEnviron.txt

apport information

apport information

a (rqcv1762) wrote : ProcModules.txt

apport information

a (rqcv1762) wrote : PulseList.txt

apport information

a (rqcv1762) wrote : RfKill.txt

apport information

a (rqcv1762) wrote : UdevDb.txt

apport information

a (rqcv1762) wrote : WifiSyslog.txt

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
a (rqcv1762) wrote :

The above diagnosis was performed having started the computer with 4.15.0-33.36 amd64; as a result there was no network connection. To obtain network connection for submitting the data, a Gigaset USB Adapter 108 has been plugged in prior to running apport-collect 1788997.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
status: Incomplete → Triaged
Changed in linux (Ubuntu Bionic):
importance: Undecided → Medium
status: New → Triaged
Rene (gxrcr981) wrote :

I have hp-15-ac167nf with wireless chip rtl8723be and ubuntu xenial 16.04 LTS and HWE.

I got same issue: module rtl8723be option ant_sel=2 is not working anymore from kernel 4.15.0-33.

As a workaround I boot previous kernel 4.15.0-32 (from grub menu).
On same PC, I tried ubuntu bionic 18.04, and symptoms are exactly the same.

Heribert Heckhoff (hheckhoff) wrote :

Same story here with HP 17-y009ng, 16.04 worked like a charm, with ant_sel=2 ( after having had a hard time to find out that this option was a must).

Kernel worked as well after upgrade to 18.04-1.

No more wifi signal after update to kernel Tried all other module options but had no success.

Currently booting with kernel 4.15.0-32 ....

Changed in linux (Ubuntu):
status: Triaged → In Progress
Changed in linux (Ubuntu Bionic):
status: Triaged → In Progress
Changed in linux (Ubuntu):
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu Bionic):
assignee: nobody → Joseph Salisbury (jsalisbury)
Joseph Salisbury (jsalisbury) wrote :

I built a test kernel with a revert of commit af8a41cccf8f469165c6debc8fe07c5fd2ca501a. The test kernel can be downloaded from:

Can you test this kernel and see if it resolves this bug?

Note about installing test kernels:
* If the test kernel is prior to 4.15(Bionic) you need to install the linux-image and linux-image-extra .deb packages.
* If the test kernel is 4.15(Bionic) or newer, you need to install the linux-modules, linux-modules-extra and linux-image-unsigned .deb packages.

Thanks in advance!

a (rqcv1762) wrote :

Thx! With the test kernel from http://kernel.ubuntu.com/~jsalisbury/lp1788997 according to #21 wifi of the laptop HP 1S-af023ngof works again. So reverting commit af8a41cccf8f469165c6debc8fe07c5fd2ca501a seems to fix the bug.

Rene (gxrcr981) wrote :

I have difficulties trying your test kernel.
maybe because I use signed kernel with secure boot ?

In the instruction you talk about
linux-image and linux-image-extra .deb packages
linux-image-extra is not in folder.
image is unsigned, and do not install.

So I installed headers, modules, modules-extra.
rtl8723be do not load anymore (because not signed).

Could you confirm test procedure for 16.04 LT HWE with uefi secureboot ?
Thank you in advance.

Heribert Heckhoff (hheckhoff) wrote :

A new kernel update has been provided recently. This kernel doesn't work with / support rtl8723be either. It seems the fix has not been committed so far.

18.4.1 typically keeps two kernels, unless you modify /etc/kernel/postinst.d/apt-auto-removal, so to keep more kernels. Hence users that installed the latest kernel update will have not more kernel installed that supports rtl8723be !!

The changes, that were applied in, have completely broken all system with rtl8223be meanwhile, unless you've made changes to the system how it handles kernel updates.

So I think there is evidence to provide a kernel update including the fixes to support rtl8723be immediately.

- Heribert

Joseph Salisbury (jsalisbury) wrote :

I'll ping upstream and the author of the patch that was reverted. However, before doing so, we should test the latest mainline kernel to see if the bug is already fixed upstream.

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.19 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19-rc3

Heribert Heckhoff (hheckhoff) wrote :

I've tested with the kernel as recommended and suggest in #25. Wifi with rtl8723b3 works again (like a charm). However, ant_sel must be set to 1 (ant_sel=1) as opposed to kernel 4.15.0-32, which required ant_sel to be set to 2 (ant_sel=2). (e.g sudo modprobe rtl8723be ant_sel=1 vs. sudo modprobe rtl8723be ant_sel=2).

Heribert Heckhoff (hheckhoff) wrote :

I don't know how to add a tag to or mark this bug track. :-;

tags: added: kernel-fixed-upstream
Changed in linux (Ubuntu Bionic):
status: In Progress → Confirmed
Heribert Heckhoff (hheckhoff) wrote :

found how to set the tag and marked status as confirmed.

Joseph Salisbury (jsalisbury) wrote :

We can perform a "Reverse" bisect to identify the commit that fixes this bug in v4.19. We first need to identify the last bad kernel version and the first good kernel version.

Can you test the following kernels:
v4.16 Final: http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.16/
v4.17 Final: http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.17/
v4.18 Final: http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.18/
v4.19-rc1: http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19-rc1/

You don't have to test every kernel, just up until the first kernel that does not have the bug.

Thanks in advance!

Changed in linux (Ubuntu Bionic):
status: Confirmed → In Progress
Heribert Heckhoff (hheckhoff) wrote :

4.16 does not work at all.
4.17 and 4.18 work just fine.
Haven't tested 4.19-rc1 though anymore, as suggested.

Joseph Salisbury (jsalisbury) wrote :

We next need to identify which 4.17 release candidate introduced the fix. Can you next test the following kernels:

v4.17-rc1: http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.17-rc1
v4.17-rc4: http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.17-rc4
v4.17-rc7: http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.17-rc7

Like before, you don't have to test every kernel, just up until the first kernel that does not have the bug.

Thanks in advance!

Heribert Heckhoff (hheckhoff) wrote :

v4.17-rc4 just works fine.
v4.17-rc1 doesn't work at all (yields no , or a very, very weak signal).

I do not know Linux kernel process, but i would like to know if and when this fix will appear by defautl into Ubuntu doing a sudo apt upgrade ?
Thanks and sorry for such basic question.

Joseph Salisbury (jsalisbury) wrote :

@Stephane Potier, once we identify the fix, I will SRU it to the Ubuntu kernel. At that point, the fix will be applied for the following round of updates.

Heribert Heckhoff (hheckhoff) wrote :

neither rc2 or rc3 work at all...very low signal ...

Joseph Salisbury (jsalisbury) wrote :

Just to confirm, v4.17-rc4 works? I'll start a "Reverse" bisect between v4.17-rc3 and v4.17-rc4.

Joseph Salisbury (jsalisbury) wrote :

I think this commit should fix the bug:
af8a41cccf8f rtlwifi: cleanup 8723be ant_sel definition

However, this commit was added to Bionic in 4.15.0-33, which I believe you already tested. Can you test -proposed or newer than -33 to see if this bug is fixed? If not, there is only one other rtl commit in v4.17-rc4.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed.

Thank you in advance!

royden (ryts) wrote :

" Can you test -proposed or newer than -33 to see if this bug is fixed?"

Tested with 4.15.0-36 and -24 which was distributed a few days back - same problem as originally reported, with either ant_sel 1 or 2.

royden (ryts) wrote :

I meant to type "-34" and of course it was -36 that was released recently.

21 comments hidden view all 101 comments
royden (ryts) wrote :

Tested bionic-proposed kernel 4.15.0-38.41.

There now is no difference between ant_sel=0,1,or 2 BUT compared to 4.15.0-32 ant_sel=2, the reception is 70% as opposed to 100%.

Go figure :-)

dekl (dekl) wrote :

Sorry, but it seems the kernels 4.15.0-38 in bionic-updates and in bionic-proposed are the same. I have tested it already (#57), the bug is in place. I would be happy to help test other kernels.

Rene (gxrcr981) wrote :

I tested last proposed kernel 4.15.0-39, but the issue is still there, no signal with either no ant_sel, ant_sel=0, ant_sel=1 or ant_sel=2.
In my environment the last working kernel is 4.15.0-32 with ant_sel=2.

Rene (gxrcr981) wrote :

I also tested last kernel from mainline (following #25 & #26 ,just for confirmation...)
[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19
modinfo rtl8723be says:
filename: /lib/modules/4.19.0-041900-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723be/rtl8723be.ko
firmware: rtlwifi/rtl8723befw_36.bin
firmware: rtlwifi/rtl8723befw.bin
srcversion: CF0CBB2F4446A615D0ABCBE

similarily with comment #58 wifi works out of the box (no ant_sel)
it works also fine with ant_sel=0 (supposed to be equivalent)
it works also fine with ant_sel=1
does not work with ant_sel=2
like for comment #53, the working ant_sel changed compared to reference kernel 4.15.0-32

Heribert Heckhoff (hheckhoff) wrote :

I can confirm comment #65 :-)

fidel (akism89) wrote :

Works on 4.15.0-36 but not on 4.15.0-38...

spi (spi-gmxpro) wrote :

Still doesn't work in 4.15.0-42 either.

Changed in linux (Ubuntu Bionic):
status: In Progress → Confirmed
Changed in linux (Ubuntu):
status: In Progress → Confirmed
Changed in linux (Ubuntu Bionic):
assignee: Joseph Salisbury (jsalisbury) → nobody
Changed in linux (Ubuntu):
assignee: Joseph Salisbury (jsalisbury) → nobody
jack lemon (mb0087) wrote :

This problem still exists for me on debian testing with 4.19.0-1-amd64 #1 SMP Debian 4.19.12-1

Only if I put my laptop directly next to a device emitting a wifi network I am able to connect. Few meters away it already becomes unusable. ant_sel=1 makes it worse. ant_sel=2 not better.

Detailed information here:

Kai-Heng Feng (kaihengfeng) wrote :

Does reverting the simple commit help? If it helps then we should simply revert it.

The other route is to back port the functional changes this commit depends on, ranges from v4.15 to v4.17.

Heribert Heckhoff (hheckhoff) wrote :

well...this bug has been unresolved for more than 6 month meanwhile, which is pretty hard for me to understand. I think it is common understanding that the Linux community is fixing bugs more or less instantaneously, as opposed to Microsoft Windows. Reverting a code change is a no brainer, which leave the question why this bug is not fixed with a kernel update. Quite a few contributers, as well as myself, have tested kernels that fix the bug, let alone, that no "official" fix has been released meanwhile. This is pretty much frustrating.

I can as well not agree that breaking a functionality completely can be considered as "medium impact"..

I mean we started out with kernel 4.15 and we're at 4.20 / 5.0 meanwhile ...

Kai-Heng Feng (kaihengfeng) wrote :

AFAIU, mainline kernel works, but with different ant_sel value.
On currently Ubuntu kernel, it doesn't work at all, correct?

Heribert Heckhoff (hheckhoff) wrote :

well, I have not seen any "officially released" kernel beyond 4.15.0-32, that works .

royden (ryts) wrote :

I guess folk like myself who upgraded to Cosmic and 4.18 have a working wifi with ant_sel=1. Bionic has the problem, ironically given that it is LTS.

BTW, I suspect there are other issues with the rtl8723be under 4.18 - my connection stalls after a while, until modprobe -r && modprobe then all is well again

Kai-Heng Feng (kaihengfeng) wrote :

So for Bionic, the commit should be reverted.

Please test this kernel:

jack lemon (mb0087) wrote :

For me ant_sel=0 "zero!" was the magic key. Took me a week of messing around until I realized one cannot only select 1 or 2 but also 0. Try out with these:

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be ant_sel=0
iwlist scan | egrep -i 'ssid|quality'
sudo modprobe -r rtl8723be
sudo modprobe rtl8723be ant_sel=1
iwlist scan | egrep -i 'ssid|quality'
sudo modprobe -r rtl8723be
sudo modprobe rtl8723be ant_sel=2
iwlist scan | egrep -i 'ssid|quality'


Heribert Heckhoff (hheckhoff) wrote :

 kernel 4.15.0-46 works as good as -4.15.0-32, i.e. with the same setting (ant_sel=2 only)

Heribert Heckhoff (hheckhoff) wrote :

hmm, well...I'm not sure what happened...

the kernel created of the packages from https://people.canonical.com/~khfeng/lp1788997/ (post #75) just works great.

However, I run an update as well later this day and that included (supposingly) the very same packages. However the kernel generated from those packages does not work at all. Strange, as both kernel packages have the very same version number ...

The generated kernel files do as well differ ( first column as of #75, second column as of update )

initrd.img-4.15.0-46-generic /boot/initrd.img-4.15.0-46-generic differ: byte 5, line 1
System.map-4.15.0-46-generic /boot/System.map-4.15.0-46-generic differ: byte 11352, line 334
vmlinuz-4.15.0-46-generic /boot/vmlinuz-4.15.0-46-generic differ: byte 159, line 4

I guess it's normal that initrd.img differ, as there seems to be a time stamp at the beginning of the image ....

uname reveals for the kernel as of post #75 reveals:

Linux heri-hp-pc 4.15.0-46-generic #49 SMP Fri Mar 8 13:21:42 CST 2019 x86_64 x86_64 x86_64 GNU/Linux

uname for the kernel after the update reveals:

Linux heri-hp-pc 4.15.0-46-generic #49-Ubuntu SMP Wed Feb 6 09:33:07 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

pretty weird :-(

Kai-Heng Feng (kaihengfeng) wrote :

Sorry, I didn't bump the version number of the test kernel I built. I'll send a patch to revert the patch.

description: updated
Heribert Heckhoff (hheckhoff) wrote :

hmm, well, I had the test kernel as of #75 installed , which was overridden by a regular update today...and guess what, that kernel , as already mentioned in #78, does NOT work. So manual intervention is required to revert to the test kernel again. This is NOT very handy :-((

The expectation is that BIONIC should continue to fully support RTL8723b, which it doesn't meanwhile for more than 7 (in words SEVEN) month.

Kai-Heng Feng (kaihengfeng) wrote :

It'll be included in next kernel release.

Changed in linux (Ubuntu Bionic):
status: Confirmed → Fix Committed

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
Heribert Heckhoff (hheckhoff) wrote :

The Kernel modules as shown when -proposed is enabled DOES NOT solve the problem at all. The wifi signal is still extremely weak. Only the test kernel mention in #77 and #78 solves the problem.

It's as well somewhat weird, that the version number in proposed has not been bumped up, as promised in #79.

The documentation for enabling -proposed is, by the way, not 100% up-to-date, as bionic has a new development tab in software update's setting, where you have to enabled proposed.

tags: added: verification-failed-bionic
removed: verification-needed-bionic
Heribert Heckhoff (hheckhoff) wrote :

oh well, ....it seems to me that kernel versioning is pretty much messed up. The (test) kernel I had installed, as of #77 reports version 4.15.0-46 ( linux-unsigned, modules, modoles-extra). Software Updater reports the very same version numbers for those modules to be updated, independent from whether -proposed under the development tab in Software Updater is enabled or not !!

So either the kernel with the reverted code has not been checked in properly, or versioning is messed up or -proposed doesn't work properly ...

sigh ...

Kai-Heng Feng (kaihengfeng) wrote :

What's the version of the proposed kernel? It should be -48.

Heribert Heckhoff (hheckhoff) wrote :

this is what software updater reports:

Installed version: 4.15.0-46.49 (as of #77, which works)
Available version: 4.15.0-46.49 (does not work)

The available version is the VERY SAME, either with proposed enabled or disabled in software updater !!

Kai-Heng Feng (kaihengfeng) wrote :

Maybe the mirror is not in-sync? Please give another mirror a try.

Heribert Heckhoff (hheckhoff) wrote :

I'm downloading from archive.canonical.com/ubuntu ...but NOT from a mirror. The test kernel as of #77 is already at version 49 !, so how can a kernel in proposed be at version # 48.

That does seem to make any sense to me. Even if it where at version 48, the software updater would ignore it, as there is a more recent version, i.e. #49 , available.

uname -a yields ...Linux heri-hp-pc 4.15.0-46-generic #49 SMP Fri Mar 8 13:21:42 CST 2019 x86_64 x86_64 x86_64 GNU/Linux, i.e. that is the test kernel, which I have verified and as well in use for quite a while.

So, I claim again that there is a versioning issue or the reverted sources have not been checked in properly.

Kai-Heng Feng (kaihengfeng) wrote :

What's the output of `dpkg -l | grep linux-image` and `apt show linux-image-generic`?

Heribert Heckhoff (hheckhoff) wrote :

To repeat again: I have the kernel as of # 75 installed.

heri@heri-hp-pc:~$ dpkg -l | grep linux-image | grep 4.15
ii linux-image-4.15.0-32-generic 4.15.0-32.35 amd64 Signed kernel image generic
rc linux-image-4.15.0-34-generic 4.15.0-34.37 amd64 Signed kernel image generic
ii linux-image-unsigned-4.15.0-46-generic 4.15.0-46.49 amd64 Linux kernel image for version 4.15.0 on 64 bit x86 SMP

There are as well a pretty large number 4.4.* and 3.* images references, which I have omitted.

heri@heri-hp-pc:~$ apt -a show linux-image-generic
Package: linux-image-generic
Priority: optional
Section: kernel
Source: linux-meta
Origin: Ubuntu
Maintainer: Ubuntu Kernel Team <email address hidden>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 15,4 kB
Depends: linux-image-4.15.0-47-generic, linux-modules-extra-4.15.0-47-generic, linux-firmware, intel-microcode, amd64-microcode
Recommends: thermald
Supported: 5y
Download-Size: 2.412 B
APT-Sources: http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
Description: Generic Linux kernel image
 This package will always depend on the latest generic kernel image

Package: linux-image-generic
Priority: optional
Section: kernel
Source: linux-meta
Origin: Ubuntu
Maintainer: Ubuntu Kernel Team <email address hidden>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 14,3 kB
Depends: linux-image-4.15.0-20-generic, linux-modules-extra-4.15.0-20-generic, linux-firmware
Recommends: thermald
Breaks: flash-kernel (<< 3.90ubuntu2), s390-tools (<< 2.3.0-0ubuntu3)
Supported: 5y
Download-Size: 2.660 B
APT-Sources: http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
Description: Generic Linux kernel image
 This package will always depend on the latest generic kernel image

By the way https://wiki.ubuntu.com/Testing/EnableProposed is not up-to-date with respect to bionic, as there is no option to select pre-released updates under the "Updates" tab. One has to enable the option under the "development" tab.

Kai-Heng Feng (kaihengfeng) wrote :

On my system:
$ rmadison linux | grep bionic-proposed
 linux | 4.15.0-48.51 | bionic-proposed | source

$ apt show linux-generic
Package: linux-generic

So I think -proposed is not correctly enabled in /etc/apt/source.list.d. This can be a bug in the updater GUI.

Thees Flatow (fan80) wrote :

Suffering from weak rtl8723be wifi signal and new to proposed updates.

What I have done:

1. Make sure there are no more updates from non-propopsed sources (main, universe).
2. Enable proposed updates in GUI (this updates package list automatically).
3. back to command-line (just to feel safe): $ sudo apt-get update
4. $ sudo apt-get install linux-image-generic/bionic-proposed
5. $ sudo reboot

Weak signal! :-(

$ uname -a
Linux a12 4.15.0-48-generic #51-Ubuntu SMP Wed Apr 3 08:28:49 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
$ dpkg -l | grep linux-image
ii linux-image-4.15.0-20-generic 4.15.0-20.21 amd64 Signed kernel image generic
ii linux-image-4.15.0-47-generic 4.15.0-47.50 amd64 Signed kernel image generic
ii linux-image-4.15.0-48-generic 4.15.0-48.51 amd64 Signed kernel image generic
ii linux-image-generic amd64 Generic Linux kernel image

With ant_sel=2 I do get strong signal, though. But as that requires manual intervention ...

I cannot confirm this bug being solved with kernel in proposed updates.

Thees Flatow (fan80) wrote :

Just to avoid confusion:

I have enabled selective installation of packages from bionic-proposed as discussed in <https://wiki.ubuntu.com/Testing/EnableProposed>. I.e. there's a step missing:

2.5. Add file `/etc/apt/preferences.d/proposed-updates` with contents

Package: *
Pin: release a=bionic-proposed
Pin-Priority: 400

Heribert Heckhoff (hheckhoff) wrote :

Well, I have to stand corrected !

Thanks to the hints in #92/#93 I was able to have the proposed kernel installed.

I have removed the test kernel as of #75 as a prerequisite first !!

I have as well used the apt command as opposed to the Software Updater UI.

Linux heri-hp-pc 4.15.0-48-generic #51-Ubuntu SMP Wed Apr 3 08:28:49 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

heri@heri-hp-pc:~$ dpkg -l | grep linux-image | grep 4.15
ii linux-image-4.15.0-32-generic 4.15.0-32.35 amd64 Signed kernel image generic
rc linux-image-4.15.0-34-generic 4.15.0-34.37 amd64 Signed kernel image generic
ii linux-image-4.15.0-48-generic 4.15.0-48.51 amd64 Signed kernel image generic
ii linux-image-generic amd64 Generic Linux kernel image

I have the hunch that the Software Updater UI got confused, because test kernel as of #75 was an **unsigned** kernel, as opposed to the kernel from proposed, which is a **signed** kernel.

Anyhow, I consider the problem as resolved, as the proposed kernel works as good as 4.15.0-32, which only showed a reasonable WIFI signal with ant_sel=2.

So changing tag to verification-done-bionic.

tags: added: verification-done-bionic
removed: verification-failed-bionic
Matthias Homann (palto) wrote :

I installed the proposed kernel and the fix works in principle, but in the manual selection the numbering seems swapped. On my HP 250 the antenna cable is connected to connector #1 (label printed on the WiFi module) but in the kernel module I have to select antenna #2 for a good signal.
Anyhow, this is juts a cosmetic issue for me, thanks for the fix :)

Launchpad Janitor (janitor) wrote :
Download full text (14.6 KiB)

This bug was fixed in the package linux - 4.15.0-48.51

linux (4.15.0-48.51) bionic; urgency=medium

  * linux: 4.15.0-48.51 -proposed tracker (LP: #1822820)

  * Packaging resync (LP: #1786013)
    - [Packaging] update helper scripts
    - [Packaging] resync retpoline extraction

  * 3b080b2564287be91605bfd1d5ee985696e61d3c in ubuntu_btrfs_kernel_fixes
    triggers system hang on i386 (LP: #1812845)
    - btrfs: raid56: properly unmap parity page in finish_parity_scrub()

  * [P9][LTCTest][Opal][FW910] cpupower monitor shows multiple stop Idle_Stats
    (LP: #1719545)
    - cpupower : Fix header name to read idle state name

  * [amdgpu] screen corruption when using touchpad (LP: #1818617)
    - drm/amdgpu/gmc: steal the appropriate amount of vram for fw hand-over (v3)
    - drm/amdgpu: Free VGA stolen memory as soon as possible.

  * [SRU][B/C/OEM]IOMMU: add kernel dma protection (LP: #1820153)
    - ACPICA: AML parser: attempt to continue loading table after error
    - ACPI / property: Allow multiple property compatible _DSD entries
    - PCI / ACPI: Identify untrusted PCI devices
    - iommu/vt-d: Force IOMMU on for platform opt in hint
    - iommu/vt-d: Do not enable ATS for untrusted devices
    - thunderbolt: Export IOMMU based DMA protection support to userspace
    - iommu/vt-d: Disable ATS support on untrusted devices

  * Add basic support to NVLink2 passthrough (LP: #1819989)
    - powerpc/powernv/npu: Do not try invalidating 32bit table when 64bit table is
    - powerpc/powernv: call OPAL_QUIESCE before OPAL_SIGNAL_SYSTEM_RESET
    - powerpc/powernv: Export opal_check_token symbol
    - powerpc/powernv: Make possible for user to force a full ipl cec reboot
    - powerpc/powernv/idoa: Remove unnecessary pcidev from pci_dn
    - powerpc/powernv: Move npu struct from pnv_phb to pci_controller
    - powerpc/powernv/npu: Move OPAL calls away from context manipulation
    - powerpc/pseries/iommu: Use memory@ nodes in max RAM address calculation
    - powerpc/pseries/npu: Enable platform support
    - powerpc/pseries: Remove IOMMU API support for non-LPAR systems
    - powerpc/powernv/npu: Check mmio_atsd array bounds when populating
    - powerpc/powernv/npu: Fault user page into the hypervisor's pagetable

  * Huawei Hi1822 NIC has poor performance (LP: #1820187)
    - net-next: hinic: fix a problem in free_tx_poll()
    - hinic: remove ndo_poll_controller
    - net-next/hinic: add checksum offload and TSO support
    - hinic: Fix l4_type parameter in hinic_task_set_tunnel_l4
    - net-next/hinic:replace multiply and division operators
    - net-next/hinic:add rx checksum offload for HiNIC
    - net-next/hinic:fix a bug in set mac address
    - net-next/hinic: fix a bug in rx data flow
    - net: hinic: fix null pointer dereference on pointer hwdev
    - hinic: optmize rx refill buffer mechanism
    - net-next/hinic:add shutdown callback
    - net-next/hinic: replace disable_irq_nosync/enable_irq

  * [CONFIG] please enable highdpi font FONT_TER16x32 (LP: #1819881)
    - Fonts: New Terminus large console font
    - [Config]: enable highdpi Terminus 16x32 font support

  * [19.04 FEAT] qeth: Enhanced link...

Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) on 2019-07-24
tags: added: cscc
Noname (anonymous.noname) wrote :

doesn't work on 4.15.0-55

Noname (anonymous.noname) wrote :

doesn't work on 4.15.0-55

$ lsmod|grep 8723
rtl8723be 126976 0
btcoexist 434176 1 rtl8723be
rtl8723_common 24576 1 rtl8723be
rtl_pci 32768 1 rtl8723be
rtlwifi 163840 4 rtl_pci,rtl8723be,btcoexist,rtl8723_common
mac80211 790528 3 rtl_pci,rtl8723be,rtlwifi

$ modinfo rtl8723be -V
kmod version 24

~/rtlwifi_new$ uname -a
Linux laptop 4.15.0-55-lowlatency #60-Ubuntu SMP PREEMPT Tue Jul 2 19:11:22 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Noname (anonymous.noname) wrote :

sudo modprobe -rvf rtl8723be
rmmod rtl8723be
rmmod rtl_pci
rmmod rtl8723_common
rmmod btcoexist
rmmod rtlwifi
rmmod mac80211
rmmod cfg80211

sudo modprobe -v rtl8723be -b
insmod /lib/modules/4.15.0-55-lowlatency/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/4.15.0-55-lowlatency/kernel/net/mac80211/mac80211.ko
insmod /lib/modules/4.15.0-55-lowlatency/kernel/drivers/net/wireless/realtek/rtlwifi/rtlwifi.ko
insmod /lib/modules/4.15.0-55-lowlatency/kernel/drivers/net/wireless/realtek/rtlwifi/rtl_pci.ko
insmod /lib/modules/4.15.0-55-lowlatency/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723com/rtl8723-common.ko
insmod /lib/modules/4.15.0-55-lowlatency/kernel/drivers/net/wireless/realtek/rtlwifi/btcoexist/btcoexist.ko
insmod /lib/modules/4.15.0-55-lowlatency/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723be/rtl8723be.ko fwlps=0 ant_sel=2

Noname (anonymous.noname) wrote :

sorry,reinstalling the kernel package helped

Luke Tynan (luketyn) wrote :

apport-collect 1788997

Displaying first 40 and last 40 comments. View all 101 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers