psmouse: after sleep/suspend thinkpad touchpad not functional

Bug #1788928 reported by Joshua Powers on 2018-08-24
This bug report is a duplicate of:  Bug #1786574: remove i2c-i801 from blacklist. Edit Remove
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

The touchpad after sleep/suspend of my ThinkPad X1 will not function correctly.

Expected Behavior:
After sleep/suspend scroll works correctly.

Actual Behavior:
Unable to scroll or correctly click on a window and move it without reloading the driver

Steps to reproduce:
1. Install Bionic on Thinkpad X1 (4.15.0-32-generic)
2. Open something to scroll (e.g. browser, terminal, etc.)
3. Close lid
4. Re-open lid once sleeping/suspended
5. Try to scroll and note that it does not work

Run the following after re-opening the lid
$ sudo modprobe psmouse -r; sudo modprobe psmouse

dmesg on reload:
[12753.847050] psmouse serio1: synaptics: queried max coordinates: x [..5676], y [..4758]
[12753.879362] psmouse serio1: synaptics: queried min coordinates: x [1266..], y [1096..]
[12753.879375] psmouse serio1: synaptics: Trying to set up SMBus access
[12753.882246] psmouse serio1: synaptics: SMbus companion is not ready yet
[12753.944774] psmouse serio1: synaptics: Touchpad model: 1, fw: 8.1, id: 0x1e2b1, caps: 0xf003a3/0x943300/0x12e800/0x10000, board id: 3072, fw id: 1795685
[12753.944791] psmouse serio1: synaptics: serio: Synaptics pass-through port at isa0060/serio1/input0
[12753.985102] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input24
[12754.619594] psmouse serio5: trackpoint: IBM TrackPoint firmware: 0x0e, buttons: 3/3
[12754.823238] input: TPPS/2 IBM TrackPoint as /devices/platform/i8042/serio1/serio5/input/input25
ProblemType: Bug
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
 /dev/snd/controlC1: powersj 2506 F.... pulseaudio
 /dev/snd/controlC0: powersj 2506 F.... pulseaudio
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 18.04
HibernationDevice: RESUME=UUID=40a4eb28-4454-44f0-a377-ea611ce685bb
InstallationDate: Installed on 2018-02-19 (185 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180214)
 Bus 001 Device 002: ID 8087:8001 Intel Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 002 Device 002: ID 04f2:b45d Chicony Electronics Co., Ltd
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: LENOVO 20BSCTO1WW
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
Package: linux (not installed)
 PATH=(custom, no user)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.15.0-32-generic root=/dev/mapper/ubuntu--vg-root ro
ProcVersionSignature: Ubuntu 4.15.0-32.35-generic 4.15.18
 linux-restricted-modules-4.15.0-32-generic N/A
 linux-backports-modules-4.15.0-32-generic N/A
 linux-firmware 1.173.1
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Tags: bionic
Uname: Linux 4.15.0-32-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip docker kvm libvirt lpadmin lxd plugdev sambashare sudo
_MarkForUpload: True 09/13/2017
dmi.bios.vendor: LENOVO
dmi.bios.version: N14ET42W (1.20 )
dmi.board.asset.tag: Not Available 20BSCTO1WW
dmi.board.vendor: LENOVO
dmi.board.version: SDK0E50512 STD
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrN14ET42W(1.20):bd09/13/2017:svnLENOVO:pn20BSCTO1WW:pvrThinkPadX1Carbon3rd:rvnLENOVO:rn20BSCTO1WW:rvrSDK0E50512STD:cvnLENOVO:ct10:cvrNone: ThinkPad X1 Carbon 3rd 20BSCTO1WW
dmi.product.version: ThinkPad X1 Carbon 3rd
dmi.sys.vendor: LENOVO

apport information

tags: added: apport-collected bionic
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Did this issue start happening after an update/upgrade? Was there a prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer to . Please test the latest v4.18 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.


Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in linux (Ubuntu Bionic):
importance: Undecided → Medium
status: New → Confirmed
tags: added: kernel-da-key

Added kernel-bug-exists-upstream as this occurs on 4.18.3-041803-generic.

> Did this issue start happening after an update/upgrade?

> Was there a prior kernel version where you were not having this particular problem?
On Bionic, I think I have always had this issue

tags: added: kernel-bug-exists-upstream
Anthony Wong (anthonywong) wrote :

Do you have "blacklist i2c_i801" in /etc/modprobe.d/blacklist.conf? If so could you remove the line, reboot and test again? Post dmesg if anything is not working well.

Kai-Heng Feng (kaihengfeng) wrote :

Please try kernel parameter "psmouse.synaptics_intertouch=0".

Joshua Powers (powersj) wrote :

> Do you have "blacklist i2c_i801" in /etc/modprobe.d/blacklist.conf?

Yes it was there. I commented it out, rebooted, and tried the test again. Afterwards there were no issues \o/ I repeated the test again and it continued to work as expected.

> Please try kernel parameter "psmouse.synaptics_intertouch=0".

I re-blacklisted the i2c_i801 module above, added the parameter to /etc/default/grub, and regenerated my grub. After reboot I ran the test again and there were no issues. I again repeated the test and it continued to work as expected.

Anthony Wong (anthonywong) wrote :

Thanks for the testing! We have another bug to remove i2c_i801 from blacklist.conf, so I will set this bug as a duplicate.

bill (bill-zannoni) wrote :

I've recently installed Ubuntu 18.04.01 on a Lenovo S540 laptop (full disk installation).
I have the kernel 4.15.0-43-generic and I had the same problem.
In my /etc/modprobe.d/blacklist.conf there was not module "i2c_i801" blacklisted, but still the touchpad would be inactive after a wake-up from suspension and it would come back after a restart.

Adding the parameter "psmouse.synaptics_intertouch=0" to grub solved the issue.

Mathias (gnillev) wrote :

Commenting to help others: I'm on Ubuntu 18.10 on a Lenovo L540 laptop and had the same problem.
I didn't have i2c_i801 in my blacklist either, but still the touchpad would be unresponsive after suspend (so not a duplicate of #1786574).

Adding "psmouse.synaptics_intertouch=0" to GRUB_CMDLINE_LINUX in /etc/default/grub seems to have solved it for me as well.

Brad Figg (brad-figg) on 2019-07-24
tags: added: cscc
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers