System takes long time to read device via Thunderbolt 3 port

Bug #1788567 reported by AceLan Kao on 2018-08-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
Undecided
AceLan Kao
Bionic
Undecided
Unassigned

Bug Description

[Impact]
On Dell XPS 13 with Dell TB16 docking station, sometimes the devices on docking station do not show up or takes couple minutes to be recognized.

[Fix]
This issue doesn't exist in 4.16 vanilla kernel, and after bisected the kernel and found below commit fixes this issue.
   cc5db3150e87 net: qcom/emac: Use proper free methods during TX
Applied this commit on top of Bionic 4.15 kernel and confirmed it works.

[Regression Potential]
Low, this commit is more like a patch fixes a bug which has been introduced since the driver was created. It aligns the dma_map and dma_unmap methods which might cause issue in some cases.

AceLan Kao (acelankao) wrote :

commit cc5db3150e87fe7f7e947bf333b6c1c97f848ecb
Author: Hemanth Puranik <email address hidden>
Date: Tue Mar 6 08:18:06 2018 +0530

    net: qcom/emac: Use proper free methods during TX

    This patch fixes the warning messages/call traces seen if DMA debug is
    enabled, In case of fragmented skb's memory was allocated using
    dma_map_page but freed using dma_unmap_single. This patch modifies buffer
    allocations in TX path to use dma_map_page in all the places and
    dma_unmap_page while freeing the buffers.

    Signed-off-by: Hemanth Puranik <email address hidden>
    Acked-by: Timur Tabi <email address hidden>
    Signed-off-by: David S. Miller <email address hidden>

summary: - System take long time to read device via Thunderbolt 3 port
+ System takea long time to read device via Thunderbolt 3 port
summary: - System takea long time to read device via Thunderbolt 3 port
+ System takes long time to read device via Thunderbolt 3 port
tags: added: originate-from-1786753 somerville
AceLan Kao (acelankao) wrote :

This commit has been included in 4.15.0-1018.21 and 4.15.0-34.37

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Changed in hwe-next:
status: New → Fix Released
Changed in linux (Ubuntu Bionic):
status: New → Fix Released
Brad Figg (brad-figg) on 2019-07-24
tags: added: cscc
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers