bind03 in ubuntu_ltp_syscalls failed with X/B

Bug #1788351 reported by Po-Hsu Lin on 2018-08-22
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Nominated for Bionic by Po-Hsu Lin
Nominated for Xenial by Po-Hsu Lin

Bug Description

This is a new test. It has passed on Trusty but failed on X/B (I guess in C as well)

<<<test_start>>>
tag=bind03 stime=1534863126
cmdline="bind03"
contacts=""
analysis=exit
<<<test_output>>>
tst_test.c:1017: INFO: Timeout per run is 0h 05m 00s
bind03.c:48: FAIL: expected EINVAL: EADDRINUSE

Summary:
passed 0
failed 1
skipped 0
warnings 0
<<<execution_status>>>
initiation_status="ok"
duration=0 termination_type=exited termination_id=1 corefile=no
cutime=0 cstime=0
<<<test_end>>>

From the commit message of this test:
    With 0fb44559ffd6 ("af_unix: move unix_mknod() out of bindlock")
    the behavior of bind() for STREAM UNIX sockets changed in
    case a socket that is already bound is passed to bind() again.

    This testcase fails for the new behavior and passes for the
    old one.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-4.4.0-1032-kvm 4.4.0-1032.38
ProcVersionSignature: User Name 4.4.0-1032.38-kvm 4.4.140
Uname: Linux 4.4.0-1032-kvm x86_64
ApportVersion: 2.20.1-0ubuntu2.18
Architecture: amd64
Date: Wed Aug 22 07:33:43 2018
SourcePackage: linux-kvm
UpgradeStatus: No upgrade log present (probably fresh install)

Po-Hsu Lin (cypressyew) wrote :
affects: linux-kvm (Ubuntu) → linux (Ubuntu)
description: updated
tags: added: bionic

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1788351

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Po-Hsu Lin (cypressyew) wrote :

It seems that this issue has been addressed in commit:
https://github.com/linux-test-project/ltp/commit/21c27c11c3f2ded30b718ae3ec7a5b8763abf201

Will need to verify these across different kernels.

Po-Hsu Lin (cypressyew) wrote :

Passed on Bionic GCP.

Po-Hsu Lin (cypressyew) wrote :

Still failing with 4.4.0-1068.78 AWS Xenial

Po-Hsu Lin (cypressyew) wrote :

Passed with Bionic-KVM, Bionic
Failed with Xenial-KVM, Xenial

I will update the title.

summary: - bind03 in ubuntu_ltp_syscalls failed with X/B
+ bind03 in ubuntu_ltp_syscalls failed with X
Changed in ubuntu-kernel-tests:
status: New → Confirmed
Sean Feole (sfeole) wrote :

Test is Failing on Bionic-AMD64, Bionic.

1145. 08/29 13:00:20 DEBUG| utils:0153| [stdout] tag=bind03 stime=1535547620
1146. 08/29 13:00:20 DEBUG| utils:0153| [stdout] cmdline="bind03"
1147. 08/29 13:00:20 DEBUG| utils:0153| [stdout] contacts=""
1148. 08/29 13:00:20 DEBUG| utils:0153| [stdout] analysis=exit
1149. 08/29 13:00:20 DEBUG| utils:0153| [stdout] <<>>
1150. 08/29 13:00:20 DEBUG| utils:0153| [stdout] tst_test.c:1017: INFO: Timeout per run is 0h 05m 00s
1151. 08/29 13:00:20 DEBUG| utils:0153| [stdout] bind03.c:48: FAIL: expected EINVAL: EADDRINUSE
1152. 08/29 13:00:20 DEBUG| utils:0153| [stdout]
1153. 08/29 13:00:20 DEBUG| utils:0153| [stdout] Summary:
1154. 08/29 13:00:20 DEBUG| utils:0153| [stdout] passed 0
1155. 08/29 13:00:20 DEBUG| utils:0153| [stdout] failed 1
1156. 08/29 13:00:20 DEBUG| utils:0153| [stdout] skipped 0
1157. 08/29 13:00:20 DEBUG| utils:0153| [stdout] warnings 0
1158. 08/29 13:00:20 DEBUG| utils:0153| [stdout] <<>>

summary: - bind03 in ubuntu_ltp_syscalls failed with X
+ bind03 in ubuntu_ltp_syscalls failed with X/B
Po-Hsu Lin (cypressyew) wrote :

I saw this one passed with AMD64 / ARM64 / i386 / P8 / s390x Bionic in this cycle (4.15.0-38.41-generic)

bind03.c:81: PASS: bind() failed with EADDRINUSE as expected

Po-Hsu Lin (cypressyew) wrote :

Didn't see this in X-HWE-EDGE as well.

Po-Hsu Lin (cypressyew) wrote :

Didn't see this in T-AWS (4.4) this cycle, with the updated ubuntu_ltp_syscall fix

Po-Hsu Lin (cypressyew) wrote :

To comment #5, passed with 4.4.0-1073.83 AWS

Po-Hsu Lin (cypressyew) wrote :

Test passed with 4.15.0-42.45-generic and 4.4.0-140.166 - generic
Mark this as Fix released.

Please open a new bug if you have encounter any.

Changed in ubuntu-kernel-tests:
status: Confirmed → Fix Released
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers